aboutsummaryrefslogtreecommitdiff
path: root/net/grive2
diff options
context:
space:
mode:
authorCarlos J. Puga Medina <cpm@FreeBSD.org>2018-04-23 21:32:53 +0000
committerCarlos J. Puga Medina <cpm@FreeBSD.org>2018-04-23 21:32:53 +0000
commit626593acd8e1eef8ea8df2fe7de841ce750f3a9d (patch)
treebe4b52c8aa6bcb956d4caa3eb6a0e9c2fca30149 /net/grive2
parent4f8f6415e250e259ecb1bb551ff1b9b919280a2f (diff)
downloadports-626593acd8e1eef8ea8df2fe7de841ce750f3a9d.tar.gz
ports-626593acd8e1eef8ea8df2fe7de841ce750f3a9d.zip
Notes
Diffstat (limited to 'net/grive2')
-rw-r--r--net/grive2/Makefile6
-rw-r--r--net/grive2/distinfo6
-rw-r--r--net/grive2/files/patch-libgrive_src_util_OS.hh13
3 files changed, 18 insertions, 7 deletions
diff --git a/net/grive2/Makefile b/net/grive2/Makefile
index 04c6aebb693e..a2723507380f 100644
--- a/net/grive2/Makefile
+++ b/net/grive2/Makefile
@@ -2,9 +2,8 @@
# $FreeBSD$
PORTNAME= grive2
-PORTVERSION= 0.5.0
DISTVERSIONPREFIX= v
-PORTREVISION= 7
+DISTVERSION= 0.5.1-dev
CATEGORIES= net
MAINTAINER= cpm@FreeBSD.org
@@ -20,12 +19,11 @@ LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
libgpg-error.so:security/libgpg-error \
libyajl.so:devel/yajl
-CONFLICTS_INSTALL= grive-[0-9]*
-
USES= cmake localbase pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= vitalif
+GH_TAGNAME= 11a3d78
PLIST_FILES= bin/grive \
man/man1/grive.1.gz
diff --git a/net/grive2/distinfo b/net/grive2/distinfo
index 22491f4ed072..f140084fcd31 100644
--- a/net/grive2/distinfo
+++ b/net/grive2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1472387091
-SHA256 (vitalif-grive2-v0.5.0_GH0.tar.gz) = 24641ef4802eb93bb55e7069bca55c4fb8aa17fd88833b9c89a1b2ee7d266567
-SIZE (vitalif-grive2-v0.5.0_GH0.tar.gz) = 162886
+TIMESTAMP = 1524507398
+SHA256 (vitalif-grive2-v0.5.1-dev-11a3d78_GH0.tar.gz) = b073ae8a7b18c259d577741476d5bedcd66ccfcf3a4677f8cbab7f5bd5515b2e
+SIZE (vitalif-grive2-v0.5.1-dev-11a3d78_GH0.tar.gz) = 161620
diff --git a/net/grive2/files/patch-libgrive_src_util_OS.hh b/net/grive2/files/patch-libgrive_src_util_OS.hh
new file mode 100644
index 000000000000..c17d59d494b4
--- /dev/null
+++ b/net/grive2/files/patch-libgrive_src_util_OS.hh
@@ -0,0 +1,13 @@
+--- libgrive/src/util/OS.hh.orig 2018-04-23 17:00:17 UTC
++++ libgrive/src/util/OS.hh
+@@ -24,6 +24,10 @@
+
+ #include <string>
+
++#if defined(__FreeBSD__)
++#define off64_t off_t
++#endif
++
+ namespace gr {
+
+ class DateTime ;