aboutsummaryrefslogtreecommitdiff
path: root/net/grive
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2014-08-20 15:46:05 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2014-08-20 15:46:05 +0000
commit123425fce59999f5bae1c1c70579f927db136c12 (patch)
tree9a4554b0cdb34a33f2fbc43d9eac828c20acfefd /net/grive
parentdea396af635e57fe3886fd04662d3708923e3e96 (diff)
downloadports-123425fce59999f5bae1c1c70579f927db136c12.tar.gz
ports-123425fce59999f5bae1c1c70579f927db136c12.zip
Notes
Diffstat (limited to 'net/grive')
-rw-r--r--net/grive/Makefile2
-rw-r--r--net/grive/files/patch-cmake__Modules__FindJSONC.cmake11
-rw-r--r--net/grive/files/patch-libgrive__src__protocol__Json.cc13
3 files changed, 25 insertions, 1 deletions
diff --git a/net/grive/Makefile b/net/grive/Makefile
index 8c95865073c0..1a8f35d1dc75 100644
--- a/net/grive/Makefile
+++ b/net/grive/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= libboost_filesystem.so:${PORTSDIR}/devel/boost-libs \
libcurl.so:${PORTSDIR}/ftp/curl \
libexpat.so:${PORTSDIR}/textproc/expat2 \
libgcrypt.so:${PORTSDIR}/security/libgcrypt \
- libjson.so:${PORTSDIR}/devel/json-c \
+ libjson-c.so:${PORTSDIR}/devel/json-c \
libyajl.so:${PORTSDIR}/devel/yajl
USE_GITHUB= yes
diff --git a/net/grive/files/patch-cmake__Modules__FindJSONC.cmake b/net/grive/files/patch-cmake__Modules__FindJSONC.cmake
new file mode 100644
index 000000000000..28c90d5b6faf
--- /dev/null
+++ b/net/grive/files/patch-cmake__Modules__FindJSONC.cmake
@@ -0,0 +1,11 @@
+--- ./cmake/Modules/FindJSONC.cmake.orig 2014-08-20 11:43:11.000000000 -0400
++++ ./cmake/Modules/FindJSONC.cmake 2014-08-20 11:43:25.000000000 -0400
+@@ -6,7 +6,7 @@
+ # JSONC_INCLUDE_DIR - The JSON-C include directory.
+ # JSONC_LIBRARY - The JSON-C library to link against.
+
+-FIND_PATH(JSONC_INCLUDE_DIR json/json.h)
++FIND_PATH(JSONC_INCLUDE_DIR json-c/json.h)
+ FIND_LIBRARY(JSONC_LIBRARY NAMES json)
+
+ IF (JSONC_INCLUDE_DIR AND JSONC_LIBRARY)
diff --git a/net/grive/files/patch-libgrive__src__protocol__Json.cc b/net/grive/files/patch-libgrive__src__protocol__Json.cc
new file mode 100644
index 000000000000..f2f23127bf22
--- /dev/null
+++ b/net/grive/files/patch-libgrive__src__protocol__Json.cc
@@ -0,0 +1,13 @@
+--- ./libgrive/src/protocol/Json.cc.orig 2014-08-20 11:44:51.000000000 -0400
++++ ./libgrive/src/protocol/Json.cc 2014-08-20 11:45:03.000000000 -0400
+@@ -29,8 +29,8 @@
+ #pragma warning(push)
+ #pragma warning(disable: 4005)
+ #endif
+-#include <json/json_tokener.h>
+-#include <json/linkhash.h>
++#include <json-c/json_tokener.h>
++#include <json-c/linkhash.h>
+ #ifdef _MSC_VER
+ #pragma warning(pop)
+ #endif