aboutsummaryrefslogtreecommitdiff
path: root/net/grpcui/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-10-03 02:43:10 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-10-03 02:55:50 +0000
commit956556b2692e8d0136ca30db36d8d8c5fd89deb3 (patch)
tree5ab2bd6ce0100141736374d5da721d59d3cb0f1c /net/grpcui/Makefile
parent53f62aa34707d8b65111b779e37542cfd3bc3d20 (diff)
downloadports-956556b2692e8d0136ca30db36d8d8c5fd89deb3.tar.gz
ports-956556b2692e8d0136ca30db36d8d8c5fd89deb3.zip
Diffstat (limited to 'net/grpcui/Makefile')
-rw-r--r--net/grpcui/Makefile29
1 files changed, 3 insertions, 26 deletions
diff --git a/net/grpcui/Makefile b/net/grpcui/Makefile
index 5da3e1665fb3..cf0305fbcf2f 100644
--- a/net/grpcui/Makefile
+++ b/net/grpcui/Makefile
@@ -1,7 +1,6 @@
PORTNAME= grpcui
DISTVERSIONPREFIX= v
-DISTVERSION= 1.3.1
-PORTREVISION= 11
+DISTVERSION= 1.3.2
CATEGORIES= net www
MAINTAINER= yuri@FreeBSD.org
@@ -12,30 +11,8 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= go:modules
-USE_GITHUB= yes
-GH_ACCOUNT= fullstorydev
-GH_SUBDIR= src/github.com/fullstorydev/grpcui
-GH_TUPLE= \
- census-instrumentation:opencensus-proto:v0.2.1:census_instrumentation_opencensus_proto/vendor/github.com/census-instrumentation/opencensus-proto \
- cespare:xxhash:v2.1.1:cespare_xxhash_v2/vendor/github.com/cespare/xxhash/v2 \
- cncf:udpa:04548b0d99d4:cncf_udpa_go/vendor/github.com/cncf/udpa \
- cncf:xds:cb28da3451f1:cncf_xds_go/vendor/github.com/cncf/xds \
- envoyproxy:go-control-plane:cf90f659a021:envoyproxy_go_control_plane/vendor/github.com/envoyproxy/go-control-plane \
- envoyproxy:protoc-gen-validate:v0.1.0:envoyproxy_protoc_gen_validate/vendor/github.com/envoyproxy/protoc-gen-validate \
- fullstorydev:grpcurl:v1.8.6:fullstorydev_grpcurl/vendor/github.com/fullstorydev/grpcurl \
- golang:appengine:v1.6.5:golang_appengine/vendor/google.golang.org/appengine \
- golang:crypto:75b288015ac9:golang_crypto/vendor/golang.org/x/crypto \
- golang:net:c89045814202:golang_net/vendor/golang.org/x/net \
- golang:oauth2:bf48bf16ab8d:golang_oauth2/vendor/golang.org/x/oauth2 \
- golang:protobuf:v1.5.2:golang_protobuf/vendor/github.com/golang/protobuf \
- golang:sys:v0.6.0:golang_sys/vendor/golang.org/x/sys \
- golang:text:v0.3.7:golang_text/vendor/golang.org/x/text \
- google:go-genproto:cb27e3aa2013:google_go_genproto/vendor/google.golang.org/genproto \
- googleapis:google-cloud-go:v0.56.0:googleapis_google_cloud_go/vendor/cloud.google.com/go \
- grpc:grpc-go:011544f72939:grpc_grpc_go/vendor/google.golang.org/grpc \
- jhump:protoreflect:v1.12.0:jhump_protoreflect/vendor/github.com/jhump/protoreflect \
- pkg:browser:0a3d74bf9ce4:pkg_browser/vendor/github.com/pkg/browser \
- protocolbuffers:protobuf-go:v1.28.0:protocolbuffers_protobuf_go/vendor/google.golang.org/protobuf
+
+GO_MODULE= github.com/fullstorydev/grpcui
GO_TARGET= ./cmd/${PORTNAME}
PLIST_FILES= bin/${PORTNAME}