aboutsummaryrefslogtreecommitdiff
path: root/net/gscloud/Makefile
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2020-09-09 18:22:00 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2020-09-09 18:22:00 +0000
commit3a4a513bc4b70f26fcd254119929133bb6a1bde8 (patch)
treec06a11b02249f121d66a4580e5489eb9c1298694 /net/gscloud/Makefile
parent2c870d595389dff2c17913380ff595f503edc930 (diff)
downloadports-3a4a513bc4b70f26fcd254119929133bb6a1bde8.tar.gz
ports-3a4a513bc4b70f26fcd254119929133bb6a1bde8.zip
Notes
Diffstat (limited to 'net/gscloud/Makefile')
-rw-r--r--net/gscloud/Makefile54
1 files changed, 52 insertions, 2 deletions
diff --git a/net/gscloud/Makefile b/net/gscloud/Makefile
index 7ed2e1eb3184..d96b13542091 100644
--- a/net/gscloud/Makefile
+++ b/net/gscloud/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= gscloud
-DISTVERSION= g20200504
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.4.0
CATEGORIES= net devel
MAINTAINER= egypcio@FreeBSD.org
@@ -14,10 +15,59 @@ USES= go:modules
USE_GITHUB= yes
GH_ACCOUNT= gridscale
-GH_TAGNAME= 3705cba
+GH_TUPLE= cpuguy83:go-md2man:v2.0.0:cpuguy83_go_md2man_v2/vendor/github.com/cpuguy83/go-md2man/v2 \
+ davecgh:go-spew:v1.1.1:davecgh_go_spew/vendor/github.com/davecgh/go-spew \
+ fsnotify:fsnotify:v1.4.7:fsnotify_fsnotify/vendor/github.com/fsnotify/fsnotify \
+ go-inf:inf:v0.9.1:go_inf_inf/vendor/gopkg.in/inf.v0 \
+ go-ini:ini:v1.51.0:go_ini_ini/vendor/gopkg.in/ini.v1 \
+ go-yaml:yaml:9f266ea9e77c:go_yaml_yaml_1/vendor/gopkg.in/yaml.v3 \
+ go-yaml:yaml:v2.3.0:go_yaml_yaml/vendor/gopkg.in/yaml.v2 \
+ gogo:protobuf:65acae22fc9d:gogo_protobuf/vendor/github.com/gogo/protobuf \
+ golang:appengine:v1.6.1:golang_appengine/vendor/google.golang.org/appengine \
+ golang:crypto:5c40567a22f8:golang_crypto/vendor/golang.org/x/crypto \
+ golang:net:e086a090c8fd:golang_net/vendor/golang.org/x/net \
+ golang:oauth2:0f29369cfe45:golang_oauth2/vendor/golang.org/x/oauth2 \
+ golang:protobuf:v1.3.2:golang_protobuf/vendor/github.com/golang/protobuf \
+ golang:sys:85ca7c5b95cd:golang_sys/vendor/golang.org/x/sys \
+ golang:text:v0.3.2:golang_text/vendor/golang.org/x/text \
+ golang:time:9d24e82272b4:golang_time/vendor/golang.org/x/time \
+ google:gofuzz:v1.0.0:google_gofuzz/vendor/github.com/google/gofuzz \
+ google:uuid:v1.1.1:google_uuid/vendor/github.com/google/uuid \
+ gridscale:gsclient-go:v3.2.0:gridscale_gsclient_go_v3/vendor/github.com/gridscale/gsclient-go/v3 \
+ hashicorp:hcl:v1.0.0:hashicorp_hcl/vendor/github.com/hashicorp/hcl \
+ imdario:mergo:v0.3.9:imdario_mergo/vendor/github.com/imdario/mergo \
+ inconshreveable:mousetrap:v1.0.0:inconshreveable_mousetrap/vendor/github.com/inconshreveable/mousetrap \
+ json-iterator:go:v1.1.9:json_iterator_go/vendor/github.com/json-iterator/go \
+ kardianos:osext:2bc1f35cddc0:kardianos_osext/vendor/github.com/kardianos/osext \
+ kirsle:configdir:e45d2f54772f:kirsle_configdir/vendor/github.com/kirsle/configdir \
+ konsorten:go-windows-terminal-sequences:v1.0.1:konsorten_go_windows_terminal_sequences/vendor/github.com/konsorten/go-windows-terminal-sequences \
+ kubernetes-sigs:yaml:v1.1.0:kubernetes_sigs_yaml/vendor/sigs.k8s.io/yaml \
+ kubernetes:apimachinery:62598f38f24e:kubernetes_apimachinery/vendor/k8s.io/apimachinery \
+ kubernetes:client-go:fdb3fbe99e1d:kubernetes_client_go/vendor/k8s.io/client-go \
+ kubernetes:klog:v1.0.0:kubernetes_klog/vendor/k8s.io/klog \
+ kubernetes:utils:69764acb6e8e:kubernetes_utils/vendor/k8s.io/utils \
+ magiconair:properties:v1.8.1:magiconair_properties/vendor/github.com/magiconair/properties \
+ mattn:go-runewidth:v0.0.9:mattn_go_runewidth/vendor/github.com/mattn/go-runewidth \
+ mitchellh:mapstructure:v1.1.2:mitchellh_mapstructure/vendor/github.com/mitchellh/mapstructure \
+ modern-go:concurrent:bacd9c7ef1dd:modern_go_concurrent/vendor/github.com/modern-go/concurrent \
+ modern-go:reflect2:v1.0.1:modern_go_reflect2/vendor/github.com/modern-go/reflect2 \
+ pelletier:go-toml:v1.2.0:pelletier_go_toml/vendor/github.com/pelletier/go-toml \
+ pmezard:go-difflib:v1.0.0:pmezard_go_difflib/vendor/github.com/pmezard/go-difflib \
+ russross:blackfriday:v2.0.1:russross_blackfriday_v2/vendor/github.com/russross/blackfriday/v2 \
+ shurcooL:sanitized_anchor_name:v1.0.0:shurcool_sanitized_anchor_name/vendor/github.com/shurcooL/sanitized_anchor_name \
+ sirupsen:logrus:v1.4.2:sirupsen_logrus/vendor/github.com/sirupsen/logrus \
+ spf13:afero:v1.2.2:spf13_afero/vendor/github.com/spf13/afero \
+ spf13:cast:v1.3.0:spf13_cast/vendor/github.com/spf13/cast \
+ spf13:cobra:v1.0.0:spf13_cobra/vendor/github.com/spf13/cobra \
+ spf13:jwalterweatherman:v1.0.0:spf13_jwalterweatherman/vendor/github.com/spf13/jwalterweatherman \
+ spf13:pflag:v1.0.3:spf13_pflag/vendor/github.com/spf13/pflag \
+ spf13:viper:v1.7.0:spf13_viper/vendor/github.com/spf13/viper \
+ stretchr:testify:v1.6.1:stretchr_testify/vendor/github.com/stretchr/testify \
+ subosito:gotenv:v1.2.0:subosito_gotenv/vendor/github.com/subosito/gotenv
GO_PKGNAME= github.com/gridscale/gscloud/cmd
GO_TARGET= .
+CGO_ENABLED= 0
PLIST_FILES= bin/${PORTNAME}