aboutsummaryrefslogtreecommitdiff
path: root/net/gscloud/Makefile
diff options
context:
space:
mode:
authorVinícius Zavam <egypcio@FreeBSD.org>2020-05-21 20:26:36 +0000
committerVinícius Zavam <egypcio@FreeBSD.org>2020-05-21 20:26:36 +0000
commitcdf4f0f7180fbc02458c168064b82a80c43d22ba (patch)
treea42ef350d621a5c069c5e6a540b763a1c2d490e4 /net/gscloud/Makefile
parentf9444ecef8b0dc9db0c63ef042412d226c481826 (diff)
downloadports-cdf4f0f7180fbc02458c168064b82a80c43d22ba.tar.gz
ports-cdf4f0f7180fbc02458c168064b82a80c43d22ba.zip
Notes
Diffstat (limited to 'net/gscloud/Makefile')
-rw-r--r--net/gscloud/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/net/gscloud/Makefile b/net/gscloud/Makefile
new file mode 100644
index 000000000000..7ed2e1eb3184
--- /dev/null
+++ b/net/gscloud/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= gscloud
+DISTVERSION= g20200504
+CATEGORIES= net devel
+
+MAINTAINER= egypcio@FreeBSD.org
+COMMENT= Official command-line interface for gridscale's API written in Go
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= gridscale
+GH_TAGNAME= 3705cba
+
+GO_PKGNAME= github.com/gridscale/gscloud/cmd
+GO_TARGET= .
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>