aboutsummaryrefslogtreecommitdiff
path: root/net/gsk/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-01-12 16:47:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-01-12 16:47:34 +0000
commit105058a5cbb40b32b4703aa4efc165df0c0ea1a7 (patch)
treefb519b38b234703f9c0c8ef91dc942ea4e600d40 /net/gsk/Makefile
parent4646ae3211b641736657585f880790ec5f77ce7f (diff)
downloadports-105058a5cbb40b32b4703aa4efc165df0c0ea1a7.tar.gz
ports-105058a5cbb40b32b4703aa4efc165df0c0ea1a7.zip
Notes
Diffstat (limited to 'net/gsk/Makefile')
-rw-r--r--net/gsk/Makefile27
1 files changed, 17 insertions, 10 deletions
diff --git a/net/gsk/Makefile b/net/gsk/Makefile
index 63a429ea7351..5054a8798665 100644
--- a/net/gsk/Makefile
+++ b/net/gsk/Makefile
@@ -1,28 +1,28 @@
-# ex:ts=8
# New ports collection makefile for: gsk
-# Date created: May 1, 2001
-# Whom: ijliao
+# Date created: May 1, 2001
+# Whom: ijliao
#
# $FreeBSD$
#
PORTNAME= gsk
-PORTVERSION= 1.0.13
-PORTREVISION= 1
+PORTVERSION= 1.0.17
CATEGORIES= net devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= babak@farrokhi.net
COMMENT= A C library for writing servers
USE_GNOME= glib20 gnomehack gnometarget
USE_REINPLACE= yes
-USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
-CONFIGURE_ARGS= --disable-gtk-doc
INSTALLS_SHLIB= yes
+CONFIGURE_ARGS+= --disable-gtk-doc
+
+PORTDOCS= *
+
.if defined(WITHOUT_OPENSSL)
CONFIGURE_ARGS+= --disable-ssl
PLIST_SUB+= OPENSSL="@comment "
@@ -32,7 +32,14 @@ PLIST_SUB+= OPENSSL=""
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- '/^SUBDIRS =/s|programs tests||g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|^\(HTML_DIR\).*|\1 = ${PREFIX}/share/doc|' \
+ ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s|programs tests||' \
+ ${WRKSRC}/src/Makefile.in
+
+.if defined(NOPORTDOCS)
+ @${REINPLACE_CMD} -e 's|^\(SUBDIRS = \).*|\1 src|' \
+ ${WRKSRC}/Makefile.in
+.endif
.include <bsd.port.mk>