aboutsummaryrefslogtreecommitdiff
path: root/net/gsk
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-01 17:29:30 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-01 17:29:30 +0000
commit79360788dff8416175028b234e778b7fc82c7b06 (patch)
treeb86c6160a8cebfcb7fe885b36e793ecaa6cd3605 /net/gsk
parent70ab50b499bb8a19e39147625e96927c17590fc8 (diff)
downloadports-79360788dff8416175028b234e778b7fc82c7b06.tar.gz
ports-79360788dff8416175028b234e778b7fc82c7b06.zip
Notes
Diffstat (limited to 'net/gsk')
-rw-r--r--net/gsk/Makefile28
-rw-r--r--net/gsk/distinfo1
-rw-r--r--net/gsk/files/patch-demos::small-webserver::Makefile.in11
-rw-r--r--net/gsk/pkg-comment1
-rw-r--r--net/gsk/pkg-descr4
-rw-r--r--net/gsk/pkg-plist107
6 files changed, 152 insertions, 0 deletions
diff --git a/net/gsk/Makefile b/net/gsk/Makefile
new file mode 100644
index 000000000000..5158cde52223
--- /dev/null
+++ b/net/gsk/Makefile
@@ -0,0 +1,28 @@
+# ex:ts=8
+# New ports collection makefile for: gsk
+# Date created: May 1, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gsk
+PORTVERSION= 0.3.0
+CATEGORIES= net devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ijliao@FreeBSD.org
+
+.if !defined(WITHOUT_OPENSSL)
+USE_OPENSSL= yes
+CONFIGURE_ARGS= --enable-ssl
+.endif
+
+USE_GLIB= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.mk>
diff --git a/net/gsk/distinfo b/net/gsk/distinfo
new file mode 100644
index 000000000000..757497cc2e43
--- /dev/null
+++ b/net/gsk/distinfo
@@ -0,0 +1 @@
+MD5 (gsk-0.3.0.tar.gz) = 5d55d3302184c5e777618604664f5bfe
diff --git a/net/gsk/files/patch-demos::small-webserver::Makefile.in b/net/gsk/files/patch-demos::small-webserver::Makefile.in
new file mode 100644
index 000000000000..c83eb739623d
--- /dev/null
+++ b/net/gsk/files/patch-demos::small-webserver::Makefile.in
@@ -0,0 +1,11 @@
+--- demos/small-webserver/Makefile.in.orig Tue May 1 23:34:38 2001
++++ demos/small-webserver/Makefile.in Tue May 1 23:34:52 2001
+@@ -95,7 +95,7 @@
+ debug_suffix = @debug_suffix@
+ INCLUDES = -I$(top_srcdir)/include @GSK_CFLAGS@ @GSK_LIB_CFLAGS@
+
+-misc_gsk_ld_add = ../../src/libgsk$(debug_suffix).la ../../src/protocols/libgsk-protocol$(debug_suffix).la ../../src/xml/libgsk-xml$(debug_suffix).la ../../src/xml/libgsk-server$(debug_suffix).la @GSK_LIBS@ ../../src/gtk/libgsk-minigtk$(debug_suffix).la -lgthread
++misc_gsk_ld_add = ../../src/libgsk$(debug_suffix).la ../../src/protocols/libgsk-protocol$(debug_suffix).la ../../src/xml/libgsk-xml$(debug_suffix).la ../../src/xml/libgsk-server$(debug_suffix).la @GSK_LIBS@ ../../src/gtk/libgsk-minigtk$(debug_suffix).la
+
+
+ gsksmallhttpserver_LDADD = $(misc_gsk_ld_add)
diff --git a/net/gsk/pkg-comment b/net/gsk/pkg-comment
new file mode 100644
index 000000000000..d9e21d18bf27
--- /dev/null
+++ b/net/gsk/pkg-comment
@@ -0,0 +1 @@
+A C library for writing servers
diff --git a/net/gsk/pkg-descr b/net/gsk/pkg-descr
new file mode 100644
index 000000000000..daf6e2f0ce4b
--- /dev/null
+++ b/net/gsk/pkg-descr
@@ -0,0 +1,4 @@
+GSK is a C library for writing servers. It is designed for writing servers
+where everything happens in a single thread.
+
+WWW: http://gsk.sourceforge.net/
diff --git a/net/gsk/pkg-plist b/net/gsk/pkg-plist
new file mode 100644
index 000000000000..89c3076d13b7
--- /dev/null
+++ b/net/gsk/pkg-plist
@@ -0,0 +1,107 @@
+bin/gsk-config
+bin/gsk-make-iface-macros
+bin/gsk-make-memchunk
+bin/gsk-skeleton
+bin/gsk-skeleton-data-scan
+include/gsk/gskactor.h
+include/gsk/gskactorbuffered.h
+include/gsk/gskactorcli.h
+include/gsk/gskactordatagramsocket.h
+include/gsk/gskactorlistener.h
+include/gsk/gskactorparser.h
+include/gsk/gskactorstreamsocket.h
+include/gsk/gskactorudp.h
+include/gsk/gskarrayedarg.h
+include/gsk/gskbasic.h
+include/gsk/gskbuffer.h
+include/gsk/gskbufferiterator.h
+include/gsk/gskconfig.h
+include/gsk/gskconstraint.h
+include/gsk/gskdaemonize.h
+include/gsk/gskdaemonsettings.h
+include/gsk/gskdatagramsocket.h
+include/gsk/gskdebug.h
+include/gsk/gskdebugoptions.h
+include/gsk/gskgtk.h
+include/gsk/gskinterface.h
+include/gsk/gsklog.h
+include/gsk/gskmain.h
+include/gsk/gskmainloop.h
+include/gsk/gskmainloopdevpoll.h
+include/gsk/gskmainloopkqueue.h
+include/gsk/gskmainlooppoll.h
+include/gsk/gskmainlooppollbase.h
+include/gsk/gskmainloopselect.h
+include/gsk/gsknetworkinterface.h
+include/gsk/gsksocket.h
+include/gsk/gsksocketaddress.h
+include/gsk/gsksocketlistener.h
+include/gsk/gsksocketlocation.h
+include/gsk/gsksocketudp.h
+include/gsk/gskstreamsocket.h
+include/gsk/gskstringify.h
+include/gsk/gskthreadpool.h
+include/gsk/gskutil.h
+include/gsk/gskvalidator.h
+include/gsk/gtk/gtkarg.h
+include/gsk/gtk/gtkdebug.h
+include/gsk/gtk/gtkenums.h
+include/gsk/gtk/gtkmarshal.h
+include/gsk/gtk/gtkobject.h
+include/gsk/gtk/gtksignal.h
+include/gsk/gtk/gtktypebuiltins.h
+include/gsk/gtk/gtktypeutils.h
+include/gsk/gtk/makeenums.h
+include/gsk/gtkreflection.h
+include/gsk/protocols/gskbase64.h
+include/gsk/protocols/gskdate.h
+include/gsk/protocols/gskdns.h
+include/gsk/protocols/gskdnscache.h
+include/gsk/protocols/gskdnsimplementations.h
+include/gsk/protocols/gskdnsinterfaces.h
+include/gsk/protocols/gskdnsrrcache.h
+include/gsk/protocols/gskhttpclient.h
+include/gsk/protocols/gskhttpcommon.h
+include/gsk/protocols/gskhttpheader.h
+include/gsk/protocols/gskhttpserver.h
+include/gsk/protocols/gskhttpservlet.h
+include/gsk/protocols/gskresolver.h
+include/gsk/protocols/gsksimpleproxy.h
+include/gsk/protocols/gsksimpleproxylistener.h
+include/gsk/protocols/gskurl.h
+include/gsk/protocols/gskurldownload.h
+include/gsk/protocols/gskxmlrpc.h
+include/gsk/xml/gskxmldeserialize.h
+include/gsk/xml/gskxmloutput.h
+include/gsk/xml/gskxmlparser.h
+include/gsk/xml/gskxmlprocessor.h
+include/gsk/xml/gskxmlserialize.h
+include/gsk/xml/gskxmlservlet.h
+include/gsk/xml/gskxmltoken.h
+@dirrm include/gsk/gtk
+@dirrm include/gsk/protocols
+@dirrm include/gsk/xml
+@dirrm include/gsk
+lib/libgsk-minigtk.a
+lib/libgsk-minigtk.la
+lib/libgsk-minigtk.so
+lib/libgsk-minigtk.so.0
+lib/libgsk-protocol.a
+lib/libgsk-protocol.la
+lib/libgsk-protocol.so
+lib/libgsk-protocol.so.0
+lib/libgsk-server.a
+lib/libgsk-server.la
+lib/libgsk-server.so
+lib/libgsk-server.so.0
+lib/libgsk-xml.a
+lib/libgsk-xml.la
+lib/libgsk-xml.so
+lib/libgsk-xml.so.0
+lib/libgsk.a
+lib/libgsk.la
+lib/libgsk.so
+lib/libgsk.so.0
+share/aclocal/gsk.m4
+share/gsk-skeleton/gsk.skeleton-data
+@dirrm share/gsk-skeleton