aboutsummaryrefslogtreecommitdiff
path: root/net/gspoof
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-29 04:17:37 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2003-01-29 04:17:37 +0000
commitb0802091e00d6735b6d6cda0a7509e1f9fed2645 (patch)
tree43d5eefa19d61b4d20d74527c70a454cac668da4 /net/gspoof
parent74f0872c5b982e0ba326b19c22a9901e999e6947 (diff)
downloadports-b0802091e00d6735b6d6cda0a7509e1f9fed2645.tar.gz
ports-b0802091e00d6735b6d6cda0a7509e1f9fed2645.zip
Notes
Diffstat (limited to 'net/gspoof')
-rw-r--r--net/gspoof/Makefile32
-rw-r--r--net/gspoof/distinfo1
-rw-r--r--net/gspoof/files/patch-Makefile8
-rw-r--r--net/gspoof/pkg-comment1
-rw-r--r--net/gspoof/pkg-descr3
-rw-r--r--net/gspoof/pkg-plist1
6 files changed, 46 insertions, 0 deletions
diff --git a/net/gspoof/Makefile b/net/gspoof/Makefile
new file mode 100644
index 000000000000..4e90cdbbeccd
--- /dev/null
+++ b/net/gspoof/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# Ports collection makefile for: gspoof
+# Date created: Jan 29, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= gspoof
+PORTVERSION= 2.1.1
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libnet.a:${PORTSDIR}/net/libnet-devel
+
+USE_REINPLACE= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
+WRKSRC= ${WRKDIR}/${PORTNAME}
+ALL_TARGET= gtk
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|gtk-config|${GTK_CONFIG}|g" ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gspoof ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/net/gspoof/distinfo b/net/gspoof/distinfo
new file mode 100644
index 000000000000..0b701e818207
--- /dev/null
+++ b/net/gspoof/distinfo
@@ -0,0 +1 @@
+MD5 (gspoof-2.1.1.tar.gz) = ac3a448d51eab10c8eda42fba925398a
diff --git a/net/gspoof/files/patch-Makefile b/net/gspoof/files/patch-Makefile
new file mode 100644
index 000000000000..cbc43ab7c4a9
--- /dev/null
+++ b/net/gspoof/files/patch-Makefile
@@ -0,0 +1,8 @@
+--- Makefile.orig Wed Sep 25 03:17:31 2002
++++ Makefile Wed Jan 29 12:04:47 2003
+@@ -1,4 +1,4 @@
+-CC := gcc -O3 -ansi -Wall
++CC+= ${CFLAGS}
+ VERSION = "Gspoof -< Console/GTK+ TCP/IP Packets Forger v. 2.1.1 >-"
+ GSRC = main.c interface.c callbacks.c console.c common.c
+ CSRC = cmain.c console.c common.c
diff --git a/net/gspoof/pkg-comment b/net/gspoof/pkg-comment
new file mode 100644
index 000000000000..3f21c0718324
--- /dev/null
+++ b/net/gspoof/pkg-comment
@@ -0,0 +1 @@
+Console/GTK+ TCP/IP Packets Forger
diff --git a/net/gspoof/pkg-descr b/net/gspoof/pkg-descr
new file mode 100644
index 000000000000..cf30f0614b7a
--- /dev/null
+++ b/net/gspoof/pkg-descr
@@ -0,0 +1,3 @@
+Gspoof is a GTK+ program written in C language which makes easier and accurate
+the building and the sending of TCP packet with a data-payload or not. It's
+possible to modify TCP/IP fields also Ethernet header working to Link Level.
diff --git a/net/gspoof/pkg-plist b/net/gspoof/pkg-plist
new file mode 100644
index 000000000000..4a7d986a32c1
--- /dev/null
+++ b/net/gspoof/pkg-plist
@@ -0,0 +1 @@
+bin/gspoof