aboutsummaryrefslogtreecommitdiff
path: root/net/gspoof
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-01-31 14:09:55 +0000
commiteb81a88093e7d71530eebb2957f8ba4317b26ee6 (patch)
tree9290c97700f22b8ed6b87a10fda7d195dac09f04 /net/gspoof
parente6b247dce1d9f6355a583ef6269fdbba110eaea8 (diff)
downloadports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.tar.gz
ports-eb81a88093e7d71530eebb2957f8ba4317b26ee6.zip
Notes
Diffstat (limited to 'net/gspoof')
-rw-r--r--net/gspoof/Makefile12
-rw-r--r--net/gspoof/files/patch-configure30
2 files changed, 38 insertions, 4 deletions
diff --git a/net/gspoof/Makefile b/net/gspoof/Makefile
index d3447339a29d..a6c35c3090ca 100644
--- a/net/gspoof/Makefile
+++ b/net/gspoof/Makefile
@@ -8,7 +8,7 @@
PORTNAME= gspoof
PORTVERSION= 3.2
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,15 +16,19 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Console/GTK+ TCP/IP Packets Forger
-BUILD_DEPENDS= libnet*>=1.1.2,1:${PORTSDIR}/net/libnet
+BUILD_DEPENDS= ${LIBNET_CONFIG}:${PORTSDIR}/net/libnet
USE_GNOME= gnometarget gtk20
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-libnet-prefix=${LOCALBASE}
+
+LIBNET_CONFIG?= ${LOCALBASE}/bin/libnet11-config
post-patch:
- @${REINPLACE_CMD} -e 's|-Wall -O2|$${CFLAGS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|-Wall -O2|$${CFLAGS}|g; \
+ s|libnet-config|${LIBNET_CONFIG}|' \
+ ${CONFIGURE_WRKSRC}/${CONFIGURE_SCRIPT}
@${REINPLACE_CMD} -e 's|-Wall -O2|@CFLAGS@|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|/usr/local/share|${PREFIX}/share|g ; \
s|/usr/share|${X11BASE}/share|g' ${WRKSRC}/gtk.c
diff --git a/net/gspoof/files/patch-configure b/net/gspoof/files/patch-configure
new file mode 100644
index 000000000000..9721ae803bb6
--- /dev/null
+++ b/net/gspoof/files/patch-configure
@@ -0,0 +1,30 @@
+--- ./configure.orig Tue Dec 23 07:54:42 2003
++++ ./configure Wed Sep 27 18:23:26 2006
+@@ -2505,24 +2505,12 @@
+ as_ac_File=`echo "ac_cv_file_$LIBNET_PREFIX/lib/libnet.a" | $as_tr_sh`
+ echo "$as_me:$LINENO: checking for $LIBNET_PREFIX/lib/libnet.a" >&5
+ echo $ECHO_N "checking for $LIBNET_PREFIX/lib/libnet.a... $ECHO_C" >&6
+-if eval "test \"\${$as_ac_File+set}\" = set"; then
+- echo $ECHO_N "(cached) $ECHO_C" >&6
+-else
+- test "$cross_compiling" = yes &&
+- { { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
+-echo "$as_me: error: cannot check for file existence when cross compiling" >&2;}
+- { (exit 1); exit 1; }; }
+-if test -r "$LIBNET_PREFIX/lib/libnet.a"; then
+- eval "$as_ac_File=yes"
+-else
+- eval "$as_ac_File=no"
+-fi
+-fi
++eval "$as_ac_File=yes"
+ echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_File'}'`" >&5
+ echo "${ECHO_T}`eval echo '${'$as_ac_File'}'`" >&6
+ if test `eval echo '${'$as_ac_File'}'` = yes; then
+- LDFLAGS="-L$LIBNET_PREFIX/lib"
+- CPPFLAGS="-I$LIBNET_PREFIX/include"
++ LDFLAGS="`libnet-config --libs`"
++ CPPFLAGS="`libnet-config --cflags`"
+ else
+ { { echo "$as_me:$LINENO: error:
+ Libnet-1.1.1 Packet Shaping Library is required!