aboutsummaryrefslogtreecommitdiff
path: root/net/gtic
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2019-10-16 15:29:32 +0000
committerRene Ladan <rene@FreeBSD.org>2019-10-16 15:29:32 +0000
commit13d4527a34237c3848445140a659128518ca196f (patch)
treea59de3287464c291f091b739fe407ba6df10c951 /net/gtic
parenta12065703469e10f4f34b1e43555af92cfceaa6c (diff)
downloadports-13d4527a34237c3848445140a659128518ca196f.tar.gz
ports-13d4527a34237c3848445140a659128518ca196f.zip
Notes
Diffstat (limited to 'net/gtic')
-rw-r--r--net/gtic/Makefile34
-rw-r--r--net/gtic/distinfo2
-rw-r--r--net/gtic/files/patch-CONFIG28
-rw-r--r--net/gtic/files/patch-src_areas.c12
-rw-r--r--net/gtic/files/patch-src_tic.c11
-rw-r--r--net/gtic/files/patch-src_toss.c57
-rw-r--r--net/gtic/files/patch-src_users.c12
-rw-r--r--net/gtic/files/patch-src_xmalloc.h12
-rw-r--r--net/gtic/pkg-descr1
-rw-r--r--net/gtic/pkg-plist7
10 files changed, 0 insertions, 176 deletions
diff --git a/net/gtic/Makefile b/net/gtic/Makefile
deleted file mode 100644
index a2646bceec01..000000000000
--- a/net/gtic/Makefile
+++ /dev/null
@@ -1,34 +0,0 @@
-# Created by: Denis Shaposhnikov <dsh@vlink.ru>
-# $FreeBSD$
-
-PORTNAME= gtic
-PORTVERSION= 1.3.b
-PORTREVISION= 1
-CATEGORIES= net
-MASTER_SITES= ftp://ftp.kspu.kr.ua/pub/unix/FIDO/gtic/ \
- ftp://ftp.braz.ru/pub/fido/gtic/
-DISTNAME= ${PORTNAME}-1.3b
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= The GNU file forwarder (FSC-0087) for fidonet-like networks
-
-BROKEN= unfetchable
-DEPRECATED= Unfetchable, unmaintained
-EXPIRATION_DATE= 2019-10-16
-
-MAKE_ENV+= DEFINES="${DEFINES}"
-
-.if defined(WITH_AMIGA4D)
-DEFINES+= -DAMIGA4D
-.endif
-
-.include <bsd.port.pre.mk>
-
-do-install:
- ${MKDIR} ${STAGEDIR}${ETCDIR}
-.for i in areagroups areas config domains help users
- ${INSTALL_DATA} ${WRKSRC}/etc/${i} ${STAGEDIR}${ETCDIR}/${i}.sample
-.endfor
- ${INSTALL_PROGRAM} ${WRKSRC}/src/gtic ${STAGEDIR}${PREFIX}/sbin/
-
-.include <bsd.port.post.mk>
diff --git a/net/gtic/distinfo b/net/gtic/distinfo
deleted file mode 100644
index f5a8af3952c0..000000000000
--- a/net/gtic/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (gtic-1.3b.tar.gz) = b3f9f4cfb54ee29c93cb9cd607e44983e7b8ed25817aaa69ac34a11b81c26020
-SIZE (gtic-1.3b.tar.gz) = 74766
diff --git a/net/gtic/files/patch-CONFIG b/net/gtic/files/patch-CONFIG
deleted file mode 100644
index a1f6346eb18a..000000000000
--- a/net/gtic/files/patch-CONFIG
+++ /dev/null
@@ -1,28 +0,0 @@
---- CONFIG.orig Mon Jul 6 16:09:40 1998
-+++ CONFIG Sun Mar 5 19:42:04 2000
-@@ -2,7 +2,7 @@
- VERSION = "1.3b"
-
- # Main configuration file.
--CONFIG = "/etc/gtic/config"
-+CONFIG = "${PREFIX}/etc/gtic/config"
-
- # Path to other configuration files (also see default config file).
- CONFIGDIR = "/etc/gtic"
-@@ -15,13 +15,13 @@
- GROUP = gtic
-
- # Name of C compiler.
--CC = gcc
-+#CC = gcc
-
- # Compiler flags.
--CFLAGS=-Wall -g
-+#CFLAGS=-Wall -g
-
- # Defines for gtic's sources use.
--DEFINES = ${OPTS} -DCONFIG=\"${CONFIG}\" -DVERSION=\"${VERSION}\"
-+DEFINES += ${OPTS} -DCONFIG=\"${CONFIG}\" -DVERSION=\"${VERSION}\"
-
- # Compile-time options.
-
diff --git a/net/gtic/files/patch-src_areas.c b/net/gtic/files/patch-src_areas.c
deleted file mode 100644
index 8c8c2ecec80f..000000000000
--- a/net/gtic/files/patch-src_areas.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/areas.c.orig Sun Oct 24 20:16:14 1999
-+++ src/areas.c Sun Oct 24 20:19:15 1999
-@@ -305,9 +305,6 @@
-
- /* make a backup copy of areas_file */
- strcpy(new_path,areas_file);
-- if(strchr(new_path,'.'))
-- strcpy(strrchr(new_path,'.'),".bak");
-- else
- strcat(new_path,".bak");
- if(rename(areas_file,new_path))
- l_printf("Warning: unable to move %s to %s",areas_file,new_path);
diff --git a/net/gtic/files/patch-src_tic.c b/net/gtic/files/patch-src_tic.c
deleted file mode 100644
index 0265e10170ba..000000000000
--- a/net/gtic/files/patch-src_tic.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tic.c.orig Mon Jul 6 15:39:46 1998
-+++ src/tic.c Sun Sep 12 15:38:14 1999
-@@ -227,7 +227,7 @@
- else if(!strcasecmp(buff,"ReceiptRequest")) continue; /* skip by FSC-0087 */
- else
- {
-- e_printf("readtic: %s(%d) - %s[%s] - keyword unknown - ignored",
-+ l_printf("readtic: %s(%d) - %s[%s] - keyword unknown - ignored",
- tlist->name,linecnt,buff,v);
- continue;
- }
diff --git a/net/gtic/files/patch-src_toss.c b/net/gtic/files/patch-src_toss.c
deleted file mode 100644
index c872ca60c7ad..000000000000
--- a/net/gtic/files/patch-src_toss.c
+++ /dev/null
@@ -1,57 +0,0 @@
---- src/toss.c.orig Mon Jul 6 16:04:30 1998
-+++ src/toss.c Sun Mar 5 18:35:41 2000
-@@ -316,11 +316,16 @@
- newtic->areadesc=xstrcpy(acur->desc);
-
- /* make base of outbound file name */
-+#ifndef AMIGA4D
- if(utmp->addr.point!=0)
- snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x.pnt/%08x",
- utmp->addr.net,utmp->addr.node,utmp->addr.point);
- else
- snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x",utmp->addr.net,utmp->addr.node);
-+#else
-+ snprintf(ftmp,sizeof(ftmp)-1,"%d.%d.%d.%d", utmp->addr.zone,
-+ utmp->addr.net, utmp->addr.node, utmp->addr.point);
-+#endif /* AMIGA4D */
-
- /* determine queue directory */
- strcpy(qdir,get_outbound(utmp->addr.zone)); strcat(qdir,"/");
-@@ -342,21 +347,28 @@
- outbound/xxxxyyyy.pnt[/gtic_q]/zzzzzzzz.xlo
- */
- strcpy(xlo,get_outbound(utmp->addr.zone)); strcat(xlo,"/");
-+#ifndef AMIGA4D
- if(utmp->addr.point!=0)
- {
- snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x.pnt/",
- utmp->addr.net,utmp->addr.node);
- strcat(xlo,ftmp);
- }
-+#endif /* AMIGA4D */
- if(mk_bsy==FALSE)
- {
- strcat(xlo,"gtic_q/");
- mkdirs(xlo,dirmode(outbound_mode));
- }
-+#ifndef AMIGA4D
- if(newtic->to.point!=0)
- snprintf(ftmp,sizeof(ftmp)-1,"%08x",newtic->to.point);
- else
- snprintf(ftmp,sizeof(ftmp)-1,"%04x%04x",newtic->to.net,newtic->to.node);
-+#else
-+ snprintf(ftmp,sizeof(ftmp)-1,"%d.%d.%d.%d", newtic->to.zone,
-+ newtic->to.net, newtic->to.node, newtic->to.point);
-+#endif /* AMIGA4D */
- if(utmp->flags & USER_HOLD)
- strcat(ftmp,".hlo");
- else
-@@ -873,7 +885,7 @@
-
- if(announce_f)
- {
-- fprintf(announce_f,"AREA: %-15s FILE: %s\n",curarea->name,cur->file);
-+ fprintf(announce_f,">AREA: %-15s FILE: %s\n",curarea->name,cur->file);
- if(pub_path && pub_url &&
- strlen(curarea->path)>=strlen(pub_path) &&
- strncmp(curarea->path,pub_path,strlen(pub_path))==0)
diff --git a/net/gtic/files/patch-src_users.c b/net/gtic/files/patch-src_users.c
deleted file mode 100644
index 5681ad8946fc..000000000000
--- a/net/gtic/files/patch-src_users.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/users.c.orig Sun Oct 24 20:19:46 1999
-+++ src/users.c Sun Oct 24 20:20:10 1999
-@@ -125,9 +125,6 @@
-
- /* make a backup copy of users_file */
- strcpy(new_path,users_file);
-- if(strchr(new_path,'.'))
-- strcpy(strrchr(new_path,'.'),".bak");
-- else
- strcat(new_path,".bak");
- if(rename(users_file,new_path))
- l_printf("Warning: unable to move %s to %s",users_file,new_path);
diff --git a/net/gtic/files/patch-src_xmalloc.h b/net/gtic/files/patch-src_xmalloc.h
deleted file mode 100644
index 8e9ea1a9433f..000000000000
--- a/net/gtic/files/patch-src_xmalloc.h
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/xmalloc.h.orig Sun Feb 6 10:50:42 2000
-+++ src/xmalloc.h Sun Feb 6 10:51:14 2000
-@@ -1,7 +1,9 @@
- #ifndef __XMALLOC_H
- #define __XMALLOC_H
-
-+#if !defined(__FreeBSD__)
- void *xmalloc(size_t size);
-+#endif
- void xfree(void *ptr);
-
- #endif
diff --git a/net/gtic/pkg-descr b/net/gtic/pkg-descr
deleted file mode 100644
index ae2a5c67640a..000000000000
--- a/net/gtic/pkg-descr
+++ /dev/null
@@ -1 +0,0 @@
-The GNU file forwarder (FSC-0087) for fidonet-like networks.
diff --git a/net/gtic/pkg-plist b/net/gtic/pkg-plist
deleted file mode 100644
index 6cc3ddae6a55..000000000000
--- a/net/gtic/pkg-plist
+++ /dev/null
@@ -1,7 +0,0 @@
-@sample %%ETCDIR%%/areagroups.sample
-@sample %%ETCDIR%%/areas.sample
-@sample %%ETCDIR%%/config.sample
-@sample %%ETCDIR%%/domains.sample
-@sample %%ETCDIR%%/help.sample
-@sample %%ETCDIR%%/users.sample
-sbin/gtic