aboutsummaryrefslogtreecommitdiff
path: root/net/gtk+licq
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2001-04-07 21:02:44 +0000
committerWill Andrews <will@FreeBSD.org>2001-04-07 21:02:44 +0000
commitba8fb144828cd3916d0b55ee28d42652c20ae5b5 (patch)
treea342cba15dc4be590f82c947e2540a888463e878 /net/gtk+licq
parent46aa7c00013094a7b311c0afacf6c2128068c5f3 (diff)
downloadports-ba8fb144828cd3916d0b55ee28d42652c20ae5b5.tar.gz
ports-ba8fb144828cd3916d0b55ee28d42652c20ae5b5.zip
Notes
Diffstat (limited to 'net/gtk+licq')
-rw-r--r--net/gtk+licq/Makefile31
-rw-r--r--net/gtk+licq/files/patch-src::options_dialog.cpp2
-rw-r--r--net/gtk+licq/files/patch-src::plugin_dialog.cpp2
-rw-r--r--net/gtk+licq/pkg-plist26
4 files changed, 45 insertions, 16 deletions
diff --git a/net/gtk+licq/Makefile b/net/gtk+licq/Makefile
index 071564c2dcfe..9cc7349b13c3 100644
--- a/net/gtk+licq/Makefile
+++ b/net/gtk+licq/Makefile
@@ -7,33 +7,38 @@
PORTNAME= gtk+licq
PORTVERSION= 0.50.1
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://gtk.licq.org/download/
MAINTAINER= ishmael27@home.com
BUILD_DEPENDS= ${LOCALBASE}/include/licq/licq_icqd.h:${PORTSDIR}/net/licq
+LIB_DEPENDS= pspell.4:${PORTSDIR}/textproc/pspell
RUN_DEPENDS= licq:${PORTSDIR}/net/licq
USE_GMAKE= yes
USE_GTK= yes
WANT_GNOME= yes
USE_LIBTOOL= yes
-USE_AUTOMAKE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
-.if defined(WITHOUT_GNOME)
-CONFIGURE_ARGS= --disable-gnome
-GUITYPE= gtk
+.include <bsd.port.pre.mk>
+
+.if defined(HAVE_GNOME)
+USE_GNOME= yes
+CONFIGURE_ARGS= --enable-gnome
.else
-GUITYPE= gnome
+CONFIGURE_ARGS= --disable-gnome
+post-patch:
+ @${PERL5} -pi -e \
+ 's|^SUBDIRS\ =.*|SUBDIRS\ =\ |' ${WRKSRC}/doc/Makefile.in
.endif
-PLIST_SUB= GUITYPE=${GUITYPE}
-
-CONFIGURE_ENV= CPPFLAGS=-"I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
-
-post-install:
- strip ${PREFIX}/lib/licq/licq_${GUITYPE}_gui.a
+post-configure:
+ @${PERL5} -pi -e \
+ 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \
+ ${WRKSRC}/libtool
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/net/gtk+licq/files/patch-src::options_dialog.cpp b/net/gtk+licq/files/patch-src::options_dialog.cpp
index b626523243f7..cfeba9e882a5 100644
--- a/net/gtk+licq/files/patch-src::options_dialog.cpp
+++ b/net/gtk+licq/files/patch-src::options_dialog.cpp
@@ -3,7 +3,7 @@
@@ -1,5 +1,6 @@
#include "gtk-gui.h"
-+#include <sys/unistd.h>
++#include <unistd.h>
#include <sys/time.h>
#include <stdio.h>
#include <sys/types.h>
diff --git a/net/gtk+licq/files/patch-src::plugin_dialog.cpp b/net/gtk+licq/files/patch-src::plugin_dialog.cpp
index 5f1f52ab3e53..3946cb9a74b3 100644
--- a/net/gtk+licq/files/patch-src::plugin_dialog.cpp
+++ b/net/gtk+licq/files/patch-src::plugin_dialog.cpp
@@ -3,7 +3,7 @@
@@ -1,5 +1,6 @@
#include "gtk-gui.h"
-+#include <sys/unistd.h>
++#include <unistd.h>
#include <sys/time.h>
#include <stdio.h>
#include <sys/types.h>
diff --git a/net/gtk+licq/pkg-plist b/net/gtk+licq/pkg-plist
index 679526efbcc0..caf7ceadae99 100644
--- a/net/gtk+licq/pkg-plist
+++ b/net/gtk+licq/pkg-plist
@@ -1,4 +1,24 @@
-lib/licq/licq_%%GUITYPE%%_gui.a
+%%GNOME:%%lib/licq/licq_gnome_gui.so
+%%GNOME:%%share/gnome/help/gtk+licq/C/arvancedusage.html
+%%GNOME:%%share/gnome/help/gtk+licq/C/authors.html
+%%GNOME:%%share/gnome/help/gtk+licq/C/bugs.html
+%%GNOME:%%share/gnome/help/gtk+licq/C/docbook.css
+%%GNOME:%%share/gnome/help/gtk+licq/C/goodstuff.html
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_applet.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_chatwindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_infowindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_mainwindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_optionwindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_regwindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_searchwindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_sendwindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/images/gtk_licq_viewwindow.png
+%%GNOME:%%share/gnome/help/gtk+licq/C/index.html
+%%GNOME:%%share/gnome/help/gtk+licq/C/license.html
+%%GNOME:%%share/gnome/help/gtk+licq/C/prefs.html
+%%GNOME:%%share/gnome/help/gtk+licq/C/topic.dat
+%%GNOME:%%share/gnome/help/gtk+licq/C/usage.html
+%%NOGNOME:%%lib/licq/licq_gtk_gui.so
share/licq/gtk-gui/pixmaps/arrow.xpm
share/licq/gtk-gui/pixmaps/chatBeep.xpm
share/licq/gtk-gui/pixmaps/chatBold.xpm
@@ -21,6 +41,10 @@ share/licq/gtk-gui/pixmaps/sideways_strippeddownlogo.xpm
share/locale/de/LC_MESSAGES/gtk+licq.mo
share/locale/es/LC_MESSAGES/gtk+licq.mo
share/locale/pt/LC_MESSAGES/gtk+licq.mo
+share/locale/pt_BR/LC_MESSAGES/gtk+licq.mo
share/locale/ru/LC_MESSAGES/gtk+licq.mo
+%%GNOME:%%@dirrm share/gnome/help/gtk+licq/C/images
+%%GNOME:%%@dirrm share/gnome/help/gtk+licq/C
+%%GNOME:%%@dirrm share/gnome/help/gtk+licq
@dirrm share/licq/gtk-gui/pixmaps
@dirrm share/licq/gtk-gui