aboutsummaryrefslogtreecommitdiff
path: root/net/gupnp-igd
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-12 19:14:38 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-12 19:14:38 +0000
commitc25fb8d1754dd6dc915bc598368cdd0affece699 (patch)
tree309fd484253a8d5e7b802ee9ce120943fb62b6a7 /net/gupnp-igd
parent82969f73fc75607ec001e3667a89602b9269aaed (diff)
downloadports-c25fb8d1754dd6dc915bc598368cdd0affece699.tar.gz
ports-c25fb8d1754dd6dc915bc598368cdd0affece699.zip
Notes
Diffstat (limited to 'net/gupnp-igd')
-rw-r--r--net/gupnp-igd/Makefile23
-rw-r--r--net/gupnp-igd/distinfo4
-rw-r--r--net/gupnp-igd/files/patch-libgupnp-igd-gupnp-simple-igd.c11
-rw-r--r--net/gupnp-igd/pkg-descr2
-rw-r--r--net/gupnp-igd/pkg-plist11
5 files changed, 34 insertions, 17 deletions
diff --git a/net/gupnp-igd/Makefile b/net/gupnp-igd/Makefile
index 12d9784c63d4..df59b638affa 100644
--- a/net/gupnp-igd/Makefile
+++ b/net/gupnp-igd/Makefile
@@ -6,26 +6,27 @@
#
PORTNAME= gupnp-igd
-PORTVERSION= 0.1.6
-PORTREVISION= 3
+PORTVERSION= 0.2.1
CATEGORIES= net
-MASTER_SITES= http://www.gupnp.org/sites/all/files/sources/
+MASTER_SITES= http://www.gupnp.org/sites/all/files/sources/ \
+ LOCAL/sunpoet
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Library to handle UPnP IGD port mapping
-BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject
+LICENSE= LGPL21
+
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/pygobject-2.0.pc:${PORTSDIR}/devel/py-gobject \
+ gobject-introspection>=0.10:${PORTSDIR}/devel/gobject-introspection \
+ gupnp>=0.18:${PORTSDIR}/net/gupnp
LIB_DEPENDS= gupnp-1.0:${PORTSDIR}/net/gupnp
+RUN_DEPENDS= gupnp>=0.18:${PORTSDIR}/net/gupnp
+CONFIGURE_ARGS= --enable-introspection=yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack intlhack libglade2 glib20
+USE_GNOME= glib20 gnomehack
USE_LDCONFIG= yes
USE_PYTHON= yes
-# For gmake >= 3.82 -- no idea where this line comes from, patching
-# the Makefile.in seems to have no effect
-post-configure:
- @${REINPLACE_CMD} -e 's|^\[|# \[|' ${WRKSRC}/python/Makefile
-
.include <bsd.port.mk>
diff --git a/net/gupnp-igd/distinfo b/net/gupnp-igd/distinfo
index 7e0c1e3032a6..381d910acd8d 100644
--- a/net/gupnp-igd/distinfo
+++ b/net/gupnp-igd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gupnp-igd-0.1.6.tar.gz) = 518cfc31a7acf7dd260626453c217b53ff881d227dfd30e433899a43c9e45117
-SIZE (gupnp-igd-0.1.6.tar.gz) = 353920
+SHA256 (gupnp-igd-0.2.1.tar.gz) = 023ae08200ff14ebfee7d3113c25047dd585087252bc65dbf8d42f4804452aa2
+SIZE (gupnp-igd-0.2.1.tar.gz) = 378358
diff --git a/net/gupnp-igd/files/patch-libgupnp-igd-gupnp-simple-igd.c b/net/gupnp-igd/files/patch-libgupnp-igd-gupnp-simple-igd.c
new file mode 100644
index 000000000000..e04f10913895
--- /dev/null
+++ b/net/gupnp-igd/files/patch-libgupnp-igd-gupnp-simple-igd.c
@@ -0,0 +1,11 @@
+--- libgupnp-igd/gupnp-simple-igd.c.orig 2011-11-08 06:37:37.000000000 +0800
++++ libgupnp-igd/gupnp-simple-igd.c 2012-05-04 01:21:02.021160345 +0800
+@@ -41,6 +41,8 @@
+
+ #include <string.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
++#include <sys/socket.h>
+
+ #include <libgupnp/gupnp.h>
+
diff --git a/net/gupnp-igd/pkg-descr b/net/gupnp-igd/pkg-descr
index c3ccc5194215..df07ae7c5b49 100644
--- a/net/gupnp-igd/pkg-descr
+++ b/net/gupnp-igd/pkg-descr
@@ -1,3 +1,3 @@
This is a library to handle UPnP IGD port mapping.
-WWW: http://www.gupnp.org/
+WWW: http://www.gupnp.org/
diff --git a/net/gupnp-igd/pkg-plist b/net/gupnp-igd/pkg-plist
index 493df0ba2be2..99eb265f8c72 100644
--- a/net/gupnp-igd/pkg-plist
+++ b/net/gupnp-igd/pkg-plist
@@ -3,15 +3,19 @@ include/gupnp-igd-1.0/libgupnp-igd/gupnp-simple-igd.h
lib/libgupnp-igd-1.0.a
lib/libgupnp-igd-1.0.la
lib/libgupnp-igd-1.0.so
-lib/libgupnp-igd-1.0.so.3
+lib/libgupnp-igd-1.0.so.5
+%%PYTHON_SITELIBDIR%%/gupnp/__init__.py
+%%PYTHON_SITELIBDIR%%/gupnp/__init__.pyc
+%%PYTHON_SITELIBDIR%%/gupnp/__init__.pyo
%%PYTHON_SITELIBDIR%%/gupnp/igd.a
%%PYTHON_SITELIBDIR%%/gupnp/igd.la
%%PYTHON_SITELIBDIR%%/gupnp/igd.so
+lib/girepository-1.0/GUPnPIgd-1.0.typelib
libdata/pkgconfig/gupnp-igd-1.0.pc
+share/gir-1.0/GUPnPIgd-1.0.gir
share/gtk-doc/html/gupnp-igd/GUPnPSimpleIgd.html
share/gtk-doc/html/gupnp-igd/GUPnPSimpleIgdThread.html
share/gtk-doc/html/gupnp-igd/ch01.html
-share/gtk-doc/html/gupnp-igd/gupnp-igd.devhelp
share/gtk-doc/html/gupnp-igd/gupnp-igd.devhelp2
share/gtk-doc/html/gupnp-igd/home.png
share/gtk-doc/html/gupnp-igd/index.html
@@ -23,8 +27,9 @@ share/gtk-doc/html/gupnp-igd/up.png
@dirrmtry share/gtk-doc/html/gupnp-igd
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc
+@dirrmtry share/gir-1.0
@dirrmtry %%PYTHON_SITELIBDIR%%/gupnp
@dirrmtry %%PYTHON_SITELIBDIR%%
-@dirrmtry %%PYTHON_LIBDIR%%
+@dirrmtry lib/girepository-1.0
@dirrmtry include/gupnp-igd-1.0/libgupnp-igd
@dirrmtry include/gupnp-igd-1.0