aboutsummaryrefslogtreecommitdiff
path: root/net/gupnp/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-26 13:54:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-26 13:54:20 +0000
commit172f0797a0e840d2c22d2b80d437b421b6e9ef80 (patch)
tree3cc4dc392589eadecb7a8ea7cb0f191ff022e8a9 /net/gupnp/Makefile
parent78c652efbf0cbc53885a4797bcbcdfbb4c29f0d9 (diff)
Notes
Diffstat (limited to 'net/gupnp/Makefile')
-rw-r--r--net/gupnp/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/net/gupnp/Makefile b/net/gupnp/Makefile
new file mode 100644
index 000000000000..dc485800956f
--- /dev/null
+++ b/net/gupnp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gupnp
+# Date created: 2009-12-26
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gupnp
+PORTVERSION= 0.13.2
+CATEGORIES= net
+MASTER_SITES= http://www.gupnp.org/sources/${PORTNAME}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Framework for UPnP devices
+
+LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ gssdp-1.0:${PORTSDIR}/net/gssdp \
+ uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack intlhack libglade2 glib20
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|' \
+ ${WRKSRC}/tools/gupnp-binding-tool
+
+.include <bsd.port.mk>