aboutsummaryrefslogtreecommitdiff
path: root/net/gupnp
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-12-26 13:54:20 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-12-26 13:54:20 +0000
commit172f0797a0e840d2c22d2b80d437b421b6e9ef80 (patch)
tree3cc4dc392589eadecb7a8ea7cb0f191ff022e8a9 /net/gupnp
parent78c652efbf0cbc53885a4797bcbcdfbb4c29f0d9 (diff)
Notes
Diffstat (limited to 'net/gupnp')
-rw-r--r--net/gupnp/Makefile29
-rw-r--r--net/gupnp/distinfo3
-rw-r--r--net/gupnp/files/patch-libgupnp_gupnp-control-point.c11
-rw-r--r--net/gupnp/files/patch-libgupnp_gupnp-services.c35
-rw-r--r--net/gupnp/pkg-descr5
-rw-r--r--net/gupnp/pkg-plist67
6 files changed, 150 insertions, 0 deletions
diff --git a/net/gupnp/Makefile b/net/gupnp/Makefile
new file mode 100644
index 000000000000..dc485800956f
--- /dev/null
+++ b/net/gupnp/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: gupnp
+# Date created: 2009-12-26
+# Whom: Martin Wilke <miwi@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gupnp
+PORTVERSION= 0.13.2
+CATEGORIES= net
+MASTER_SITES= http://www.gupnp.org/sources/${PORTNAME}/
+
+MAINTAINER= miwi@FreeBSD.org
+COMMENT= Framework for UPnP devices
+
+LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
+ gssdp-1.0:${PORTSDIR}/net/gssdp \
+ uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+
+USE_PYTHON= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gnomehack intlhack libglade2 glib20
+USE_LDCONFIG= yes
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|' \
+ ${WRKSRC}/tools/gupnp-binding-tool
+
+.include <bsd.port.mk>
diff --git a/net/gupnp/distinfo b/net/gupnp/distinfo
new file mode 100644
index 000000000000..348d3ca1a336
--- /dev/null
+++ b/net/gupnp/distinfo
@@ -0,0 +1,3 @@
+MD5 (gupnp-0.13.2.tar.gz) = eca3f79b32deb43f5de752d6cf2c160d
+SHA256 (gupnp-0.13.2.tar.gz) = 34e2d5bc2c61c8eae590375a6f8c5c875bf4e964832db21dd2b28dfa8b5f1219
+SIZE (gupnp-0.13.2.tar.gz) = 548808
diff --git a/net/gupnp/files/patch-libgupnp_gupnp-control-point.c b/net/gupnp/files/patch-libgupnp_gupnp-control-point.c
new file mode 100644
index 000000000000..b46b5663ee0f
--- /dev/null
+++ b/net/gupnp/files/patch-libgupnp_gupnp-control-point.c
@@ -0,0 +1,11 @@
+--- libgupnp/gupnp-control-point.c.orig 2009-08-24 18:29:33.000000000 +0200
++++ libgupnp/gupnp-control-point.c 2009-12-26 14:32:06.000000000 +0100
+@@ -658,7 +658,7 @@
+ /* Count elements */
+ count = g_strv_length (bits);
+
+- if (count == 1) {
++ if (count == 1 || (count == 2 && strlen(bits[1]) == 0)) {
+ /* uuid:device-UUID */
+
+ *udn = bits[0];
diff --git a/net/gupnp/files/patch-libgupnp_gupnp-services.c b/net/gupnp/files/patch-libgupnp_gupnp-services.c
new file mode 100644
index 000000000000..57ef4ded229b
--- /dev/null
+++ b/net/gupnp/files/patch-libgupnp_gupnp-services.c
@@ -0,0 +1,35 @@
+--- libgupnp/gupnp-service.c.orig 2009-12-02 15:27:43.000000000 +0100
++++ libgupnp/gupnp-service.c 2009-12-26 14:30:23.000000000 +0100
+@@ -30,7 +30,11 @@
+ #include <gobject/gvaluecollector.h>
+ #include <gmodule.h>
+ #include <libsoup/soup-date.h>
++#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
++#include <uuid.h>
++#else
+ #include <uuid/uuid.h>
++#endif
+ #include <string.h>
+ #include "gupnp-service.h"
+ #include "gupnp-root-device.h"
+@@ -867,9 +871,19 @@
+ {
+ uuid_t id;
+ char out[39];
+-
++#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
++ char *myout;
++#endif
++
++#if defined(__NetBSD__) || defined(__DragonFly__) || defined(__FreeBSD__)
++ uuid_create(&id, 0);
++ uuid_to_string(&id, &myout, 0);
++ strncpy(out, myout, sizeof(out));
++ free(myout);
++#else
+ uuid_generate (id);
+ uuid_unparse (id, out);
++#endif
+
+ return g_strdup_printf ("uuid:%s", out);
+ }
diff --git a/net/gupnp/pkg-descr b/net/gupnp/pkg-descr
new file mode 100644
index 000000000000..9ed2964a4551
--- /dev/null
+++ b/net/gupnp/pkg-descr
@@ -0,0 +1,5 @@
+GUPnP implements the UPnP specification: resource announcement and discovery,
+description, control, event notification, and presentation
+(GUPnP includes basic web server functionality through libsoup).
+
+WWW: http://www.gupnp.org/
diff --git a/net/gupnp/pkg-plist b/net/gupnp/pkg-plist
new file mode 100644
index 000000000000..21066987bb81
--- /dev/null
+++ b/net/gupnp/pkg-plist
@@ -0,0 +1,67 @@
+bin/gupnp-binding-tool
+include/gupnp-1.0/libgupnp/gupnp-context-manager.h
+include/gupnp-1.0/libgupnp/gupnp-context.h
+include/gupnp-1.0/libgupnp/gupnp-control-point.h
+include/gupnp-1.0/libgupnp/gupnp-device-info.h
+include/gupnp-1.0/libgupnp/gupnp-device-proxy.h
+include/gupnp-1.0/libgupnp/gupnp-device.h
+include/gupnp-1.0/libgupnp/gupnp-error.h
+include/gupnp-1.0/libgupnp/gupnp-resource-factory.h
+include/gupnp-1.0/libgupnp/gupnp-root-device.h
+include/gupnp-1.0/libgupnp/gupnp-service-info.h
+include/gupnp-1.0/libgupnp/gupnp-service-introspection.h
+include/gupnp-1.0/libgupnp/gupnp-service-proxy.h
+include/gupnp-1.0/libgupnp/gupnp-service.h
+include/gupnp-1.0/libgupnp/gupnp-types.h
+include/gupnp-1.0/libgupnp/gupnp-xml-doc.h
+include/gupnp-1.0/libgupnp/gupnp.h
+lib/libgupnp-1.0.a
+lib/libgupnp-1.0.la
+lib/libgupnp-1.0.so
+lib/libgupnp-1.0.so.3
+libdata/pkgconfig/gupnp-1.0.pc
+share/gtk-doc/html/gupnp/GUPnPContext.html
+share/gtk-doc/html/gupnp/GUPnPContextManager.html
+share/gtk-doc/html/gupnp/GUPnPControlPoint.html
+share/gtk-doc/html/gupnp/GUPnPDevice.html
+share/gtk-doc/html/gupnp/GUPnPDeviceInfo.html
+share/gtk-doc/html/gupnp/GUPnPDeviceProxy.html
+share/gtk-doc/html/gupnp/GUPnPResourceFactory.html
+share/gtk-doc/html/gupnp/GUPnPRootDevice.html
+share/gtk-doc/html/gupnp/GUPnPService.html
+share/gtk-doc/html/gupnp/GUPnPServiceInfo.html
+share/gtk-doc/html/gupnp/GUPnPServiceIntrospection.html
+share/gtk-doc/html/gupnp/GUPnPServiceProxy.html
+share/gtk-doc/html/gupnp/GUPnPXMLDoc.html
+share/gtk-doc/html/gupnp/api-device-control.html
+share/gtk-doc/html/gupnp/api-device-impl.html
+share/gtk-doc/html/gupnp/api-device-info.html
+share/gtk-doc/html/gupnp/api-tools.html
+share/gtk-doc/html/gupnp/api-utility.html
+share/gtk-doc/html/gupnp/api.html
+share/gtk-doc/html/gupnp/client-tutorial.html
+share/gtk-doc/html/gupnp/glossary.html
+share/gtk-doc/html/gupnp/gupnp-Error-codes.html
+share/gtk-doc/html/gupnp/gupnp-Special-UPnP-types.html
+share/gtk-doc/html/gupnp/gupnp-binding-tool.html
+share/gtk-doc/html/gupnp/gupnp.devhelp
+share/gtk-doc/html/gupnp/gupnp.devhelp2
+share/gtk-doc/html/gupnp/home.png
+share/gtk-doc/html/gupnp/index.html
+share/gtk-doc/html/gupnp/index.sgml
+share/gtk-doc/html/gupnp/ix01.html
+share/gtk-doc/html/gupnp/left.png
+share/gtk-doc/html/gupnp/overview.html
+share/gtk-doc/html/gupnp/right.png
+share/gtk-doc/html/gupnp/schemas-device.html
+share/gtk-doc/html/gupnp/schemas-service.html
+share/gtk-doc/html/gupnp/schemas.html
+share/gtk-doc/html/gupnp/server-tutorial.html
+share/gtk-doc/html/gupnp/style.css
+share/gtk-doc/html/gupnp/tutorial.html
+share/gtk-doc/html/gupnp/up.png
+@dirrmtry share/gtk-doc/html/gupnp
+@dirrmtry share/gtk-doc/html
+@dirrmtry share/gtk-doc
+@dirrmtry include/gupnp-1.0/libgupnp
+@dirrmtry include/gupnp-1.0