aboutsummaryrefslogtreecommitdiff
path: root/net/gupnp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-12 19:12:19 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2012-06-12 19:12:19 +0000
commitb58efac19d25e139853af3aebcb9fbf9adfc5984 (patch)
treee6470a83cd7846ed61c69639f69750b67798c8fb /net/gupnp
parentf2dbedff35006141d4a88618b561fce1db347a0d (diff)
downloadports-b58efac19d25e139853af3aebcb9fbf9adfc5984.tar.gz
ports-b58efac19d25e139853af3aebcb9fbf9adfc5984.zip
Notes
Diffstat (limited to 'net/gupnp')
-rw-r--r--net/gupnp/Makefile27
-rw-r--r--net/gupnp/distinfo4
-rw-r--r--net/gupnp/pkg-descr14
-rw-r--r--net/gupnp/pkg-plist10
4 files changed, 36 insertions, 19 deletions
diff --git a/net/gupnp/Makefile b/net/gupnp/Makefile
index 35d9c11596c8..056f3b88e923 100644
--- a/net/gupnp/Makefile
+++ b/net/gupnp/Makefile
@@ -6,25 +6,30 @@
#
PORTNAME= gupnp
-PORTVERSION= 0.13.2
-PORTREVISION= 3
+PORTVERSION= 0.18.3
CATEGORIES= net
-MASTER_SITES= http://www.gupnp.org/sites/all/files/sources/
+MASTER_SITES= GNOME
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Framework for UPnP devices
-LIB_DEPENDS= soup-2.4.1:${PORTSDIR}/devel/libsoup \
- gssdp-1.0:${PORTSDIR}/net/gssdp \
- uuid.1:${PORTSDIR}/misc/e2fsprogs-libuuid
+LICENSE= LGPL20
-USE_PYTHON= yes
+BUILD_DEPENDS= gobject-introspection>=0.6.4:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= gssdp-1.0:${PORTSDIR}/net/gssdp \
+ soup-2.4:${PORTSDIR}/devel/libsoup \
+ uuid:${PORTSDIR}/misc/e2fsprogs-libuuid
+
+CONFIGURE_ARGS= --enable-introspection=yes
GNU_CONFIGURE= yes
-USE_GNOME= gnomehack intlhack libglade2 glib20
+USE_GMAKE= yes
+USE_GNOME= glib20 gnomehack
USE_LDCONFIG= yes
+USE_PYTHON= yes
+USE_XZ= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/bin/python|/usr/bin/env python|' \
- ${WRKSRC}/tools/gupnp-binding-tool
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ ${WRKSRC}/tools/gupnp-binding-tool
.include <bsd.port.mk>
diff --git a/net/gupnp/distinfo b/net/gupnp/distinfo
index 39d0a1c10602..573fe2e9be6e 100644
--- a/net/gupnp/distinfo
+++ b/net/gupnp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gupnp-0.13.2.tar.gz) = 34e2d5bc2c61c8eae590375a6f8c5c875bf4e964832db21dd2b28dfa8b5f1219
-SIZE (gupnp-0.13.2.tar.gz) = 548808
+SHA256 (gupnp-0.18.3.tar.xz) = 5920621de6386664ee759386514effa5e0544e40298245e4c67076d92715fba2
+SIZE (gupnp-0.18.3.tar.xz) = 359744
diff --git a/net/gupnp/pkg-descr b/net/gupnp/pkg-descr
index 9ed2964a4551..18a262a53780 100644
--- a/net/gupnp/pkg-descr
+++ b/net/gupnp/pkg-descr
@@ -1,5 +1,13 @@
+GUPnP is an elegant, object-oriented open source framework for creating UPnP
+devices and control points, written in C using GObject and libsoup. The GUPnP
+API is intended to be easy to use, efficient and flexible. It provides the same
+set of features as libupnp, but shields the developer from most of UPnP's
+internals.
+
GUPnP implements the UPnP specification: resource announcement and discovery,
-description, control, event notification, and presentation
-(GUPnP includes basic web server functionality through libsoup).
+description, control, event notification, and presentation (GUPnP includes basic
+web server functionality through libsoup). GUPnP does not include helpers for
+construction or control of specific standardized resources (e.g. MediaServer);
+this is left for higher level libraries utilizing the GUPnP framework.
-WWW: http://www.gupnp.org/
+WWW: http://www.gupnp.org/
diff --git a/net/gupnp/pkg-plist b/net/gupnp/pkg-plist
index 21066987bb81..95a2d988744d 100644
--- a/net/gupnp/pkg-plist
+++ b/net/gupnp/pkg-plist
@@ -15,11 +15,13 @@ include/gupnp-1.0/libgupnp/gupnp-service.h
include/gupnp-1.0/libgupnp/gupnp-types.h
include/gupnp-1.0/libgupnp/gupnp-xml-doc.h
include/gupnp-1.0/libgupnp/gupnp.h
+lib/girepository-1.0/GUPnP-1.0.typelib
lib/libgupnp-1.0.a
lib/libgupnp-1.0.la
lib/libgupnp-1.0.so
-lib/libgupnp-1.0.so.3
+lib/libgupnp-1.0.so.4
libdata/pkgconfig/gupnp-1.0.pc
+share/gir-1.0/GUPnP-1.0.gir
share/gtk-doc/html/gupnp/GUPnPContext.html
share/gtk-doc/html/gupnp/GUPnPContextManager.html
share/gtk-doc/html/gupnp/GUPnPControlPoint.html
@@ -30,9 +32,9 @@ share/gtk-doc/html/gupnp/GUPnPResourceFactory.html
share/gtk-doc/html/gupnp/GUPnPRootDevice.html
share/gtk-doc/html/gupnp/GUPnPService.html
share/gtk-doc/html/gupnp/GUPnPServiceInfo.html
-share/gtk-doc/html/gupnp/GUPnPServiceIntrospection.html
share/gtk-doc/html/gupnp/GUPnPServiceProxy.html
share/gtk-doc/html/gupnp/GUPnPXMLDoc.html
+share/gtk-doc/html/gupnp/annotation-glossary.html
share/gtk-doc/html/gupnp/api-device-control.html
share/gtk-doc/html/gupnp/api-device-impl.html
share/gtk-doc/html/gupnp/api-device-info.html
@@ -44,7 +46,7 @@ share/gtk-doc/html/gupnp/glossary.html
share/gtk-doc/html/gupnp/gupnp-Error-codes.html
share/gtk-doc/html/gupnp/gupnp-Special-UPnP-types.html
share/gtk-doc/html/gupnp/gupnp-binding-tool.html
-share/gtk-doc/html/gupnp/gupnp.devhelp
+share/gtk-doc/html/gupnp/gupnp-gupnp-service-introspection.html
share/gtk-doc/html/gupnp/gupnp.devhelp2
share/gtk-doc/html/gupnp/home.png
share/gtk-doc/html/gupnp/index.html
@@ -63,5 +65,7 @@ share/gtk-doc/html/gupnp/up.png
@dirrmtry share/gtk-doc/html/gupnp
@dirrmtry share/gtk-doc/html
@dirrmtry share/gtk-doc
+@dirrmtry share/gir-1.0
+@dirrmtry lib/girepository-1.0
@dirrmtry include/gupnp-1.0/libgupnp
@dirrmtry include/gupnp-1.0