aboutsummaryrefslogtreecommitdiff
path: root/net/gupnp
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-19 18:38:30 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2014-05-19 18:38:30 +0000
commitf165d7010e3fc661ce3cb751528e858821a9c3bb (patch)
tree4e0b2d66e14c8aa3937eec87e1d012c890dc0c4d /net/gupnp
parent2896d979980a9adeb4463d2c4780785e61325d36 (diff)
downloadports-f165d7010e3fc661ce3cb751528e858821a9c3bb.tar.gz
ports-f165d7010e3fc661ce3cb751528e858821a9c3bb.zip
Notes
Diffstat (limited to 'net/gupnp')
-rw-r--r--net/gupnp/Makefile13
-rw-r--r--net/gupnp/distinfo4
-rw-r--r--net/gupnp/files/patch-libgupnp-gupnp-acl.h15
-rw-r--r--net/gupnp/files/patch-libgupnp-gupnp-control-point.c (renamed from net/gupnp/files/patch-libgupnp_gupnp-control-point.c)0
-rw-r--r--net/gupnp/files/patch-libgupnp-gupnp-device.h12
-rw-r--r--net/gupnp/files/patch-libgupnp-gupnp-service.h12
-rw-r--r--net/gupnp/files/patch-libgupnp-gupnp-services.c (renamed from net/gupnp/files/patch-libgupnp_gupnp-services.c)0
-rw-r--r--net/gupnp/pkg-plist6
8 files changed, 56 insertions, 6 deletions
diff --git a/net/gupnp/Makefile b/net/gupnp/Makefile
index 37943ce31243..14e5651d2fbf 100644
--- a/net/gupnp/Makefile
+++ b/net/gupnp/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gupnp
-PORTVERSION= 0.20.10
+PORTVERSION= 0.20.11
CATEGORIES= net
MASTER_SITES= GNOME
@@ -22,10 +22,17 @@ GNU_CONFIGURE= yes
MAKE_ENV= INSTALL_STRIP_FLAG=${STRIP}
USE_GNOME= glib20 introspection:build
USE_LDCONFIG= yes
+USE_CSTD= c11
USE_PYTHON_RUN= yes
-USES= gmake pathfix pkgconfig shebangfix tar:xz
+USES= compiler:c11 gmake libtool pathfix pkgconfig shebangfix tar:xz
SHEBANG_FILES= tools/gupnp-binding-tool
python_CMD= ${PYTHON_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${CHOSEN_COMPILER_TYPE} == "clang"
+CPPFLAGS+= -Wno-return-type
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/gupnp/distinfo b/net/gupnp/distinfo
index e6d1b2567fca..fc72a23d9f5d 100644
--- a/net/gupnp/distinfo
+++ b/net/gupnp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gupnp-0.20.10.tar.xz) = 5c7f9278b50ed252606552e2f148be4e1b1616bc93ebc8b09b22fcf5d8aa08e4
-SIZE (gupnp-0.20.10.tar.xz) = 382264
+SHA256 (gupnp-0.20.11.tar.xz) = 648ad091c7bae1c2b45ae9b9c0052f8c72903ce740d6e5be945c493dec85c160
+SIZE (gupnp-0.20.11.tar.xz) = 392148
diff --git a/net/gupnp/files/patch-libgupnp-gupnp-acl.h b/net/gupnp/files/patch-libgupnp-gupnp-acl.h
new file mode 100644
index 000000000000..a962ec2b5569
--- /dev/null
+++ b/net/gupnp/files/patch-libgupnp-gupnp-acl.h
@@ -0,0 +1,15 @@
+--- libgupnp/gupnp-acl.h.orig 2014-05-04 20:49:23.000000000 +0800
++++ libgupnp/gupnp-acl.h 2014-05-09 01:00:57.105329801 +0800
+@@ -50,8 +50,12 @@
+ typedef struct _GUPnPAclInterface GUPnPAclInterface;
+
+ /* Forward declarations to avoid recursive includes */
++#if !defined(GUPnPDevice)
+ typedef struct _GUPnPDevice GUPnPDevice;
++#endif
++#if !defined(GUPnPService)
+ typedef struct _GUPnPService GUPnPService;
++#endif
+
+ struct _GUPnPAclInterface {
+ GTypeInterface parent;
diff --git a/net/gupnp/files/patch-libgupnp_gupnp-control-point.c b/net/gupnp/files/patch-libgupnp-gupnp-control-point.c
index d06447aec242..d06447aec242 100644
--- a/net/gupnp/files/patch-libgupnp_gupnp-control-point.c
+++ b/net/gupnp/files/patch-libgupnp-gupnp-control-point.c
diff --git a/net/gupnp/files/patch-libgupnp-gupnp-device.h b/net/gupnp/files/patch-libgupnp-gupnp-device.h
new file mode 100644
index 000000000000..faded8fc8c64
--- /dev/null
+++ b/net/gupnp/files/patch-libgupnp-gupnp-device.h
@@ -0,0 +1,12 @@
+--- libgupnp/gupnp-device.h.orig 2013-12-01 19:32:50.000000000 +0800
++++ libgupnp/gupnp-device.h 2014-05-09 01:24:34.890234566 +0800
+@@ -51,7 +51,9 @@
+ GUPnPDeviceClass))
+
+ typedef struct _GUPnPDevicePrivate GUPnPDevicePrivate;
++#if !defined(GUPnPDevice)
+ typedef struct _GUPnPDevice GUPnPDevice;
++#endif
+ typedef struct _GUPnPDeviceClass GUPnPDeviceClass;
+
+ /**
diff --git a/net/gupnp/files/patch-libgupnp-gupnp-service.h b/net/gupnp/files/patch-libgupnp-gupnp-service.h
new file mode 100644
index 000000000000..cde5dab7f072
--- /dev/null
+++ b/net/gupnp/files/patch-libgupnp-gupnp-service.h
@@ -0,0 +1,12 @@
+--- libgupnp/gupnp-service.h.orig 2013-12-01 19:32:50.000000000 +0800
++++ libgupnp/gupnp-service.h 2014-05-09 01:23:09.030240692 +0800
+@@ -65,7 +65,9 @@
+ #define GUPNP_TYPE_SERVICE_ACTION (gupnp_service_action_get_type ())
+
+ typedef struct _GUPnPServicePrivate GUPnPServicePrivate;
++#if !defined(GUPnPService)
+ typedef struct _GUPnPService GUPnPService;
++#endif
+ typedef struct _GUPnPServiceClass GUPnPServiceClass;
+
+ /**
diff --git a/net/gupnp/files/patch-libgupnp_gupnp-services.c b/net/gupnp/files/patch-libgupnp-gupnp-services.c
index 4d7ba13121ae..4d7ba13121ae 100644
--- a/net/gupnp/files/patch-libgupnp_gupnp-services.c
+++ b/net/gupnp/files/patch-libgupnp-gupnp-services.c
diff --git a/net/gupnp/pkg-plist b/net/gupnp/pkg-plist
index 3f36bb359a95..bd63b1fe78cd 100644
--- a/net/gupnp/pkg-plist
+++ b/net/gupnp/pkg-plist
@@ -1,4 +1,5 @@
bin/gupnp-binding-tool
+include/gupnp-1.0/libgupnp/gupnp-acl.h
include/gupnp-1.0/libgupnp/gupnp-context-manager.h
include/gupnp-1.0/libgupnp/gupnp-context.h
include/gupnp-1.0/libgupnp/gupnp-control-point.h
@@ -18,9 +19,9 @@ include/gupnp-1.0/libgupnp/gupnp-xml-doc.h
include/gupnp-1.0/libgupnp/gupnp.h
lib/girepository-1.0/GUPnP-1.0.typelib
lib/libgupnp-1.0.a
-lib/libgupnp-1.0.la
lib/libgupnp-1.0.so
lib/libgupnp-1.0.so.4
+lib/libgupnp-1.0.so.4.0.0
libdata/pkgconfig/gupnp-1.0.pc
share/gir-1.0/GUPnP-1.0.gir
share/gtk-doc/html/gupnp/GUPnPContext.html
@@ -54,8 +55,10 @@ share/gtk-doc/html/gupnp/home.png
share/gtk-doc/html/gupnp/index.html
share/gtk-doc/html/gupnp/index.sgml
share/gtk-doc/html/gupnp/ix01.html
+share/gtk-doc/html/gupnp/left-insensitive.png
share/gtk-doc/html/gupnp/left.png
share/gtk-doc/html/gupnp/overview.html
+share/gtk-doc/html/gupnp/right-insensitive.png
share/gtk-doc/html/gupnp/right.png
share/gtk-doc/html/gupnp/schemas-device.html
share/gtk-doc/html/gupnp/schemas-service.html
@@ -63,6 +66,7 @@ share/gtk-doc/html/gupnp/schemas.html
share/gtk-doc/html/gupnp/server-tutorial.html
share/gtk-doc/html/gupnp/style.css
share/gtk-doc/html/gupnp/tutorial.html
+share/gtk-doc/html/gupnp/up-insensitive.png
share/gtk-doc/html/gupnp/up.png
@dirrmtry share/gtk-doc/html/gupnp
@dirrmtry share/gtk-doc/html