aboutsummaryrefslogtreecommitdiff
path: root/net/gwhois
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2007-08-28 17:15:10 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2007-08-28 17:15:10 +0000
commit758e9afaad2cfbca1085024ef623ab9e6fb81eec (patch)
tree4e90369751f577dab915b14815075c6e803237ff /net/gwhois
parent70b6fdf3d6a44f4596df8468a0ca5e8cf0addd47 (diff)
downloadports-758e9afaad2cfbca1085024ef623ab9e6fb81eec.tar.gz
ports-758e9afaad2cfbca1085024ef623ab9e6fb81eec.zip
Notes
Diffstat (limited to 'net/gwhois')
-rw-r--r--net/gwhois/Makefile44
-rw-r--r--net/gwhois/distinfo3
-rw-r--r--net/gwhois/pkg-descr12
3 files changed, 59 insertions, 0 deletions
diff --git a/net/gwhois/Makefile b/net/gwhois/Makefile
new file mode 100644
index 000000000000..f2df49858b19
--- /dev/null
+++ b/net/gwhois/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: gwhois
+# Date created: 28 August 2007
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gwhois
+PORTVERSION= 20070822
+CATEGORIES= net
+MASTER_SITES= http://gwhois.de/gwhois/ CENKES
+DISTNAME= ${PORTNAME}_${DISTVERSION}
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= Flexible whois client and proxy
+
+RUN_DEPENDS= p5-libwww>=5.805:${PORTSDIR}/www/p5-libwww \
+ lynx:${PORTSDIR}/www/lynx \
+ curl:${PORTSDIR}/ftp/curl
+
+CONFLICTS= whois-[0-9]*
+NO_BUILD= yes
+USE_PERL5_RUN= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
+PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/pattern
+PLIST_DIRS= %%DATADIR%%
+MAN1= ${PORTNAME}.1
+PORTDOCS= TODO README.RIPE
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/gwhois|${DATADIR}|g'\
+ ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.1
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+ @${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MAN1PREFIX}/man/man1/
+ @${INSTALL} -d ${DATADIR}/
+ @${INSTALL_DATA} ${WRKSRC}/pattern ${DATADIR}/
+.ifndef NOPORTDOCS
+ @${INSTALL} -d ${DOCSDIR}/
+ @cd ${WRKSRC}/&&${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/gwhois/distinfo b/net/gwhois/distinfo
new file mode 100644
index 000000000000..722a3d49a791
--- /dev/null
+++ b/net/gwhois/distinfo
@@ -0,0 +1,3 @@
+MD5 (gwhois_20070822.tar.gz) = 1c50289e46128d916b4c8ac46c4adac2
+SHA256 (gwhois_20070822.tar.gz) = 60813605913e4e2b3151031d709d243e890c9b8a2b4de21b6748d25a431848ae
+SIZE (gwhois_20070822.tar.gz) = 29696
diff --git a/net/gwhois/pkg-descr b/net/gwhois/pkg-descr
new file mode 100644
index 000000000000..e4ec788fce1e
--- /dev/null
+++ b/net/gwhois/pkg-descr
@@ -0,0 +1,12 @@
+gwhois is a generic whois client. It strives to know for all existing
+tlds and all ip address range the appropiate whois server to ask. You
+can simple call gwhois with a query for some domain or some ip and it
+will ask the right server for you! It can even query webforms which
+are unfortunately the only query type supported by many bad nics.
+
+gwhois can also be used as a whois server. You can call it from the
+inetd and make it accessable via a normal standard whois client. This
+allows for example using a windows client and still make use of the
+enhanced features of gwhois.
+
+WWW: http://freshmeat.net/projects/gwhois/