aboutsummaryrefslogtreecommitdiff
path: root/net/hagelslag
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-11-07 12:52:37 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-11-07 12:52:37 +0000
commitdc2190846a4490c208e610f342a00f26834a4084 (patch)
treee1a25561f793803d87813aadfee13c510ac5f182 /net/hagelslag
parent72f445503940beed8f79e5fcb48d405f52d23eff (diff)
downloadports-dc2190846a4490c208e610f342a00f26834a4084.tar.gz
ports-dc2190846a4490c208e610f342a00f26834a4084.zip
Notes
Diffstat (limited to 'net/hagelslag')
-rw-r--r--net/hagelslag/files/patch-src-Makefile12
-rw-r--r--net/hagelslag/files/patch-src-RC-Makefile21
-rw-r--r--net/hagelslag/files/patch-src-SearchManager.cpp10
3 files changed, 38 insertions, 5 deletions
diff --git a/net/hagelslag/files/patch-src-Makefile b/net/hagelslag/files/patch-src-Makefile
index d5a6dc2b97f7..51df1dc46bb1 100644
--- a/net/hagelslag/files/patch-src-Makefile
+++ b/net/hagelslag/files/patch-src-Makefile
@@ -1,12 +1,14 @@
--- src/Makefile.orig Sun Apr 8 19:58:59 2001
-+++ src/Makefile Mon May 7 12:18:41 2001
-@@ -1,5 +1,4 @@
++++ src/Makefile Mon Nov 4 21:24:23 2002
+@@ -1,13 +1,13 @@
# Don't change this...
-CXX=g++
++CXX?=g++
LFLAGS=
- COMMONFLAGS=-Wall -O2 -g
+-COMMONFLAGS=-Wall -O2 -g
++#COMMONFLAGS=-Wall -O2 -g
ROUTER_FLAGS=$(COMMONFLAGS) -DROUTER
-@@ -7,7 +6,7 @@
+ DAEMON_FLAGS=$(COMMONFLAGS) -DDAEMON
CONSOLE_FLAGS=$(COMMONFLAGS) -DCONSOLE
# Change this instead.
@@ -15,7 +17,7 @@
# Nothing below here should be changed
-@@ -98,7 +97,7 @@
+@@ -98,7 +98,7 @@
cp -f UserLib.a ../lib
depend:
diff --git a/net/hagelslag/files/patch-src-RC-Makefile b/net/hagelslag/files/patch-src-RC-Makefile
new file mode 100644
index 000000000000..b860b2d4d418
--- /dev/null
+++ b/net/hagelslag/files/patch-src-RC-Makefile
@@ -0,0 +1,21 @@
+--- src/RC/Makefile.orig Mon Nov 4 21:30:53 2002
++++ src/RC/Makefile Mon Nov 4 21:31:16 2002
+@@ -1,7 +1,7 @@
+ # Don't change this...
+-CXX=g++
++CXX?=g++
+ LFLAGS=
+-CXXFLAGS=-Wall -O2 -g
++#CXXFLAGS=-Wall -O2 -g
+
+ RC_H = RCEntry.h RCParameters.h RCPattern.h RCPacket.h RCQPacket.h \
+ RCQRPacket.h RCMesgID.h RCPacketStorage.h RCSpam.h RCConnectionID.h \
+@@ -23,7 +23,7 @@
+ all: clean depend remotecachelib
+
+ depend:
+- makedepend -Y -- $(RC_CPP)
++ makedepend -- $(RC_CPP)
+
+ clean:
+ rm -f *.o *.a
diff --git a/net/hagelslag/files/patch-src-SearchManager.cpp b/net/hagelslag/files/patch-src-SearchManager.cpp
new file mode 100644
index 000000000000..926b72b89b07
--- /dev/null
+++ b/net/hagelslag/files/patch-src-SearchManager.cpp
@@ -0,0 +1,10 @@
+--- src/SearchManager.cpp.orig Mon Nov 4 21:18:37 2002
++++ src/SearchManager.cpp Mon Nov 4 21:19:01 2002
+@@ -9,6 +9,7 @@
+
+ #include <time.h>
+ #include <stdio.h>
++#include <string.h>
+
+ #include "Config.h"
+ #include "Constants.h"