aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2015-10-21 10:59:46 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2015-10-21 10:59:46 +0000
commita04a706bdd2810b59623983792b7f2e47fdd6d46 (patch)
treea46b15fc32c210b3d01e8adb4c9cb6e79c2574e3 /net/haproxy
parent63b74b76e23efb05d7637bd543109e4dc95ea90d (diff)
downloadports-a04a706bdd2810b59623983792b7f2e47fdd6d46.tar.gz
ports-a04a706bdd2810b59623983792b7f2e47fdd6d46.zip
Notes
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile31
-rw-r--r--net/haproxy/distinfo6
-rw-r--r--net/haproxy/pkg-plist33
3 files changed, 49 insertions, 21 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 2f6936486cd7..60ec29c1675c 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -2,9 +2,10 @@
# $FreeBSD$
PORTNAME= haproxy
-PORTVERSION= 1.5.14
+PORTVERSION= 1.6.1
CATEGORIES= net www
-MASTER_SITES= http://www.haproxy.org/download/1.5/src/
+MASTER_SITES= http://www.haproxy.org/download/1.6/src/
+DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
MAINTAINER= demon@FreeBSD.org
COMMENT= The Reliable, High Performance TCP/HTTP Load Balancer
@@ -17,11 +18,16 @@ CONFLICTS= haproxy-devel-[0-9]*
USES= cpe gmake
USE_RC_SUBR= haproxy
-OPTIONS_DEFINE= DOCS EXAMPLES OPENSSL
+DEVICEATLAS_VERSION= 2.1
+DEVICEATLAS_DISTFILE= deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
+DEVICEATLAS_REGISTRATION_URL= https://deviceatlas.com/deviceatlas-haproxy-module
+
+OPTIONS_DEFINE= DOCS EXAMPLES LUA OPENSSL DEVICEATLAS
OPTIONS_RADIO= PCRE
OPTIONS_RADIO_PCRE= DPCRE SPCRE
DPCRE_DESC= Link dynamically
SPCRE_DESC= Link statically
+DEVICEATLAS_DESC= DeviceAtlas Device Detection support
OPTIONS_DEFAULT= SPCRE OPENSSL
.include <bsd.port.options.mk>
@@ -33,16 +39,35 @@ MAKE_ARGS= TARGET=freebsd DEFINE=-DFREEBSD_PORTS USE_GETADDRINFO=1 \
LIB_DEPENDS+= libpcre.so:${PORTSDIR}/devel/pcre
MAKE_ARGS+= USE_PCRE=1 USE_PCRE_JIT=1
.endif
+
.if ${PORT_OPTIONS:MSPCRE}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libpcre.a:${PORTSDIR}/devel/pcre
MAKE_ARGS+= USE_STATIC_PCRE=1 USE_PCRE_JIT=1
.endif
+.if ${PORT_OPTIONS:MDEVICEATLAS}
+.if !exists(${DISTDIR}/${DEVICEATLAS_DISTFILE}.zip)
+IGNORE?= You must manually fetch the DeviceAtlas Device Detection C API from ${DEVICEATLAS_REGISTRATION_URL} and place it in ${DISTDIR} and then run make again
+.else
+RESTRICTED= The redistribution of the DeviceAtlas Device Detection C API is not permitted
+DISTFILES+= ${DEVICEATLAS_DISTFILE}.zip
+MAKE_ARGS+= USE_DEVICEATLAS=1 DEVICEATLAS_SRC=${WRKDIR}/deviceatlas-enterprise-c-${DEVICEATLAS_VERSION}
+.endif
+.if ! ${PORT_OPTIONS:MDPCRE} && ! ${PORT_OPTIONS:MSPCRE}
+IGNORE?= Enable PCRE support to use DeviceAtlas
+.endif
+.endif
+
.if ${PORT_OPTIONS:MOPENSSL}
USE_OPENSSL= yes
MAKE_ARGS+= USE_OPENSSL=1
.endif
+.if ${PORT_OPTIONS:MLUA}
+USES+= lua:53
+MAKE_ARGS+= USE_LUA=1 LUA_INC=${LUA_INCDIR} LUA_LIB=${LUA_LIBDIR} LUA_LIB_NAME=lua-${LUA_VER}
+.endif
+
post-build:
cd ${WRKSRC}/contrib/halog && ${MAKE_CMD} ${MAKE_ENV}
diff --git a/net/haproxy/distinfo b/net/haproxy/distinfo
index 58725b08f024..72553b225737 100644
--- a/net/haproxy/distinfo
+++ b/net/haproxy/distinfo
@@ -1,2 +1,4 @@
-SHA256 (haproxy-1.5.14.tar.gz) = 9565dd38649064d0350a2883fa81ccfe92eb17dcda457ebdc01535e1ab0c8f99
-SIZE (haproxy-1.5.14.tar.gz) = 1345345
+SHA256 (haproxy-1.6.1.tar.gz) = 71da2abe610ed42afd6678c2e95321db5f3c416fe2803235f75fc459d8246289
+SIZE (haproxy-1.6.1.tar.gz) = 1538337
+SHA256 (deviceatlas-enterprise-c-2.1.zip) = a02fc29486d245b1c8d946c663b71ba981e88fee8d037f5bc1bf255deb287974
+SIZE (deviceatlas-enterprise-c-2.1.zip) = 504286
diff --git a/net/haproxy/pkg-plist b/net/haproxy/pkg-plist
index 019a3c0aedaa..662f61a167ef 100644
--- a/net/haproxy/pkg-plist
+++ b/net/haproxy/pkg-plist
@@ -8,8 +8,6 @@ sbin/haproxy
%%PORTDOCS%%%%DOCSDIR%%/configuration.txt
%%PORTDOCS%%%%DOCSDIR%%/cookie-options.txt
%%PORTDOCS%%%%DOCSDIR%%/gpl.txt
-%%PORTDOCS%%%%DOCSDIR%%/haproxy-en.txt
-%%PORTDOCS%%%%DOCSDIR%%/haproxy-fr.txt
%%PORTDOCS%%%%DOCSDIR%%/haproxy.1
%%PORTDOCS%%%%DOCSDIR%%/lgpl.txt
%%PORTDOCS%%%%DOCSDIR%%/proxy-protocol.txt
@@ -22,10 +20,12 @@ sbin/haproxy
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/buffers.fig
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/config-language.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/connection-reuse.txt
-%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/cttproxy-changes.txt
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/connection-sharing.txt
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/dynamic-buffers.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/entities-v2.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/how-it-works.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/http_load_time.url
+%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/http2.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/rate-shaping.txt
%%PORTDOCS%%%%DOCSDIR%%/design-thoughts/sess_par_sec.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/acl.txt
@@ -39,12 +39,16 @@ sbin/haproxy
%%PORTDOCS%%%%DOCSDIR%%/internals/entities.pdf
%%PORTDOCS%%%%DOCSDIR%%/internals/entities.svg
%%PORTDOCS%%%%DOCSDIR%%/internals/entities.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/entities-v2.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/hashing.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/header-parser-speed.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/header-tree.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/http-cookies.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/http-docs.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/http-parsing.txt
+%%PORTDOCS%%%%DOCSDIR%%/internals/list.fig
+%%PORTDOCS%%%%DOCSDIR%%/internals/lua_socket.fig
+%%PORTDOCS%%%%DOCSDIR%%/internals/lua_socket.pdf
%%PORTDOCS%%%%DOCSDIR%%/internals/naming.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/pattern.dia
%%PORTDOCS%%%%DOCSDIR%%/internals/pattern.pdf
@@ -53,35 +57,32 @@ sbin/haproxy
%%PORTDOCS%%%%DOCSDIR%%/internals/sequence.fig
%%PORTDOCS%%%%DOCSDIR%%/internals/stats-v2.txt
%%PORTDOCS%%%%DOCSDIR%%/internals/stream-sock-states.fig
-%%PORTDOCS%%%%DOCSDIR%%/internals/todo.cttproxy
+%%PORTDOCS%%%%DOCSDIR%%/intro.txt
+%%PORTDOCS%%%%DOCSDIR%%/linux-syn-cookies.txt
+%%PORTDOCS%%%%DOCSDIR%%/lua-api/Makefile
+%%PORTDOCS%%%%DOCSDIR%%/lua-api/_static/channel.fig
+%%PORTDOCS%%%%DOCSDIR%%/lua-api/_static/channel.png
+%%PORTDOCS%%%%DOCSDIR%%/lua-api/conf.py
+%%PORTDOCS%%%%DOCSDIR%%/lua-api/index.rst
+%%PORTDOCS%%%%DOCSDIR%%/management.txt
+%%PORTDOCS%%%%DOCSDIR%%/network-namespaces.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/acl-content-sw.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/auth.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/build.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/check
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/check.conf
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/config.rc.haproxy
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/content-sw-sample.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cttproxy-src.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debug2ansi
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debug2html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/debugfind
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/examples.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy-1.1.21-flx.1.pkg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy.init
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy.spec
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/haproxy.vim
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/init.haproxy
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/init.haproxy.flx0
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/linux-2.4.21-40.EL-custom.diff
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/option-http_proxy.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rc.highsock
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/seamless_reload.txt
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ssl.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stats_haproxy.sh
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tarpit.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/test-section-kw.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/transparent_proxy.cfg
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/url-switching.cfg
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/400.http
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/403.http
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/errorfiles/408.http