aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2017-06-16 13:33:34 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2017-06-16 13:33:34 +0000
commit8e86e36594dac96e5c27a55c004cc07e0bf6bf93 (patch)
treee6869316a691502afb1ee760e2f513bd44a3201c /net/haproxy
parentb9a9de528e4914c5869e440d996b0fc7888991c5 (diff)
downloadports-8e86e36594dac96e5c27a55c004cc07e0bf6bf93.tar.gz
ports-8e86e36594dac96e5c27a55c004cc07e0bf6bf93.zip
Notes
Diffstat (limited to 'net/haproxy')
-rw-r--r--net/haproxy/Makefile3
-rw-r--r--net/haproxy/distinfo6
-rw-r--r--net/haproxy/files/patch-Makefile11
-rw-r--r--net/haproxy/files/patch-fix-dns33
4 files changed, 4 insertions, 49 deletions
diff --git a/net/haproxy/Makefile b/net/haproxy/Makefile
index 627783c57c76..c0f444e3afaa 100644
--- a/net/haproxy/Makefile
+++ b/net/haproxy/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= haproxy
-PORTVERSION= 1.7.5
-PORTREVISION= 3
+PORTVERSION= 1.7.6
CATEGORIES= net www
MASTER_SITES= http://www.haproxy.org/download/1.7/src/
DISTFILES= ${PORTNAME}-${DISTVERSION}${EXTRACT_SUFX}
diff --git a/net/haproxy/distinfo b/net/haproxy/distinfo
index 48a582a8e7ec..ac3ed1980b45 100644
--- a/net/haproxy/distinfo
+++ b/net/haproxy/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1491209100
-SHA256 (haproxy-1.7.5.tar.gz) = b04d7db6383c662eb0a421a95af7becac6d9744a1abf0df6b0280c1e61416121
-SIZE (haproxy-1.7.5.tar.gz) = 1743979
+TIMESTAMP = 1497610528
+SHA256 (haproxy-1.7.6.tar.gz) = 88f84beba34d08a5495d908ca76866e033e6046e7c74f9477b9d5316f8c3d32a
+SIZE (haproxy-1.7.6.tar.gz) = 1744267
SHA256 (deviceatlas-enterprise-c-2.1.2_1.tgz) = 984e1ae3147459a4ed0a8d5053d83dd05ce8c5127cd3cb055be35a74e9217372
SIZE (deviceatlas-enterprise-c-2.1.2_1.tgz) = 184432
diff --git a/net/haproxy/files/patch-Makefile b/net/haproxy/files/patch-Makefile
deleted file mode 100644
index 783ed156b6f6..000000000000
--- a/net/haproxy/files/patch-Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
---- Makefile.orig 2017-06-07 12:10:25.939151000 +0300
-+++ Makefile 2017-06-07 12:11:26.904447000 +0300
-@@ -128,7 +128,7 @@ DEBUG_CFLAGS = -g
- #### Compiler-specific flags that may be used to disable some negative over-
- # optimization or to silence some warnings. -fno-strict-aliasing is needed with
- # gcc >= 4.4.
--SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement
-+SPEC_CFLAGS = -fno-strict-aliasing -Wdeclaration-after-statement -fwrapv
-
- #### Memory usage tuning
- # If small memory footprint is required, you can reduce the buffer size. There
diff --git a/net/haproxy/files/patch-fix-dns b/net/haproxy/files/patch-fix-dns
deleted file mode 100644
index e6aee14ab79a..000000000000
--- a/net/haproxy/files/patch-fix-dns
+++ /dev/null
@@ -1,33 +0,0 @@
-From: Frédéric Lécaille <flecaille@haproxy.com>
-Date: Fri, 12 May 2017 07:57:15 +0000 (+0200)
-Subject: BUG/MAJOR: dns: Broken kqueue events handling (BSD systems).
-X-Git-Url: http://git.haproxy.org/?p=haproxy.git;a=commitdiff_plain;h=64920538fc19f3c7f94dfa1e84a9a6569b8c3d37
-
-BUG/MAJOR: dns: Broken kqueue events handling (BSD systems).
-
-Some DNS related network sockets were closed without unregistering their file
-descriptors from their underlying kqueue event sets. This patch replaces calls to
-close() by fd_delete() calls to that to delete such events attached to DNS
-network sockets from the kqueue before closing the sockets.
-
-The bug was introduced by commit 26c6eb8 ("BUG/MAJOR: dns: restart sockets
-after fork()") which was backported in 1.7 so this fix has to be backported
-there as well.
-
-Thanks to Jim Pingle who reported it and indicated the faulty commit, and
-to Lukas Tribus for the trace showing the bad file descriptor.
----
-
-diff --git a/src/dns.c b/src/dns.c
-index a118598..cb0a9a9 100644
---- src/dns.c
-+++ src/dns.c
-@@ -1004,7 +1004,7 @@ int dns_init_resolvers(int close_socket)
-
- if (close_socket == 1) {
- if (curnameserver->dgram) {
-- close(curnameserver->dgram->t.sock.fd);
-+ fd_delete(curnameserver->dgram->t.sock.fd);
- memset(curnameserver->dgram, '\0', sizeof(*dgram));
- dgram = curnameserver->dgram;
- }