aboutsummaryrefslogtreecommitdiff
path: root/net/hf6to4/Makefile
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-04 12:25:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-04 12:25:02 +0000
commitfca15c081ccc4af2ea2f99ea823a5634e339b826 (patch)
tree6e6e9203f7660554356cf938d1f95c22599f2708 /net/hf6to4/Makefile
parent39a4d69331f1e606e85add1a2155236a0e7902b0 (diff)
downloadports-fca15c081ccc4af2ea2f99ea823a5634e339b826.tar.gz
ports-fca15c081ccc4af2ea2f99ea823a5634e339b826.zip
Notes
Diffstat (limited to 'net/hf6to4/Makefile')
-rw-r--r--net/hf6to4/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/net/hf6to4/Makefile b/net/hf6to4/Makefile
new file mode 100644
index 000000000000..9a612b36308f
--- /dev/null
+++ b/net/hf6to4/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: hf6to4
+# Date created: 26 September 2003
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hf6to4
+PORTVERSION= 1.1
+CATEGORIES= net ipv6
+MASTER_SITES= http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/pkgsrc/net/hf6to4/files/
+DISTFILES= hf6to4\?rev=1.2\&content-type=text%2fplain \
+ hf6to4.8\?rev=1.2\&content-type=text%2fplain \
+ hf6to4.conf\?rev=1.2\&content-type=text%2fplain
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= Enables 6to4 IPv6 automatic tunnels
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+MAN8= hf6to4.8
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+.for i in ${DISTFILES}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${i} ${WRKSRC}/${i:C/\?.*$//}
+.endfor
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/pkg|${PREFIX}|g' \
+ ${WRKSRC}/hf6to4 ${WRKSRC}/hf6to4.8
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/hf6to4 ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/hf6to4.8 ${PREFIX}/man/man8
+ ${INSTALL_DATA} ${WRKSRC}/hf6to4.conf ${PREFIX}/etc/hf6to4.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>