aboutsummaryrefslogtreecommitdiff
path: root/net/hf6to4
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2003-10-04 12:25:02 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2003-10-04 12:25:02 +0000
commitfca15c081ccc4af2ea2f99ea823a5634e339b826 (patch)
tree6e6e9203f7660554356cf938d1f95c22599f2708 /net/hf6to4
parent39a4d69331f1e606e85add1a2155236a0e7902b0 (diff)
downloadports-fca15c081ccc4af2ea2f99ea823a5634e339b826.tar.gz
ports-fca15c081ccc4af2ea2f99ea823a5634e339b826.zip
Notes
Diffstat (limited to 'net/hf6to4')
-rw-r--r--net/hf6to4/Makefile43
-rw-r--r--net/hf6to4/distinfo3
-rw-r--r--net/hf6to4/pkg-descr10
-rw-r--r--net/hf6to4/pkg-message7
-rw-r--r--net/hf6to4/pkg-plist2
5 files changed, 65 insertions, 0 deletions
diff --git a/net/hf6to4/Makefile b/net/hf6to4/Makefile
new file mode 100644
index 000000000000..9a612b36308f
--- /dev/null
+++ b/net/hf6to4/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: hf6to4
+# Date created: 26 September 2003
+# Whom: Kimura Fuyuki <fuyuki@nigredo.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= hf6to4
+PORTVERSION= 1.1
+CATEGORIES= net ipv6
+MASTER_SITES= http://cvsweb.netbsd.org/bsdweb.cgi/~checkout~/pkgsrc/net/hf6to4/files/
+DISTFILES= hf6to4\?rev=1.2\&content-type=text%2fplain \
+ hf6to4.8\?rev=1.2\&content-type=text%2fplain \
+ hf6to4.conf\?rev=1.2\&content-type=text%2fplain
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= fuyuki@nigredo.org
+COMMENT= Enables 6to4 IPv6 automatic tunnels
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+
+MAN8= hf6to4.8
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+.for i in ${DISTFILES}
+ ${CP} ${DISTDIR}/${DIST_SUBDIR}/${i} ${WRKSRC}/${i:C/\?.*$//}
+.endfor
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/pkg|${PREFIX}|g' \
+ ${WRKSRC}/hf6to4 ${WRKSRC}/hf6to4.8
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/hf6to4 ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/hf6to4.8 ${PREFIX}/man/man8
+ ${INSTALL_DATA} ${WRKSRC}/hf6to4.conf ${PREFIX}/etc/hf6to4.conf.sample
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/net/hf6to4/distinfo b/net/hf6to4/distinfo
new file mode 100644
index 000000000000..65403bdd0d19
--- /dev/null
+++ b/net/hf6to4/distinfo
@@ -0,0 +1,3 @@
+MD5 (hf6to4/hf6to4?rev=1.2&content-type=text%2fplain) = 1c622ba30f949d9ef02690a6e1d557d4
+MD5 (hf6to4/hf6to4.8?rev=1.2&content-type=text%2fplain) = e16aa3435ed0ee2f9e0017da9150487e
+MD5 (hf6to4/hf6to4.conf?rev=1.2&content-type=text%2fplain) = 11ea51fb80fe77f0ca1dc480d8171bf1
diff --git a/net/hf6to4/pkg-descr b/net/hf6to4/pkg-descr
new file mode 100644
index 000000000000..05e40b959f30
--- /dev/null
+++ b/net/hf6to4/pkg-descr
@@ -0,0 +1,10 @@
+The hf6to4 script can be used to setup IPv6 on your home machine and
+network for exploring IPv6 without any registrations. 6to4 is a
+mechanism by which your IPv6 address(es) are derived from an assigned
+IPv4 address, and which involves automatic tunnelling to one or more
+remote 6to4 hubs, which will then forward your v6 packets on the 6bone
+etc. Replies are routed back to you over IPv4 via (possibly) other
+6to4 capable remote gateways. As such, IPv6-in-IPv4-encapsulated
+packets are accepted from all v4-hosts.
+
+WWW: http://www.NetBSD.org/packages/net/hf6to4/files/hf6to4.html
diff --git a/net/hf6to4/pkg-message b/net/hf6to4/pkg-message
new file mode 100644
index 000000000000..0ca97fcc5673
--- /dev/null
+++ b/net/hf6to4/pkg-message
@@ -0,0 +1,7 @@
+===========================================================================
+
+To configure this package, adjust ${PREFIX}/etc/hf6to4.conf from
+${PREFIX}/etc/hf6to4.conf.sample, then start "hf6to4 -v start".
+You should be able to "ping6 www.kame.net" after that.
+
+===========================================================================
diff --git a/net/hf6to4/pkg-plist b/net/hf6to4/pkg-plist
new file mode 100644
index 000000000000..c25bc2f6c47c
--- /dev/null
+++ b/net/hf6to4/pkg-plist
@@ -0,0 +1,2 @@
+sbin/hf6to4
+etc/hf6to4.conf.sample