aboutsummaryrefslogtreecommitdiff
path: root/net/honeyd
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>2020-09-22 14:30:41 +0000
committerStefan Eßer <se@FreeBSD.org>2020-09-22 14:30:41 +0000
commitf05bac3f363569ae1e852145fa7ab29b14774bc4 (patch)
tree2534a13f0fb56d51506eebd563d34413eb729700 /net/honeyd
parent1590ec2e8c94a0ee21fddee0a8ee663e7abbe66b (diff)
downloadports-f05bac3f363569ae1e852145fa7ab29b14774bc4.tar.gz
ports-f05bac3f363569ae1e852145fa7ab29b14774bc4.zip
Fix build with -fno-common
portlint complains that the patches have not been generated with makepatch and this caused some effort to generate the patches for this update. I'm leaving the legacy patches and the EXTRA_PATCH as-is to not cause unneccessary churn, but IMHO the patches should be regenerated with makepatch on occasion of the next major change to this port.
Notes
Notes: svn path=/head/; revision=549600
Diffstat (limited to 'net/honeyd')
-rw-r--r--net/honeyd/Makefile2
-rw-r--r--net/honeyd/files/patch-personality.c5
-rw-r--r--net/honeyd/files/patch-personality.h22
-rw-r--r--net/honeyd/files/patch-stats.h31
-rw-r--r--net/honeyd/files/patch-tagging.h33
5 files changed, 91 insertions, 2 deletions
diff --git a/net/honeyd/Makefile b/net/honeyd/Makefile
index 6288ef487859..f4c5b1f2f979 100644
--- a/net/honeyd/Makefile
+++ b/net/honeyd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= honeyd
PORTVERSION= 1.5c
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= net
MASTER_SITES= http://www.honeyd.org/uploads/ \
http://www.citi.umich.edu/u/provos/honeyd/
diff --git a/net/honeyd/files/patch-personality.c b/net/honeyd/files/patch-personality.c
index 31ecd385a3f9..353dfc579459 100644
--- a/net/honeyd/files/patch-personality.c
+++ b/net/honeyd/files/patch-personality.c
@@ -1,11 +1,14 @@
--- personality.c.orig Thu Apr 14 16:07:26 2005
+++ personality.c Thu Apr 14 12:57:11 2005
-@@ -64,6 +64,8 @@
+@@ -64,6 +64,11 @@
#include "xprobe_assoc.h"
#include "template.h"
+//#define DEBUG_XPROBE_STRUCT
+
++personalities_t personalities;
++xp_fprints_t xp_fprints;
++
/* ET - Moved SPLAY_HEAD to personality.h so xprobe_assoc.c could use it. */
int npersons;
diff --git a/net/honeyd/files/patch-personality.h b/net/honeyd/files/patch-personality.h
new file mode 100644
index 000000000000..70cece647a58
--- /dev/null
+++ b/net/honeyd/files/patch-personality.h
@@ -0,0 +1,22 @@
+--- personality.h.orig 2007-05-28 08:12:52.000000000 +0200
++++ personality.h 2020-09-22 15:57:29.215618000 +0200
+@@ -179,7 +179,8 @@
+ void print_perstree(void);
+
+ /* Splay stuff here so other modules can use it */
+-SPLAY_HEAD(perstree, personality) personalities;
++typedef SPLAY_HEAD(perstree, personality) personalities_t;
++extern personalities_t personalities;
+ static int
+ perscompare(struct personality *a, struct personality *b)
+ {
+@@ -187,7 +187,8 @@
+ }
+ SPLAY_PROTOTYPE(perstree, personality, node, perscompare);
+
+-SPLAY_HEAD(xp_fprint_tree, xp_fingerprint) xp_fprints;
++typedef SPLAY_HEAD(xp_fprint_tree, xp_fingerprint) xp_fprints_t;
++extern xp_fprints_t xp_fprints;
+ static int
+ xp_fprint_compare(struct xp_fingerprint *a, struct xp_fingerprint *b)
+ {
diff --git a/net/honeyd/files/patch-stats.h b/net/honeyd/files/patch-stats.h
new file mode 100644
index 000000000000..c8f2478a3418
--- /dev/null
+++ b/net/honeyd/files/patch-stats.h
@@ -0,0 +1,31 @@
+--- stats.h.orig 2007-05-28 06:12:52 UTC
++++ stats.h
+@@ -89,10 +89,12 @@ struct stats {
+ reserved:4;
+ };
+
+-enum {
++typedef enum {
+ M_COUNTER, M_TV_START, M_TV_END, M_RECORD, M_MAX
+-} measurement_tags;
++} measurement_tags_t;
+
++extern measurement_tags_t measurement_tags;
++
+ struct measurement {
+ uint32_t counter;
+ struct timeval tv_start;
+@@ -103,9 +105,11 @@ struct measurement {
+ #define SHA1_DIGESTSIZE 20
+ #endif
+
+-enum {
++typedef enum {
+ SIG_NAME, SIG_DIGEST, SIG_DATA, SIG_COMPRESSED_DATA, SIG_MAX
+-} signature_tags;
++} signature_tags_t;
++
++extern signature_tags_t signature_tags;
+
+ struct signature {
+ char *name;
diff --git a/net/honeyd/files/patch-tagging.h b/net/honeyd/files/patch-tagging.h
new file mode 100644
index 000000000000..379130e96da6
--- /dev/null
+++ b/net/honeyd/files/patch-tagging.h
@@ -0,0 +1,33 @@
+--- tagging.h.orig 2020-09-22 13:41:40 UTC
++++ tagging.h
+@@ -44,12 +44,14 @@ struct hash {
+ u_char digest[SHINGLE_SIZE];
+ };
+
+-enum {
++typedef enum {
+ REC_TV_START, REC_TV_END, REC_SRC, REC_DST, REC_SRC_PORT, REC_DST_PORT,
+ REC_PROTO, REC_STATE, REC_OS_FP, REC_HASH, REC_BYTES, REC_FLAGS,
+ REC_MAX_TAGS
+-} record_tags;
++} record_tags_t;
+
++extern record_tags_t record_tags;
++
+ #define RECORD_STATE_NEW 0x01
+
+ struct record {
+@@ -69,9 +71,11 @@ struct record {
+ TAILQ_HEAD(hashq, hash) hashes; /* optional */
+ };
+
+-enum {
++typedef enum {
+ ADDR_TYPE, ADDR_BITS, ADDR_ADDR, ADDR_MAX_TAGS
+-} address_tags;
++} address_tags_t;
++
++extern address_tags_t address_tags;
+
+ void record_marshal(struct evbuffer *, struct record *);
+