aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2016-09-13 05:01:26 +0000
committerJohn Marino <marino@FreeBSD.org>2016-09-13 05:01:26 +0000
commitd1a8bdcf64243b62c65a58d0814892f5bc03d4df (patch)
tree22a84252850b1d1ee367905fbacd6636fc5b7804 /net/hostapd
parent82207d5ad41c651a93b32fd74853e3d6e37513e1 (diff)
Notes
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile25
1 files changed, 4 insertions, 21 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index f7fa07011982..bd93e7dd6f8f 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hostapd
PORTVERSION= 2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://w1.fi/releases/
@@ -12,31 +12,14 @@ COMMENT= IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
LICENSE= BSD3CLAUSE
-USES= cpe gmake
+USES= cpe gmake ssl
CPE_VENDOR= w1.f1
-USE_OPENSSL= yes
BUILD_WRKSRC= ${WRKSRC}/hostapd
+CONFIGURE_ARGS= --with-ssl-dir=${OPENSSLBASE}
PLIST_FILES= sbin/hostapd sbin/hostapd_cli man/man1/hostapd_cli.1.gz \
man/man8/hostapd.8.gz
-OPTIONS_DEFINE= PORTS_SSL
-
-PORTS_SSL_DESC= Build with OpenSSL from ports (instead of base system)
-
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MPORTS_SSL}
-.if ${SSL_DEFAULT} == base
-IGNORE= the PORTS_SSL option not allowed when using SSL from base
-.endif
-CONFIGURE_ARGS+= --with-ssl-dir=${PREFIX}
-.else
-.if ${SSL_DEFAULT} != base
-IGNORE= the PORTS_SSL option is required when using SSL from ports
-.endif
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|@$$(E) " CC " $$<|@$$(E) " $$(CC) " $$<|' \
${BUILD_WRKSRC}/Makefile
@@ -52,4 +35,4 @@ do-install:
${INSTALL_MAN} ${WRKSRC}/hostapd/hostapd.8 \
${STAGEDIR}${MANPREFIX}/man/man8
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>