aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-10-16 07:19:52 +0000
committerJohn Marino <marino@FreeBSD.org>2014-10-16 07:19:52 +0000
commitc919d396b82ddd07202763f6025b778155347044 (patch)
tree3b8d9217a9372d9f9309c96b8643c3024d0635e9 /net/hostapd
parent9e58cdde2d54b88ff64570f1216858225f7020e2 (diff)
downloadports-c919d396b82ddd07202763f6025b778155347044.tar.gz
ports-c919d396b82ddd07202763f6025b778155347044.zip
Notes
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile7
-rw-r--r--net/hostapd/distinfo4
-rw-r--r--net/hostapd/files/config81
3 files changed, 66 insertions, 26 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index 41357d819435..0a4d0b878d22 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= hostapd
-PORTVERSION= 2.2
+PORTVERSION= 2.3
CATEGORIES= net
MASTER_SITES= http://w1.fi/releases/
@@ -24,9 +24,8 @@ BROKEN_sparc64= does not compile
post-patch:
@${REINPLACE_CMD} -e 's|@$$(E) " CC " $$<|@$$(E) " $$(CC) " $$<|' \
${BUILD_WRKSRC}/Makefile
-
-do-configure:
- ${CP} ${FILESDIR}/config ${WRKSRC}/hostapd/.config
+ @${SED} -e 's|@PREFIX@|${PREFIX}|g' ${FILESDIR}/config \
+ >> ${WRKSRC}/hostapd/.config
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${STAGEDIR}${PREFIX}/sbin
diff --git a/net/hostapd/distinfo b/net/hostapd/distinfo
index 2f64b3f8972c..4d3f03d82153 100644
--- a/net/hostapd/distinfo
+++ b/net/hostapd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hostapd-2.2.tar.gz) = f15b6bcb434378860ea5b88dffed7f54d8cb71fff2146de0f006977a5e25a882
-SIZE (hostapd-2.2.tar.gz) = 1586482
+SHA256 (hostapd-2.3.tar.gz) = c94c2b76876fad4c80a1063a06f958a2189ba5003475016fa7658a1ca49bb4df
+SIZE (hostapd-2.3.tar.gz) = 1592480
diff --git a/net/hostapd/files/config b/net/hostapd/files/config
index 1217fd74d6c6..de05f3384a1a 100644
--- a/net/hostapd/files/config
+++ b/net/hostapd/files/config
@@ -21,19 +21,25 @@
# Driver interface for drivers using the nl80211 kernel interface
#CONFIG_DRIVER_NL80211=y
-# driver_nl80211.c requires a rather new libnl (version 1.1) which may not be
-# shipped with your distribution yet. If that is the case, you need to build
-# newer libnl version and point the hostapd build to use it.
-#LIBNL=/usr/src/libnl
-#CFLAGS += -I$(LIBNL)/include
-#LIBS += -L$(LIBNL)/lib
+
+# driver_nl80211.c requires libnl. If you are compiling it yourself
+# you may need to point hostapd to your version of libnl.
+#
+#CFLAGS += -I$<path to libnl include files>
+#LIBS += -L$<path to libnl library files>
+
+# Use libnl v2.0 (or 3.0) libraries.
+#CONFIG_LIBNL20=y
+
+# Use libnl 3.2 libraries (if this is selected, CONFIG_LIBNL20 is ignored)
+#CONFIG_LIBNL32=y
# Driver interface for FreeBSD net80211 layer (e.g., Atheros driver)
CONFIG_DRIVER_BSD=y
-CFLAGS += -I/usr/local/include
-LIBS += -L/usr/local/lib
-LIBS_p += -L/usr/local/lib
-LIBS_c += -L/usr/local/lib
+CFLAGS += -I@PREFIX@/include
+LIBS += -L@PREFIX@/lib
+LIBS_p += -L@PREFIX@/lib
+LIBS_c += -L@PREFIX@/lib
# Driver interface for no driver (e.g., RADIUS server only)
#CONFIG_DRIVER_NONE=y
@@ -48,9 +54,6 @@ CONFIG_RSN_PREAUTH=y
#CONFIG_PEERKEY=y
# IEEE 802.11w (management frame protection)
-# This version is an experimental implementation based on IEEE 802.11w/D1.0
-# draft and is subject to change since the standard has not yet been finalized.
-# Driver support is also needed for IEEE 802.11w.
#CONFIG_IEEE80211W=y
# Integrated EAP server
@@ -102,16 +105,13 @@ CONFIG_EAP_TTLS=y
#CONFIG_EAP_GPSK_SHA256=y
# EAP-FAST for the integrated EAP server
-# Note: Default OpenSSL package does not include support for all the
-# functionality needed for EAP-FAST. If EAP-FAST is enabled with OpenSSL,
-# the OpenSSL library must be patched (openssl-0.9.9-session-ticket.patch)
-# to add the needed functions.
+# Note: If OpenSSL is used as the TLS library, OpenSSL 1.0 or newer is needed
+# for EAP-FAST support. Older OpenSSL releases would need to be patched, e.g.,
+# with openssl-0.9.8x-tls-extensions.patch, to add the needed functions.
#CONFIG_EAP_FAST=y
# Wi-Fi Protected Setup (WPS)
#CONFIG_WPS=y
-# Enable WSC 2.0 support
-#CONFIG_WPS2=y
# Enable UPnP support for external WPS Registrars
#CONFIG_WPS_UPNP=y
# Enable WPS support with NFC config method
@@ -123,6 +123,9 @@ CONFIG_EAP_TTLS=y
# Trusted Network Connect (EAP-TNC)
#CONFIG_EAP_TNC=y
+# EAP-EKE for the integrated EAP server
+#CONFIG_EAP_EKE=y
+
# PKCS#12 (PFX) support (used to read private key and certificate file from
# a file that usually has extension .p12 or .pfx)
CONFIG_PKCS12=y
@@ -160,6 +163,12 @@ CONFIG_DRIVER_RADIUS_ACL=y
# Disabled by default.
#CONFIG_DEBUG_FILE=y
+# Add support for sending all debug messages (regardless of debug verbosity)
+# to the Linux kernel tracing facility. This helps debug the entire stack by
+# making it easy to record everything happening from the driver up into the
+# same file, e.g., using trace-cmd.
+#CONFIG_DEBUG_LINUX_TRACING=y
+
# Remove support for RADIUS accounting
#CONFIG_NO_ACCOUNTING=y
@@ -177,7 +186,7 @@ CONFIG_DRIVER_RADIUS_ACL=y
# Note: This requires libnl 3.1 or newer.
#CONFIG_VLAN_NETLINK=y
-# Remove support for dumping state into a file on SIGUSR1 signal
+# Remove support for dumping internal state through control interface commands
# This can be used to reduce binary size at the cost of disabling a debugging
# option.
#CONFIG_NO_DUMP_STATE=y
@@ -273,3 +282,35 @@ CONFIG_DRIVER_RADIUS_ACL=y
# Enable SQLite database support in hlr_auc_gw, EAP-SIM DB, and eap_user_file
#CONFIG_SQLITE=y
+
+# Testing options
+# This can be used to enable some testing options (see also the example
+# configuration file) that are really useful only for testing clients that
+# connect to this hostapd. These options allow, for example, to drop a
+# certain percentage of probe requests or auth/(re)assoc frames.
+#
+#CONFIG_TESTING_OPTIONS=y
+
+# Automatic Channel Selection
+# This will allow hostapd to pick the channel automatically when channel is set
+# to "acs_survey" or "0". Eventually, other ACS algorithms can be added in
+# similar way.
+#
+# Automatic selection is currently only done through initialization, later on
+# we hope to do background checks to keep us moving to more ideal channels as
+# time goes by. ACS is currently only supported through the nl80211 driver and
+# your driver must have survey dump capability that is filled by the driver
+# during scanning.
+#
+# You can customize the ACS survey algorithm with the hostapd.conf variable
+# acs_num_scans.
+#
+# Supported ACS drivers:
+# * ath9k
+# * ath5k
+# * ath10k
+#
+# For more details refer to:
+# http://wireless.kernel.org/en/users/Documentation/acs
+#
+#CONFIG_ACS=y