aboutsummaryrefslogtreecommitdiff
path: root/net/hostapd
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-06-18 22:27:36 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-06-18 22:27:36 +0000
commit78171b51aef7b7bb832673c282bce5e32fcaecf6 (patch)
treec34246dfb7ee38002b6e858fb19b227d9e94c72e /net/hostapd
parent2c588fec996b28380b707f73bcfe08e4db3ef09d (diff)
Notes
Diffstat (limited to 'net/hostapd')
-rw-r--r--net/hostapd/Makefile39
-rw-r--r--net/hostapd/distinfo4
2 files changed, 21 insertions, 22 deletions
diff --git a/net/hostapd/Makefile b/net/hostapd/Makefile
index a3c46954a196..99a342c2d6f2 100644
--- a/net/hostapd/Makefile
+++ b/net/hostapd/Makefile
@@ -6,44 +6,43 @@
#
PORTNAME= hostapd
-PORTVERSION= 0.7.3
+PORTVERSION= 1.0
CATEGORIES= net
MASTER_SITES= http://hostap.epitest.fi/releases/
-DISTNAME= ${PORTNAME}-${PORTVERSION}
MAINTAINER= leres@ee.lbl.gov
COMMENT= IEEE 802.11 AP, IEEE 802.1X/WPA/WPA2/EAP/RADIUS Authenticator
+LICENSE= GPLv2 BSD
+LICENSE_COMB= dual
+
USE_GMAKE= yes
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+MAKE_JOBS_SAFE= yes
MAN1= hostapd_cli.1
MAN8= hostapd.8
-do-configure:
- ${CP} ${FILESDIR}/config ${WRKSRC}/hostapd/.config
-
-do-build:
- (cd ${WRKSRC}/hostapd && ${GMAKE})
-
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${PREFIX}/sbin
- ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd_cli ${PREFIX}/sbin
- ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN1} ${PREFIX}/man/man1
- ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN8} ${PREFIX}/man/man8
-
PLIST_FILES= sbin/hostapd \
sbin/hostapd_cli
-#MAKE_JOBS_SAFE= yes
-#MANCOMPRESSED= yes
-
-LICENSE= GPLv1 BSD
-LICENSE_COMB= dual
-
.include <bsd.port.pre.mk>
.if ${ARCH} == "ia64" || ${ARCH} == "powerpc" || ${ARCH} == "sparc64"
BROKEN= Does not compile on ia64, powerpc, or sparc64
.endif
+post-patch-script:
+ @${REINPLACE_CMD} -e 's|@$$(E) " CC " $$<|@$$(E) " $$(CC) " $$<|' \
+ ${BUILD_WRKSRC}/Makefile
+
+do-configure:
+ ${CP} ${FILESDIR}/config ${WRKSRC}/hostapd/.config
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd ${PREFIX}/sbin
+ ${INSTALL_PROGRAM} ${WRKSRC}/hostapd/hostapd_cli ${PREFIX}/sbin
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN1} ${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/hostapd/${MAN8} ${MAN8PREFIX}/man/man8
+
.include <bsd.port.post.mk>
diff --git a/net/hostapd/distinfo b/net/hostapd/distinfo
index 3a5799214c63..8029e5a9562f 100644
--- a/net/hostapd/distinfo
+++ b/net/hostapd/distinfo
@@ -1,2 +1,2 @@
-SHA256 (hostapd-0.7.3.tar.gz) = 31eb2781f37e1a4c27969d1594f8019c0ca87779349c099ab812833289961567
-SIZE (hostapd-0.7.3.tar.gz) = 1138869
+SHA256 (hostapd-1.0.tar.gz) = 002e9dcb7e46cf82b5900a2fcf92b30fc8cdfd32a72d7fd4488588f1c013dfcc
+SIZE (hostapd-1.0.tar.gz) = 1327943