aboutsummaryrefslogtreecommitdiff
path: root/net/howl
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-04-15 08:45:06 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-04-15 08:45:06 +0000
commit6fdc4e6b80fde09b6a1646c79d6e8a4e8ee71bad (patch)
tree3654f32fecafe5ab932fc28570f857950581c21b /net/howl
parent774d76633dce27ec8138138b555ab3c57250955a (diff)
downloadports-6fdc4e6b80fde09b6a1646c79d6e8a4e8ee71bad.tar.gz
ports-6fdc4e6b80fde09b6a1646c79d6e8a4e8ee71bad.zip
Notes
Diffstat (limited to 'net/howl')
-rw-r--r--net/howl/Makefile5
-rw-r--r--net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c11
2 files changed, 16 insertions, 0 deletions
diff --git a/net/howl/Makefile b/net/howl/Makefile
index 16324fef90e6..c392cb6a10b9 100644
--- a/net/howl/Makefile
+++ b/net/howl/Makefile
@@ -18,9 +18,14 @@ USE_GMAKE= yes
USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
+USE_REINPLACE= yes
MAN8= mDNSResponder.8
PLIST_SUB= VERSION="${PORTVERSION}"
+post-patch:
+ @${REINPLACE_CMD} -e 's|-pthread||g' ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c b/net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c
new file mode 100644
index 000000000000..3f4ed9ba8c59
--- /dev/null
+++ b/net/howl/files/patch-src_lib_howl_NotOSX_notosx_mdns.c
@@ -0,0 +1,11 @@
+--- src/lib/howl/NotOSX/notosx_mdns.c.orig Thu Apr 15 10:34:27 2004
++++ src/lib/howl/NotOSX/notosx_mdns.c Thu Apr 15 10:34:38 2004
+@@ -54,7 +54,7 @@
+ #include <salt/assert.h>
+ #include <salt/log.h>
+ #include <stdio.h>
+-
++#include <sys/time.h>
+
+ #define CACHE_SIZE 750
+