aboutsummaryrefslogtreecommitdiff
path: root/net/hping
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-05-19 10:09:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-05-19 10:09:57 +0000
commit4731a77526c8f8f6bac64e3e7b87efb9b0ca8b0a (patch)
tree533d8a7011e8f69abd1cddffada968c4d5a136b3 /net/hping
parenta99d21980f8f9a9d0f8cedb1359d1f42c63b62e2 (diff)
downloadports-4731a77526c8f8f6bac64e3e7b87efb9b0ca8b0a.tar.gz
ports-4731a77526c8f8f6bac64e3e7b87efb9b0ca8b0a.zip
Notes
Diffstat (limited to 'net/hping')
-rw-r--r--net/hping/Makefile9
-rw-r--r--net/hping/distinfo4
-rw-r--r--net/hping/files/patch-Makefile.in28
-rw-r--r--net/hping/files/patch-memlockall11
-rw-r--r--net/hping/files/patch-memunlockall11
-rw-r--r--net/hping/files/patch-warnings145
6 files changed, 30 insertions, 178 deletions
diff --git a/net/hping/Makefile b/net/hping/Makefile
index db529bea3ce0..182fd071ae95 100644
--- a/net/hping/Makefile
+++ b/net/hping/Makefile
@@ -6,24 +6,23 @@
#
PORTNAME= hping
-PORTVERSION= 2.0.0r2
-PORTREVISION= 3
+PORTVERSION= 2.0.0r3
PORTEPOCH= 1
CATEGORIES= security net
MASTER_SITES= http://www.hping.org/
-DISTNAME= hping2.0.0-rc2
+DISTNAME= hping2.0.0-rc3
MAINTAINER= ecu@ipv42.net
COMMENT= Network auditing tool
-WRKSRC= ${WRKDIR}/hping2-rc2
+WRKSRC= ${WRKDIR}/hping2-rc3
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --force-libpcap
USE_GMAKE= yes
PLIST_FILES= sbin/hping
PORTDOCS= AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN \
- MORE-FUN-WITH-IPID SPOOFED_SCAN.txt
+ MORE-FUN-WITH-IPID SPOOFED_SCAN.txt APD.txt
MAN8= hping.8
diff --git a/net/hping/distinfo b/net/hping/distinfo
index 1bdf7183c989..4af755068086 100644
--- a/net/hping/distinfo
+++ b/net/hping/distinfo
@@ -1,2 +1,2 @@
-MD5 (hping2.0.0-rc2.tar.gz) = f9ab1f84ec89f2a1c428988231d554b0
-SIZE (hping2.0.0-rc2.tar.gz) = 100501
+MD5 (hping2.0.0-rc3.tar.gz) = 029bf240f2e0545b664b2f8b9118d9e8
+SIZE (hping2.0.0-rc3.tar.gz) = 124573
diff --git a/net/hping/files/patch-Makefile.in b/net/hping/files/patch-Makefile.in
index 07e0dd9d3ddc..da0dfa76aff1 100644
--- a/net/hping/files/patch-Makefile.in
+++ b/net/hping/files/patch-Makefile.in
@@ -1,13 +1,33 @@
---- Makefile.in.orig Wed Aug 15 04:02:53 2001
-+++ Makefile.in Mon Nov 18 09:10:12 2002
-@@ -6,8 +6,8 @@
+--- Makefile.in.orig Mon May 3 11:29:39 2004
++++ Makefile.in Wed May 19 11:23:43 2004
+@@ -6,10 +6,10 @@
# $date: Sun Jul 25 17:56:15 MET DST 1999$
# $rev: 3$
-CC= gcc
--CCOPT= -O2 -Wall @PCAP_INCLUDE@
+CC?= gcc
+ AR=/usr/bin/ar
+ RANLIB=/usr/bin/ranlib
+-CCOPT= -O2 -Wall @PCAP_INCLUDE@
+CCOPT= -Wall @CFLAGS@ @PCAP_INCLUDE@
DEBUG= -g
#uncomment the following if you need libpcap based build under linux
#(not raccomanded)
+@@ -43,7 +43,7 @@
+ $(RANLIB) $@
+
+ hping2: byteorder.h $(OBJ)
+- $(CC) -o hping2 $(CCOPT) $(DEBUG) $(OBJ) $(PCAP) @SOLARISLIB@
++ $(CC) -o hping2 $(CCOPT) $(OBJ) $(PCAP) @SOLARISLIB@
+ @echo
+ ./hping2 -v
+ @echo "use \`make strip' to strip hping2 binary"
+@@ -53,7 +53,7 @@
+ ./configure
+
+ .c.o:
+- $(CC) -c $(CCOPT) $(DEBUG) $(COMPILE_TIME) $<
++ $(CC) -c $(CCOPT) $(COMPILE_TIME) $<
+
+ clean:
+ rm -rf hping2 *.o *.a
diff --git a/net/hping/files/patch-memlockall b/net/hping/files/patch-memlockall
deleted file mode 100644
index e613a3f17a22..000000000000
--- a/net/hping/files/patch-memlockall
+++ /dev/null
@@ -1,11 +0,0 @@
---- memlockall.c.orig Sun Nov 17 18:04:44 2002
-+++ memlockall.c Sun Nov 17 18:04:43 2002
-@@ -13,7 +13,7 @@
-
- int memlockall(void)
- {
--#ifdef _POSIX_MEMLOCK
-+#if _POSIX_MEMLOCK == 1
- return ( mlockall(MCL_CURRENT|MCL_FUTURE) );
- #endif
- return (-1);
diff --git a/net/hping/files/patch-memunlockall b/net/hping/files/patch-memunlockall
deleted file mode 100644
index 4a67466433f7..000000000000
--- a/net/hping/files/patch-memunlockall
+++ /dev/null
@@ -1,11 +0,0 @@
---- memunlockall.c.orig Sun Nov 17 18:04:44 2002
-+++ memunlockall.c Sun Nov 17 18:04:43 2002
-@@ -13,7 +13,7 @@
-
- int memunlockall(void)
- {
--#ifdef _POSIX_MEMLOCK
-+#if _POSIX_MEMLOCK == 1
- return ( munlockall() );
- #endif
- return(-1);
diff --git a/net/hping/files/patch-warnings b/net/hping/files/patch-warnings
deleted file mode 100644
index 4ded8a219920..000000000000
--- a/net/hping/files/patch-warnings
+++ /dev/null
@@ -1,145 +0,0 @@
-*** datafiller.c.org Sun Mar 30 13:18:24 2003
---- datafiller.c Sun Mar 30 13:20:22 2003
-***************
-*** 14,19 ****
---- 14,20 ----
- #include <sys/stat.h>
- #include <fcntl.h>
- #include <string.h> /* memset */
-+ #include <stdlib.h>
-
- #include "hping2.h"
- #include "globals.h"
-
-
-*** libpcap_stuff.c.org Sun Mar 30 13:19:42 2003
---- libpcap_stuff.c Sun Mar 30 13:25:51 2003
-***************
-*** 17,22 ****
---- 17,23 ----
- #include <sys/ioctl.h>
- #include <pcap.h>
- #include <net/bpf.h>
-+ #include <string.h>
-
- #include "globals.h"
-
-
-*** listen.c.org Sun Mar 30 13:19:24 2003
---- listen.c Sun Mar 30 13:24:31 2003
-***************
-*** 14,19 ****
---- 14,20 ----
- #include <sys/types.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
-+ #include <stdlib.h>
-
- #include "hping2.h" /* hping2.h includes hcmp.h */
- #include "globals.h"
-
-
-*** resolve.c.org Sun Mar 30 13:18:51 2003
---- resolve.c Sun Mar 30 13:22:02 2003
-***************
-*** 15,20 ****
---- 15,21 ----
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include <arpa/inet.h>
-+ #include <stdlib.h>
-
- void resolve (struct sockaddr * addr, char *hostname)
- {
-
-
-*** rtt.c.org Sun Mar 30 13:19:33 2003
---- rtt.c Mon Mar 31 17:32:40 2003
-***************
-*** 72,82 ****
- printf("\n\nSANITY CHECK in rtt.c FAILED!\n");
- printf("- seqnum = %d\n", *seqp);
- printf("- status = %d\n", status);
-! printf("- get_usec() = %ld\n", get_usec());
-! printf("- delaytable.usec = %ld\n", delaytable[tablepos].usec);
-! printf("- usec_delay = %ld\n", usec_delay);
-! printf("- time(NULL) = %ld\n", time(NULL));
-! printf("- delaytable.sec = %ld\n", delaytable[tablepos].sec);
- printf("- sec_delay = %ld\n", sec_delay);
- printf("- ms_delay = %f\n", *ms_delay);
- printf("END SANITY CHECK REPORT\n\n");
---- 72,83 ----
- printf("\n\nSANITY CHECK in rtt.c FAILED!\n");
- printf("- seqnum = %d\n", *seqp);
- printf("- status = %d\n", status);
-! /* time_t is __int32_t on i386 FreeBSD */
-! printf("- get_usec() = %ld\n", (long)get_usec());
-! printf("- delaytable.usec = %ld\n", (long)delaytable[tablepos].usec);
-! printf("- usec_delay = %ld\n", (long)usec_delay);
-! printf("- time(NULL) = %ld\n", (long)time(NULL));
-! printf("- delaytable.sec = %ld\n", (long)delaytable[tablepos].sec);
- printf("- sec_delay = %ld\n", sec_delay);
- printf("- ms_delay = %f\n", *ms_delay);
- printf("END SANITY CHECK REPORT\n\n");
-
-
-*** statistics.c.org Sun Mar 30 13:19:02 2003
---- statistics.c Sun Mar 30 13:22:18 2003
-***************
-*** 9,14 ****
---- 9,15 ----
- */
-
- #include <stdio.h>
-+ #include <stdlib.h>
-
- #include "hping2.h"
- #include "globals.h"
-
-
-*** version.c.org Sun Mar 30 13:19:17 2003
---- version.c Sun Mar 30 13:23:17 2003
-***************
-*** 9,14 ****
---- 9,15 ----
- */
-
- #include <stdio.h>
-+ #include <stdlib.h>
-
- #include "release.h"
- #include "hping2.h"
-
-
-*** waitpacket.c.org Sun Mar 30 13:18:32 2003
---- waitpacket.c Sun Mar 30 20:28:13 2003
-***************
-*** 13,18 ****
---- 13,19 ----
- #include <time.h>
- #include <ctype.h>
- #include <unistd.h>
-+ #include <stdlib.h>
-
- #include "hping2.h"
- #include "globals.h"
-
-*** waitpacket.c.org Sun Mar 30 13:18:32 2003
---- waitpacket.c Sun Mar 30 20:28:13 2003
-***************
-*** 179,185 ****
- (unsigned int) ntohl(icmp_tstamp.orig),
- (unsigned int) ntohl(icmp_tstamp.recv),
- (unsigned int) ntohl(icmp_tstamp.tran));
-! printf("ICMP timestamp RTT tsrtt=%lu\n\n",
- (get_midnight_ut_ms() - ntohl(icmp_tstamp.orig)));
- }
-
---- 180,186 ----
- (unsigned int) ntohl(icmp_tstamp.orig),
- (unsigned int) ntohl(icmp_tstamp.recv),
- (unsigned int) ntohl(icmp_tstamp.tran));
-! printf("ICMP timestamp RTT tsrtt=%u\n\n",
- (get_midnight_ut_ms() - ntohl(icmp_tstamp.orig)));
- }
-