aboutsummaryrefslogtreecommitdiff
path: root/net/hping
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 08:45:12 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-28 08:45:12 +0000
commit3c6b7d1811206a041987065015dc8fef69d47579 (patch)
treef7a134e3c5b0c2bfde5a66b94e047e15cec3bdb4 /net/hping
parent3263b0b11d2f00912cef2a9d1934e628d77e8e79 (diff)
downloadports-3c6b7d1811206a041987065015dc8fef69d47579.tar.gz
ports-3c6b7d1811206a041987065015dc8fef69d47579.zip
Notes
Diffstat (limited to 'net/hping')
-rw-r--r--net/hping/Makefile19
1 files changed, 9 insertions, 10 deletions
diff --git a/net/hping/Makefile b/net/hping/Makefile
index 4626eec673ea..4616be84dfe8 100644
--- a/net/hping/Makefile
+++ b/net/hping/Makefile
@@ -15,25 +15,24 @@ COMMENT= Network auditing tool
CONFLICTS= hping-devel-[0-9]*
WRKSRC= ${WRKDIR}/hping2-rc3
+
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --force-libpcap
-USE_GMAKE= yes
-PLIST_FILES= sbin/hping
+PLIST_FILES= sbin/hping man/man8/hping.8.gz
PORTDOCS= AS-BACKDOOR HPING2-HOWTO.txt HPING2-IS-OPEN \
MORE-FUN-WITH-IPID SPOOFED_SCAN.txt APD.txt
-MAN8= hping.8
+OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${PREFIX}/sbin/hping
- ${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 ${PREFIX}/man/man8/hping.8
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/hping2 ${STAGEDIR}${PREFIX}/sbin/hping
+ ${INSTALL_MAN} ${WRKSRC}/docs/hping2.8 \
+ ${STAGEDIR}${MANPREFIX}/man/man8/hping.8
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in ${PORTDOCS}
- ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${DOCSDIR}/
+ ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${STAGEDIR}${DOCSDIR}
.endfor
-.endif
.include <bsd.port.mk>