aboutsummaryrefslogtreecommitdiff
path: root/net/hs-connection
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
committerGabor Pali <pgj@FreeBSD.org>2014-08-10 22:34:50 +0000
commitcc555442337c7591ab5c3fd19ad8e3e185a256b0 (patch)
treea6a0dfa4f440949889fc7b609c83f74555f6894e /net/hs-connection
parent5e492199d1e024a681c6d21087c8d948cb3b7bc3 (diff)
Notes
Diffstat (limited to 'net/hs-connection')
-rw-r--r--net/hs-connection/Makefile17
-rw-r--r--net/hs-connection/distinfo2
-rw-r--r--net/hs-connection/pkg-descr6
3 files changed, 25 insertions, 0 deletions
diff --git a/net/hs-connection/Makefile b/net/hs-connection/Makefile
new file mode 100644
index 000000000000..54f5adf2975a
--- /dev/null
+++ b/net/hs-connection/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= connection
+PORTVERSION= 0.2.3
+CATEGORIES= net haskell
+
+MAINTAINER= haskell@FreeBSD.org
+COMMENT= Simple and easy network connections API
+
+LICENSE= BSD3CLAUSE
+
+USE_CABAL= cprng-aes data-default-class network>=2.3 socks>=0.4 \
+ tls>=1.2 x509>=1.4 x509-store>=1.4 x509-system>=1.4 \
+ x509-validation>=1.5
+
+.include "${.CURDIR}/../../lang/ghc/bsd.cabal.mk"
+.include <bsd.port.mk>
diff --git a/net/hs-connection/distinfo b/net/hs-connection/distinfo
new file mode 100644
index 000000000000..b8a65f4ee764
--- /dev/null
+++ b/net/hs-connection/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cabal/connection-0.2.3.tar.gz) = 4b6f62d66bebc38052e98f2b6798acdb79c9171b170d2e059aaa697d53b0b80a
+SIZE (cabal/connection-0.2.3.tar.gz) = 7621
diff --git a/net/hs-connection/pkg-descr b/net/hs-connection/pkg-descr
new file mode 100644
index 000000000000..aad4e8aab151
--- /dev/null
+++ b/net/hs-connection/pkg-descr
@@ -0,0 +1,6 @@
+Simple network library for all your connection need. Features: Really
+simple to use, SSL/TLS, SOCKS. This library provides a very simple api
+to create sockets to a destination with the choice of SSL/TLS, and
+SOCKS.
+
+WWW: http://github.com/vincenthz/hs-connection