aboutsummaryrefslogtreecommitdiff
path: root/net/httping/Makefile
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2006-07-26 15:17:48 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2006-07-26 15:17:48 +0000
commit995b350e61b273dfaa2c8d1fb241c69d5d28eaf9 (patch)
tree9c4095e7ee91d1aff6a471a82a4882eac56d9cf8 /net/httping/Makefile
parent026ac5e53a861776f702b5a7e9e89653d3222617 (diff)
downloadports-995b350e61b273dfaa2c8d1fb241c69d5d28eaf9.tar.gz
ports-995b350e61b273dfaa2c8d1fb241c69d5d28eaf9.zip
Notes
Diffstat (limited to 'net/httping/Makefile')
-rw-r--r--net/httping/Makefile19
1 files changed, 3 insertions, 16 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 6d1ff105f738..601f219c7b23 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -6,34 +6,21 @@
#
PORTNAME= httping
-PORTVERSION= 1.0.10
+PORTVERSION= 1.2.1
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
http://critical.ch/distfiles/ \
- http://energy.critical.ch/distfiles/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ehaupt
+ http://energy.critical.ch/distfiles/
EXTRACT_SUFX= .tgz
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A ping-like tool for HTTP requests
-CFLAGS+= -DVERSION=\"${PORTVERSION}\"
-LDFLAGS+= -lssl -lcrypto
-
-SRC= http io str error utils main tcp mssl res
MAN1= httping.1
PLIST_FILES= bin/httping
-do-build:
-.for f in ${SRC}
- ${CC} ${CFLAGS} -c ${WRKSRC}/${f}.c -o ${WRKSRC}/${f}.o
-.endfor
- ${CC} ${LDFLAGS} ${SRC:C/(.*)/${WRKSRC}\/\1.o/} \
- -o ${WRKSRC}/${PORTNAME}
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
.include <bsd.port.mk>