aboutsummaryrefslogtreecommitdiff
path: root/net/httping
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2013-03-20 11:08:11 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2013-03-20 11:08:11 +0000
commitdd81d4da07ae5e595d2389acf5b56f8bc96349ff (patch)
tree501631e99c9ee6c6151924b10567e78aaeff055f /net/httping
parent000acbf8b9115ec51736a4426fdc05a6e445be60 (diff)
downloadports-dd81d4da07ae5e595d2389acf5b56f8bc96349ff.tar.gz
ports-dd81d4da07ae5e595d2389acf5b56f8bc96349ff.zip
Notes
Diffstat (limited to 'net/httping')
-rw-r--r--net/httping/Makefile4
-rw-r--r--net/httping/distinfo4
-rw-r--r--net/httping/files/patch-Makefile29
-rw-r--r--net/httping/files/patch-mssl.c13
4 files changed, 35 insertions, 15 deletions
diff --git a/net/httping/Makefile b/net/httping/Makefile
index 779c6df7eb3c..92a9b86af42e 100644
--- a/net/httping/Makefile
+++ b/net/httping/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= httping
-PORTVERSION= 1.6
+PORTVERSION= 2.0
CATEGORIES= net
MASTER_SITES= http://www.vanheusden.com/httping/ \
CRITICAL
@@ -17,8 +17,6 @@ MAKE_JOBS_SAFE= yes
MAN1= httping.1
PLIST_FILES= bin/httping
-CFLAGS+= -D_GNU_SOURCE
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MANPREFIX}/man/man1
diff --git a/net/httping/distinfo b/net/httping/distinfo
index e63fe702cab6..7e6ebcaf96de 100644
--- a/net/httping/distinfo
+++ b/net/httping/distinfo
@@ -1,2 +1,2 @@
-SHA256 (httping-1.6.tgz) = ac98e013a0b476804e2f6df8f8fb3d889646633d3b326d8355a5592d27477534
-SIZE (httping-1.6.tgz) = 18429
+SHA256 (httping-2.0.tgz) = 9fcb1fef706d12149ce88dec5a3e03888d1386a80017324104453130eaeffbe0
+SIZE (httping-2.0.tgz) = 22375
diff --git a/net/httping/files/patch-Makefile b/net/httping/files/patch-Makefile
index eaecec44cf31..6b1eca32b2f9 100644
--- a/net/httping/files/patch-Makefile
+++ b/net/httping/files/patch-Makefile
@@ -1,15 +1,12 @@
---- ./Makefile.orig 2012-10-18 14:26:39.000000000 +0200
-+++ ./Makefile 2012-10-18 14:27:54.000000000 +0200
-@@ -16,13 +16,11 @@
+--- ./Makefile.orig 2013-03-19 20:10:16.000000000 +0100
++++ ./Makefile 2013-03-20 11:56:23.000000000 +0100
+@@ -18,12 +18,11 @@
- TARGET=httping
-
--DEBUG=yes
--WFLAGS=-Wall -W
+ DEBUG=yes
+ WFLAGS=-Wall -W
-OFLAGS=-O3
--CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
-+DEBUG=no
-+CFLAGS+=-DVERSION=\"$(VERSION)\"
+ CFLAGS+=$(WFLAGS) $(OFLAGS) -DVERSION=\"$(VERSION)\"
+ LDFLAGS=-lm
PACKAGE=$(TARGET)-$(VERSION)
-PREFIX=/usr
@@ -17,3 +14,15 @@
BINDIR=$(PREFIX)/bin
MANDIR=$(PREFIX)/share/man
DOCDIR=$(PREFIX)/share/doc/$(TARGET)
+@@ -59,11 +58,6 @@
+ CFLAGS+=-DTCP_TFO
+ endif
+
+-ifeq ($(DEBUG),yes)
+-CFLAGS+=-D_DEBUG -ggdb
+-LDFLAGS+=-g
+-endif
+-
+ ifeq ($(ARM),yes)
+ CC=arm-linux-gcc
+ endif
diff --git a/net/httping/files/patch-mssl.c b/net/httping/files/patch-mssl.c
new file mode 100644
index 000000000000..0c750130efb4
--- /dev/null
+++ b/net/httping/files/patch-mssl.c
@@ -0,0 +1,13 @@
+--- ./mssl.c.orig 2013-03-19 20:10:16.000000000 +0100
++++ ./mssl.c 2013-03-20 11:55:44.000000000 +0100
+@@ -165,8 +165,10 @@
+
+ SSL_CTX *ctx = SSL_CTX_new(meth);
+
++#ifdef SSL_OP_NO_COMPRESSION
+ if (!ask_compression)
+ SSL_CTX_set_options(ctx, SSL_OP_NO_COMPRESSION);
++#endif
+
+ return ctx;
+ }