aboutsummaryrefslogtreecommitdiff
path: root/net/hupnp
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-25 15:17:57 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-09-25 15:17:57 +0000
commit2eca7e4753094729304681caee3fae8aa331e848 (patch)
tree07b10f78ad296ea9e7062652a67aa27a2a317e10 /net/hupnp
parent31e1db43ed59ff468c74db7650f6815022982825 (diff)
downloadports-2eca7e4753094729304681caee3fae8aa331e848.tar.gz
ports-2eca7e4753094729304681caee3fae8aa331e848.zip
Notes
Diffstat (limited to 'net/hupnp')
-rw-r--r--net/hupnp/Makefile3
-rw-r--r--net/hupnp/files/patch-hmulticast_socket.cpp4
-rw-r--r--net/hupnp/files/patch-hupnp__src__devicehosting__devicehost__hpresence_announcer_p.h4
3 files changed, 7 insertions, 4 deletions
diff --git a/net/hupnp/Makefile b/net/hupnp/Makefile
index 35472027e9dd..70592e96f5f2 100644
--- a/net/hupnp/Makefile
+++ b/net/hupnp/Makefile
@@ -11,6 +11,9 @@ DISTNAME= herqq-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Library for building UPnP devices and control points
+LICENSE= LGPL3 # or later
+LICENSE_FILE= ${WRKSRC}/hupnp/LICENSE_LGPLv3.txt
+
USES= gmake qmake zip
USE_QT4= corelib network xml dbus gui \
moc_build rcc_build uic_build
diff --git a/net/hupnp/files/patch-hmulticast_socket.cpp b/net/hupnp/files/patch-hmulticast_socket.cpp
index de79da5e8870..c6e292a57bb7 100644
--- a/net/hupnp/files/patch-hmulticast_socket.cpp
+++ b/net/hupnp/files/patch-hmulticast_socket.cpp
@@ -1,5 +1,5 @@
---- ./hupnp/src/socket/hmulticast_socket.cpp.orig 2011-03-28 00:42:32.000000000 +0300
-+++ ./hupnp/src/socket/hmulticast_socket.cpp 2013-09-10 00:35:26.000000000 +0300
+--- hupnp/src/socket/hmulticast_socket.cpp.orig 2011-03-27 20:42:32 UTC
++++ hupnp/src/socket/hmulticast_socket.cpp
@@ -26,7 +26,10 @@
#include <winsock2.h>
#include <ws2tcpip.h>
diff --git a/net/hupnp/files/patch-hupnp__src__devicehosting__devicehost__hpresence_announcer_p.h b/net/hupnp/files/patch-hupnp__src__devicehosting__devicehost__hpresence_announcer_p.h
index 6177c3684c9b..78d6399f8985 100644
--- a/net/hupnp/files/patch-hupnp__src__devicehosting__devicehost__hpresence_announcer_p.h
+++ b/net/hupnp/files/patch-hupnp__src__devicehosting__devicehost__hpresence_announcer_p.h
@@ -1,5 +1,5 @@
---- ./hupnp/src/devicehosting/devicehost/hpresence_announcer_p.h.orig 2012-01-24 10:41:39.103825710 +0100
-+++ ./hupnp/src/devicehosting/devicehost/hpresence_announcer_p.h 2012-01-24 10:42:13.739148738 +0100
+--- hupnp/src/devicehosting/devicehost/hpresence_announcer_p.h.orig 2011-03-27 20:42:32 UTC
++++ hupnp/src/devicehosting/devicehost/hpresence_announcer_p.h
@@ -31,6 +31,7 @@
//