aboutsummaryrefslogtreecommitdiff
path: root/net/icb/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 20:41:02 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2001-01-14 20:41:02 +0000
commite06a80eebec042c43e3d9e5e7ce92817109d4f36 (patch)
tree6c36a33fcd1e58d8700668ba087b6f8295634d23 /net/icb/Makefile
parent6a83c602cb5a4249479963e0f643f50676ff94a4 (diff)
Notes
Diffstat (limited to 'net/icb/Makefile')
-rw-r--r--net/icb/Makefile22
1 files changed, 11 insertions, 11 deletions
diff --git a/net/icb/Makefile b/net/icb/Makefile
index 9fef78942758..bfd936a21994 100644
--- a/net/icb/Makefile
+++ b/net/icb/Makefile
@@ -8,26 +8,26 @@
PORTNAME= icb
PORTVERSION= 5.1.0
-CATEGORIES= net
-MASTER_SITES= http://ftp.obfuscation.org/ftp/pub/icb/ \
+PORTREVISION= 1
+CATEGORIES= net tcl82
+MASTER_SITES= http://www.obfuscation.org/ftp/pub/icb/ \
ftp://ftp.obfuscation.org/pub/icb/
-DISTNAME= cicb-${PORTVERSION}
+DISTNAME= c${PORTNAME}-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-BUILD_DEPENDS= tclsh8.3:${PORTSDIR}/lang/tcl83
+LIB_DEPENDS= tcl82.1:${PORTSDIR}/lang/tcl82
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tclinclude=${LOCALBASE}/include/tcl8.2 \
+ --with-tcllib=${LOCALBASE}/lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/icb/icb ${PREFIX}/bin
- ${INSTALL} -d -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} \
- ${PREFIX}/share/icb
+ @${MKDIR} ${PREFIX}/share/icb
${INSTALL_DATA} ${WRKSRC}/icbserverdb ${PREFIX}/share/icb
- ${INSTALL_DATA} ${WRKSRC}/contrib/sample.icbrc \
- ${WRKSRC}/contrib/bartender \
- ${WRKSRC}/contrib/confuse \
- ${WRKSRC}/contrib/echofunctions \
- ${PREFIX}/share/icb
+.for file in bartender confuse echofunctions sample.icbrc
+ ${INSTALL_DATA} ${WRKSRC}/contrib/${file} ${PREFIX}/share/icb
+.endfor
.include <bsd.port.mk>