aboutsummaryrefslogtreecommitdiff
path: root/net/iet
diff options
context:
space:
mode:
authorXin LI <delphij@FreeBSD.org>2014-10-30 18:31:45 +0000
committerXin LI <delphij@FreeBSD.org>2014-10-30 18:31:45 +0000
commitc21e021186a1fe4e9d8bdbad06aebd5db73052c1 (patch)
tree9301f72695c9f68f8a6615026411f51bf3878178 /net/iet
parent76c3908ce151b3986e26e117a2510ddc0d3b753b (diff)
downloadports-c21e021186a1fe4e9d8bdbad06aebd5db73052c1.tar.gz
ports-c21e021186a1fe4e9d8bdbad06aebd5db73052c1.zip
Notes
Diffstat (limited to 'net/iet')
-rw-r--r--net/iet/Makefile2
-rw-r--r--net/iet/files/patch-soo_ioctl20
2 files changed, 21 insertions, 1 deletions
diff --git a/net/iet/Makefile b/net/iet/Makefile
index 2c8b18994a87..6accc7c97243 100644
--- a/net/iet/Makefile
+++ b/net/iet/Makefile
@@ -3,7 +3,7 @@
PORTNAME= iet
PORTVERSION= 1.4.20.2
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= net kld
MASTER_SITES= SF/iscsitarget/iscsitarget/${PORTVERSION}/
DISTNAME= iscsitarget-${PORTVERSION}
diff --git a/net/iet/files/patch-soo_ioctl b/net/iet/files/patch-soo_ioctl
new file mode 100644
index 000000000000..9da60ef95bb8
--- /dev/null
+++ b/net/iet/files/patch-soo_ioctl
@@ -0,0 +1,20 @@
+--- kernel/nthread.c.orig 2014-10-30 11:29:21.000000000 -0700
++++ kernel/nthread.c 2014-10-30 11:30:14.000000000 -0700
+@@ -91,7 +91,7 @@
+ return 0;
+ #endif
+
+- error = soo_ioctl(&filetmp, FIONREAD, &avail, NULL, curthread);
++ error = fo_ioctl(&filetmp, FIONREAD, &avail, NULL, curthread);
+ if (error)
+ return 0;
+
+@@ -350,7 +350,7 @@
+ filetmp.f_data = conn->sock;
+ filetmp.f_cred = NULL;
+
+- error = soo_ioctl(&filetmp, FIONSPACE, &avail, NULL, curthread);
++ error = fo_ioctl(&filetmp, FIONSPACE, &avail, NULL, curthread);
+ if (error)
+ return 0;
+