aboutsummaryrefslogtreecommitdiff
path: root/net/iffinder/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-02-18 16:29:53 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-02-18 16:29:53 +0000
commit6369f028363de2035252cb0d4ac4412899d6fcdc (patch)
treedbb9d10185027b3db27b08a787db11543d7a2e16 /net/iffinder/Makefile
parentceca892ba2189061d021eafa2f35805a21483d2b (diff)
Notes
Diffstat (limited to 'net/iffinder/Makefile')
-rw-r--r--net/iffinder/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/net/iffinder/Makefile b/net/iffinder/Makefile
index c1155456efc2..318f1e4f320d 100644
--- a/net/iffinder/Makefile
+++ b/net/iffinder/Makefile
@@ -9,6 +9,8 @@ MASTER_SITES= http://www.caida.org/tools/measurement/iffinder/download/
MAINTAINER= dikshie@sfc.wide.ad.jp
COMMENT= Tools for find other interfaces for same router
+OPTIONS_DEFINE= DOCS
+
LICENSE= BSD2CLAUSE
GNU_CONFIGURE= yes
@@ -16,16 +18,11 @@ GNU_CONFIGURE= yes
PLIST_FILES= bin/iffinder
PORTDOCS= README
-.include <bsd.port.options.mk>
-.if ${OSVERSION} < 1000100
-@${REINPLACE_CMD} -e 's|CC=gcc|CC=clang|g' ${WRKSRC}/Makefile.in
-.endif
+MAKE_ARGS+= CC="${CC}"
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/iffinder ${STAGEDIR}${PREFIX}/bin
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/iffinder ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>