aboutsummaryrefslogtreecommitdiff
path: root/net/ifstated
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-02-06 07:21:39 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-02-06 07:21:39 +0000
commit521fa4943110f70eddb53e4c610435eb8a7c0583 (patch)
treec28da1a5947020802b5427eae242c520a3eb3134 /net/ifstated
parent56c42f611a9ba02be089568560ba0a574cba7f6d (diff)
downloadports-521fa4943110f70eddb53e4c610435eb8a7c0583.tar.gz
ports-521fa4943110f70eddb53e4c610435eb8a7c0583.zip
Notes
Diffstat (limited to 'net/ifstated')
-rw-r--r--net/ifstated/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/net/ifstated/Makefile b/net/ifstated/Makefile
index 7455a7a23fff..1e8ab0c46b99 100644
--- a/net/ifstated/Makefile
+++ b/net/ifstated/Makefile
@@ -12,27 +12,23 @@ COMMENT= Interface state daemon
LIB_DEPENDS= event-1:${PORTSDIR}/devel/libevent
-MAN5= ifstated.conf.5
-MAN8= ifstated.8
-
PLIST_FILES= etc/ifstated.conf-sample \
- sbin/ifstated
+ sbin/ifstated \
+ man/man5/ifstated.conf.5.gz \
+ man/man8/ifstated.8.gz
+
SUB_FILES= pkg-message
USE_RC_SUBR= ifstated
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' ${WRKSRC}/ifstated.conf.5
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/ifstated ${PREFIX}/sbin
- ${INSTALL_DATA} ${WRKSRC}/ifstated.conf-sample ${PREFIX}/etc
- ${INSTALL_MAN} ${WRKSRC}/ifstated.conf.5 ${PREFIX}/man/man5
- ${INSTALL_MAN} ${WRKSRC}/ifstated.8 ${PREFIX}/man/man8
-
-post-install:
- @${CAT} ${PKGMESSAGE}
+ ${INSTALL_PROGRAM} ${WRKSRC}/ifstated ${STAGEDIR}${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/ifstated.conf-sample ${STAGEDIR}${PREFIX}/etc
+ ${INSTALL_MAN} ${WRKSRC}/ifstated.conf.5 ${STAGEDIR}${PREFIX}/man/man5
+ ${INSTALL_MAN} ${WRKSRC}/ifstated.8 ${STAGEDIR}${PREFIX}/man/man8
.include <bsd.port.mk>