aboutsummaryrefslogtreecommitdiff
path: root/net/ifstated
diff options
context:
space:
mode:
authorRyan Steinmetz <zi@FreeBSD.org>2012-03-28 01:42:25 +0000
committerRyan Steinmetz <zi@FreeBSD.org>2012-03-28 01:42:25 +0000
commit9ff471ed2967205e3697055fa027e27786c776a8 (patch)
treecb5f5cb3e8edfb09a21d72fa95ea291bbb710dca /net/ifstated
parent95ebe9f438081e11be75d034f28b1ad6f7d83723 (diff)
downloadports-9ff471ed2967205e3697055fa027e27786c776a8.tar.gz
ports-9ff471ed2967205e3697055fa027e27786c776a8.zip
Notes
Diffstat (limited to 'net/ifstated')
-rw-r--r--net/ifstated/Makefile3
-rw-r--r--net/ifstated/distinfo4
-rw-r--r--net/ifstated/files/patch-ifstated.c23
3 files changed, 14 insertions, 16 deletions
diff --git a/net/ifstated/Makefile b/net/ifstated/Makefile
index bf4851182384..dece5ede7496 100644
--- a/net/ifstated/Makefile
+++ b/net/ifstated/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ifstated
-PORTVERSION= 4.7
-PORTREVISION= 2
+PORTVERSION= 5.1
PORTEPOCH= 1
CATEGORIES= net
MASTER_SITES= http://christianserving.org/ports/net/ifstated/
diff --git a/net/ifstated/distinfo b/net/ifstated/distinfo
index 7a06a627e2a3..8edf22565886 100644
--- a/net/ifstated/distinfo
+++ b/net/ifstated/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ifstated-4.7.tar.gz) = 68381cc577f4f323f90477c1a9bb090a369c3dd098d5baf5175c20941961a7af
-SIZE (ifstated-4.7.tar.gz) = 15057
+SHA256 (ifstated-5.1.tar.gz) = b5073994acf31111da2da938075b20d92cfe87616448081bcd7120087c2a8642
+SIZE (ifstated-5.1.tar.gz) = 15149
diff --git a/net/ifstated/files/patch-ifstated.c b/net/ifstated/files/patch-ifstated.c
index 20ba118f5bb9..2f55d7c94194 100644
--- a/net/ifstated/files/patch-ifstated.c
+++ b/net/ifstated/files/patch-ifstated.c
@@ -1,5 +1,5 @@
---- ifstated.c.orig 2010-06-11 12:20:08.000000000 -0500
-+++ ifstated.c 2010-07-30 21:55:03.045444649 -0500
+--- ifstated.c.orig 2011-07-03 23:34:14.000000000 -0500
++++ ifstated.c 2012-03-23 14:32:56.412119431 -0500
@@ -26,9 +26,11 @@
#include <sys/time.h>
#include <sys/ioctl.h>
@@ -66,7 +66,7 @@
case 'v':
if (opts & IFSD_OPT_VERBOSE)
opts |= IFSD_OPT_VERBOSE2;
-@@ -159,7 +168,6 @@
+@@ -156,7 +165,6 @@
startup_handler(int fd, short event, void *arg)
{
int rt_fd;
@@ -74,7 +74,7 @@
if ((rt_fd = socket(PF_ROUTE, SOCK_RAW, 0)) < 0)
err(1, "no routing socket");
-@@ -169,11 +177,24 @@
+@@ -166,11 +174,24 @@
exit(1);
}
@@ -104,16 +104,15 @@
event_set(&rt_msg_ev, rt_fd, EV_READ|EV_PERSIST, rt_msg_handler, NULL);
event_add(&rt_msg_ev, NULL);
-@@ -406,6 +427,8 @@
+@@ -403,6 +424,7 @@
}
}
-+#define LINK_STATE_IS_UP(_s) \
-+ ((_s) >= LINK_STATE_UP)
- #define LINK_STATE_IS_DOWN(_s) \
- (!LINK_STATE_IS_UP((_s)) && (_s) != LINK_STATE_UNKNOWN)
++#define LINK_STATE_IS_UP(_s) ((_s) >= LINK_STATE_UP)
+ #define LINK_STATE_IS_DOWN(_s) (!LINK_STATE_IS_UP((_s)))
-@@ -584,6 +607,44 @@
+ int
+@@ -580,6 +602,44 @@
}
}
@@ -158,7 +157,7 @@
/*
* Fetch the current link states.
*/
-@@ -593,26 +654,31 @@
+@@ -589,26 +649,31 @@
struct ifaddrs *ifap, *ifa;
char *oname = NULL;
int sock = socket(AF_INET, SOCK_DGRAM, 0);
@@ -198,7 +197,7 @@
}
freeifaddrs(ifap);
close(sock);
-@@ -707,3 +773,13 @@
+@@ -703,3 +768,13 @@
}
free(expression);
}