aboutsummaryrefslogtreecommitdiff
path: root/net/imapproxy
diff options
context:
space:
mode:
authorMichael Landin <mich@FreeBSD.org>2003-07-29 16:19:04 +0000
committerMichael Landin <mich@FreeBSD.org>2003-07-29 16:19:04 +0000
commit188b292236f79448e0b8825911ba9b79abb72b5e (patch)
tree772a8afa2421697f0b7fd9a304b4f1cc683ce19a /net/imapproxy
parentff700cf229fba2d2eb2ffa9c19dd0f4c17ee74bc (diff)
downloadports-188b292236f79448e0b8825911ba9b79abb72b5e.tar.gz
ports-188b292236f79448e0b8825911ba9b79abb72b5e.zip
Notes
Diffstat (limited to 'net/imapproxy')
-rw-r--r--net/imapproxy/Makefile24
-rw-r--r--net/imapproxy/distinfo1
-rw-r--r--net/imapproxy/files/patch-aa10
-rw-r--r--net/imapproxy/files/patch-ab10
-rw-r--r--net/imapproxy/files/patch-ac13
-rw-r--r--net/imapproxy/files/patch-ad11
-rw-r--r--net/imapproxy/pkg-descr10
-rw-r--r--net/imapproxy/pkg-plist2
8 files changed, 81 insertions, 0 deletions
diff --git a/net/imapproxy/Makefile b/net/imapproxy/Makefile
new file mode 100644
index 000000000000..c55cbe6898c1
--- /dev/null
+++ b/net/imapproxy/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: imapproxy
+# Date created: Mon July 28, 2003
+# Whom: Lasse L. Johnsen (lasse@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= imapproxy
+PORTVERSION= 1.0
+CATEGORIES= net
+MASTER_SITES= http://www.freebsdcluster.org/~lasse/software/ \
+ ${MASTER_SITE_LOCAL}
+
+MAINTAINER= lasse@freebsdcluster.org
+COMMENT= ImapProxy is a caching IMAP proxy daemon to be used with Horde/IMP
+
+GNU_CONFIGURE= yes
+HAS_CONFIGURE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/sbin
+ ${INSTALL_DATA} ${WRKSRC}/example.conf ${PREFIX}/etc/imapproxy.conf.dist
+
+.include <bsd.port.mk>
diff --git a/net/imapproxy/distinfo b/net/imapproxy/distinfo
new file mode 100644
index 000000000000..d732cbefa487
--- /dev/null
+++ b/net/imapproxy/distinfo
@@ -0,0 +1 @@
+MD5 (imapproxy-1.0.tar.gz) = a25e4a15160e827537de867bb91fb51b
diff --git a/net/imapproxy/files/patch-aa b/net/imapproxy/files/patch-aa
new file mode 100644
index 000000000000..914e880afaf8
--- /dev/null
+++ b/net/imapproxy/files/patch-aa
@@ -0,0 +1,10 @@
+--- configfile.c.orig Fri Aug 9 15:24:23 2002
++++ configfile.c Mon Jul 28 11:22:34 2003
+@@ -23,6 +23,7 @@
+ #include <string.h>
+ #include <strings.h>
+ #include <stdlib.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/net/imapproxy/files/patch-ab b/net/imapproxy/files/patch-ab
new file mode 100644
index 000000000000..2e6d7ea56403
--- /dev/null
+++ b/net/imapproxy/files/patch-ab
@@ -0,0 +1,10 @@
+--- database.c.orig Fri Aug 9 15:24:23 2002
++++ database.c Mon Jul 28 11:22:10 2003
+@@ -24,6 +24,7 @@
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <errno.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+ #include <arpa/inet.h>
diff --git a/net/imapproxy/files/patch-ac b/net/imapproxy/files/patch-ac
new file mode 100644
index 000000000000..586bc3cff303
--- /dev/null
+++ b/net/imapproxy/files/patch-ac
@@ -0,0 +1,13 @@
+--- network.c.orig Fri Aug 9 15:24:23 2002
++++ network.c Mon Jul 28 11:21:26 2003
+@@ -20,9 +20,9 @@
+
+
+ #include <stdio.h>
++#include <sys/types.h>
+ #include <sys/socket.h>
+ #include <netinet/in.h>
+-#include <sys/types.h>
+ #include <string.h>
+ #include <netdb.h>
+ #include <unistd.h>
diff --git a/net/imapproxy/files/patch-ad b/net/imapproxy/files/patch-ad
new file mode 100644
index 000000000000..cc980901c78d
--- /dev/null
+++ b/net/imapproxy/files/patch-ad
@@ -0,0 +1,11 @@
+--- include/defines.h.orig Mon Jul 28 12:41:58 2003
++++ include/defines.h Mon Jul 28 12:42:27 2003
+@@ -45,7 +45,7 @@
+
+ #define DEFAULT_MAX_REUSE 0
+
+-#define DEFAULT_CONFIG_FILE ".imapproxy"
++#define DEFAULT_CONFIG_FILE "/usr/local/etc/imapproxy.conf"
+ #define VERSION "v0.9-3"
+ #define PROGNAME "ImapProxy"
+ #define AUTHOR "Steven Van Acker <imapproxy@kuleuven.net>"
diff --git a/net/imapproxy/pkg-descr b/net/imapproxy/pkg-descr
new file mode 100644
index 000000000000..0cbd2a3587a0
--- /dev/null
+++ b/net/imapproxy/pkg-descr
@@ -0,0 +1,10 @@
+The program forwards all IMAP traffic between the client and the server, but
+keeps the connection to the server alive after the client logs out. When the
+same user attempts to log in again, the proxy will use the cached
+username/password pair to authenticate the client, and tie the new client to
+the old server connection (which was kept alive).
+
+WWW: http://www.kuleuven.net/projects/imapproxy/
+
+ Lasse L. Johnsen
+ lasse@freebsdcluster.org
diff --git a/net/imapproxy/pkg-plist b/net/imapproxy/pkg-plist
new file mode 100644
index 000000000000..7ecbd260c97d
--- /dev/null
+++ b/net/imapproxy/pkg-plist
@@ -0,0 +1,2 @@
+sbin/imapproxy
+etc/imapproxy.conf.dist