aboutsummaryrefslogtreecommitdiff
path: root/net/intel-ix-kmod
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2022-06-23 21:31:37 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2022-06-23 21:31:37 +0000
commit2fd9ef9ddda7bd4bd351e2940a6614fdef26770c (patch)
tree71d5adbb9d941dcd425e11d63f3966908b546237 /net/intel-ix-kmod
parent2b2c9a4d2f0a015d1605184f3d4c715588f65296 (diff)
downloadports-2fd9ef9ddda7bd4bd351e2940a6614fdef26770c.tar.gz
ports-2fd9ef9ddda7bd4bd351e2940a6614fdef26770c.zip
Diffstat (limited to 'net/intel-ix-kmod')
-rw-r--r--net/intel-ix-kmod/Makefile1
-rw-r--r--net/intel-ix-kmod/files/patch-if__ix.c15
2 files changed, 16 insertions, 0 deletions
diff --git a/net/intel-ix-kmod/Makefile b/net/intel-ix-kmod/Makefile
index 2995c68ea9e7..d3bb5edf94dc 100644
--- a/net/intel-ix-kmod/Makefile
+++ b/net/intel-ix-kmod/Makefile
@@ -21,6 +21,7 @@ MANPAGELINKS= ix if_ix if_ixgbe
MAX_NETMAP_OSVERSION= 9999999
MASTERDIR= ${.CURDIR}/../intel-ixl-kmod
+PATCHDIR= ${.CURDIR}/files
PKGDIR= ${.CURDIR}
DISTINFO_FILE= ${.CURDIR}/distinfo
diff --git a/net/intel-ix-kmod/files/patch-if__ix.c b/net/intel-ix-kmod/files/patch-if__ix.c
new file mode 100644
index 000000000000..89b9ce285111
--- /dev/null
+++ b/net/intel-ix-kmod/files/patch-if__ix.c
@@ -0,0 +1,15 @@
+--- if_ix.c.orig 2022-05-13 22:10:39 UTC
++++ if_ix.c
+@@ -241,8 +241,12 @@ static driver_t ix_driver = {
+ "ix", ix_methods, sizeof(struct adapter),
+ };
+
++#if __FreeBSD_version >= 1400058
++DRIVER_MODULE(ix, pci, ix_driver, 0, 0);
++#else
+ devclass_t ix_devclass;
+ DRIVER_MODULE(ix, pci, ix_driver, ix_devclass, 0, 0);
++#endif
+
+ MODULE_DEPEND(ix, pci, 1, 1, 1);
+ MODULE_DEPEND(ix, ether, 1, 1, 1);