aboutsummaryrefslogtreecommitdiff
path: root/net/iodine
diff options
context:
space:
mode:
authorDavid Thiel <lx@FreeBSD.org>2010-02-16 21:34:26 +0000
committerDavid Thiel <lx@FreeBSD.org>2010-02-16 21:34:26 +0000
commit1ef9ab65a46f9ac3825eede4aca2b7990ffcdf0f (patch)
tree47b9cc1220eb97f1f1e50745d52790bcf9d16939 /net/iodine
parente6b7c82e601da99821096e27db46cb494c10b030 (diff)
Update to 0.6.0 RC1, which should resolve problems setting up the tun interface.
PR: ports/141773 Feature safe: yes
Notes
Notes: svn path=/head/; revision=249974
Diffstat (limited to 'net/iodine')
-rw-r--r--net/iodine/Makefile3
-rw-r--r--net/iodine/distinfo6
-rw-r--r--net/iodine/files/patch-tun.c14
3 files changed, 5 insertions, 18 deletions
diff --git a/net/iodine/Makefile b/net/iodine/Makefile
index 326acb88f1b0..9c634c5151e7 100644
--- a/net/iodine/Makefile
+++ b/net/iodine/Makefile
@@ -6,10 +6,11 @@
#
PORTNAME= iodine
-PORTVERSION= 0.5.2
+PORTVERSION= 0.6.0r1
CATEGORIES= net
MASTER_SITES= http://code.kryo.se/iodine/ \
http://redundancy.redundancy.org/mirror/
+DISTNAME= ${PORTNAME}-0.6.0-rc1
MAINTAINER= lx@FreeBSD.org
COMMENT= Tunnel IPv4 data through a DNS server
diff --git a/net/iodine/distinfo b/net/iodine/distinfo
index 21d62e4a2226..32e3eb19a89b 100644
--- a/net/iodine/distinfo
+++ b/net/iodine/distinfo
@@ -1,3 +1,3 @@
-MD5 (iodine-0.5.2.tar.gz) = 6952343cc4614857f83dbb81247871e7
-SHA256 (iodine-0.5.2.tar.gz) = cbc14665d325634318ebd6f792f8dc2229101bd5a55232420570538612f6a5e4
-SIZE (iodine-0.5.2.tar.gz) = 50788
+MD5 (iodine-0.6.0-rc1.tar.gz) = a15bb4faba020d217016fde6e231074a
+SHA256 (iodine-0.6.0-rc1.tar.gz) = dacf950198b68fd1dae09fe980080155b0c75718f581c08e069eee0c1b6c5e60
+SIZE (iodine-0.6.0-rc1.tar.gz) = 89827
diff --git a/net/iodine/files/patch-tun.c b/net/iodine/files/patch-tun.c
deleted file mode 100644
index 3c25e722d8c8..000000000000
--- a/net/iodine/files/patch-tun.c
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/tun.c.orig 2009-12-10 20:26:35.000000000 -0800
-+++ src/tun.c 2009-12-10 20:26:46.000000000 -0800
-@@ -402,10 +402,9 @@
- }
- #ifndef WINDOWS32
- snprintf(cmdline, sizeof(cmdline),
-- "/sbin/ifconfig %s %s %s netmask %s",
-+ "/sbin/ifconfig %s %s netmask %s",
- if_name,
- ip,
-- ip,
- inet_ntoa(net));
-
- fprintf(stderr, "Setting IP of %s to %s\n", if_name, ip);