aboutsummaryrefslogtreecommitdiff
path: root/net/iodine
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-02-24 07:52:26 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-02-24 07:52:26 +0000
commit53d45bdeefb15eae73a7f4076fc81e08561e98e9 (patch)
tree21d2db0a564aee32d0a29276cd6fd93ac67e8a70 /net/iodine
parent130ca1e42aef3dac842c7a85ce6a8cbbee33a8c5 (diff)
downloadports-53d45bdeefb15eae73a7f4076fc81e08561e98e9.tar.gz
ports-53d45bdeefb15eae73a7f4076fc81e08561e98e9.zip
Notes
Diffstat (limited to 'net/iodine')
-rw-r--r--net/iodine/Makefile36
-rw-r--r--net/iodine/distinfo3
-rw-r--r--net/iodine/pkg-descr5
-rw-r--r--net/iodine/pkg-message19
4 files changed, 63 insertions, 0 deletions
diff --git a/net/iodine/Makefile b/net/iodine/Makefile
new file mode 100644
index 000000000000..82d4ae8cb8a0
--- /dev/null
+++ b/net/iodine/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: iodine
+# Date created: Feb 15 2006
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iodine
+PORTVERSION= 0.3.4
+CATEGORIES= net
+MASTER_SITES= http://code.kryo.se/iodine/
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Tunnel IPv4 data through a DNS server
+
+PLIST_FILES= bin/iodine sbin/iodined
+
+PORTDOCS= CHANGELOG README TODO
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's,^CC =,CC ?=,' -e 's,^CFLAGS =,CFLAGS +=,' \
+ ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iodine ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/iodined ${PREFIX}/sbin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/iodine/distinfo b/net/iodine/distinfo
new file mode 100644
index 000000000000..e0ca2204ae2f
--- /dev/null
+++ b/net/iodine/distinfo
@@ -0,0 +1,3 @@
+MD5 (iodine-0.3.4.tar.gz) = dfbc5037fe0229e15f6f15775117aef5
+SHA256 (iodine-0.3.4.tar.gz) = 08a60f1dde655e37e136a498f73abcf25562239b02aa7c272c3cceb34ca2a5d5
+SIZE (iodine-0.3.4.tar.gz) = 14207
diff --git a/net/iodine/pkg-descr b/net/iodine/pkg-descr
new file mode 100644
index 000000000000..e82af63f2062
--- /dev/null
+++ b/net/iodine/pkg-descr
@@ -0,0 +1,5 @@
+This is a piece of software that lets you tunnel IPv4 data through a DNS
+server. This can be usable in different situations where Internet access is
+firewalled, but DNS queries are allowed.
+
+WWW: http://code.kryo.se/iodine/
diff --git a/net/iodine/pkg-message b/net/iodine/pkg-message
new file mode 100644
index 000000000000..4d92bce671bc
--- /dev/null
+++ b/net/iodine/pkg-message
@@ -0,0 +1,19 @@
+
+=== Quick Start ===
+
+Server:
+
+iodined -f -u nobody 10.0.0.1 tunnelhost.example.net
+
+Client:
+
+iodine -f -u nobody 192.168.1.1 tunnelhost.example.net
+
+You need add these lines to the DNS zone file:
+
+tunnelhost IN A 192.168.1.1
+tunnel IN NS tunnelhost.example.net
+
+The server side of the tunnel is 10.0.0.1.
+
+Please check README for details.