aboutsummaryrefslogtreecommitdiff
path: root/net/ipcheck/Makefile
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-03-24 18:49:56 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2001-03-24 18:49:56 +0000
commit0615217f490666582212aaaf8212ac2894f53582 (patch)
treef9b6cd59021ab492134702ad6272fdf55e73f486 /net/ipcheck/Makefile
parenta695ad456a0a38d79fba187ba0bd4a4be012b5f3 (diff)
downloadports-0615217f490666582212aaaf8212ac2894f53582.tar.gz
ports-0615217f490666582212aaaf8212ac2894f53582.zip
Notes
Diffstat (limited to 'net/ipcheck/Makefile')
-rw-r--r--net/ipcheck/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/net/ipcheck/Makefile b/net/ipcheck/Makefile
new file mode 100644
index 000000000000..387133f92765
--- /dev/null
+++ b/net/ipcheck/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: ipcheck
+# Date created: 24 Mar 2001
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipcheck
+PORTVERSION= 0.85
+CATEGORIES= net
+MASTER_SITES= http://ipcheck.sourceforge.net/
+DISTNAME= ipcheck.py
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= python:${PORTSDIR}/lang/python
+
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+do-patch:
+ @${SED} -e "s!/usr/bin/python!${LOCALBASE}/bin/python!" \
+ -e "s!ppp0!tun0!" \
+ ${DISTDIR}/${DISTNAME} > ${WRKDIR}/${DISTNAME}
+
+do-install:
+ @${INSTALL_SCRIPT} ${WRKDIR}/${DISTNAME} ${PREFIX}/bin
+
+.include <bsd.port.mk>