aboutsummaryrefslogtreecommitdiff
path: root/net/ipdecap
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2018-10-14 19:00:04 +0000
committerSteve Wills <swills@FreeBSD.org>2018-10-14 19:00:04 +0000
commit24da00280428c3a9107649a99ecd1444a0928322 (patch)
treefb46b211b7ec660db52144ee56765b323d39c8f4 /net/ipdecap
parent5a9c01db672ca09d37c82385946ac0f19313db71 (diff)
downloadports-24da00280428c3a9107649a99ecd1444a0928322.tar.gz
ports-24da00280428c3a9107649a99ecd1444a0928322.zip
Notes
Diffstat (limited to 'net/ipdecap')
-rw-r--r--net/ipdecap/Makefile7
-rw-r--r--net/ipdecap/distinfo6
-rw-r--r--net/ipdecap/files/patch-src_esp.c10
-rw-r--r--net/ipdecap/files/patch-src_esp.h11
-rw-r--r--net/ipdecap/files/patch-src_ipdecap.c18
-rw-r--r--net/ipdecap/files/patch-src_utils.c10
6 files changed, 56 insertions, 6 deletions
diff --git a/net/ipdecap/Makefile b/net/ipdecap/Makefile
index 63aac9652c26..709b69691b37 100644
--- a/net/ipdecap/Makefile
+++ b/net/ipdecap/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= ipdecap
-PORTVERSION= 0.7.1
+PORTVERSION= 0.7.2
DISTVERSIONPREFIX= v
PORTREVISION= 1
CATEGORIES= net
@@ -13,12 +13,13 @@ LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/pcap/vlan.h:net/libpcap
-LIB_DEPENDS= libpcap.so.1:net/libpcap # require ports libpcap
+LIB_DEPENDS= libpcap.so:net/libpcap # require ports libpcap
+USES= autoreconf gmake ssl
USE_GITHUB= yes
+
GH_ACCOUNT= lpefferkorn
-USES= autoreconf gmake ssl
GNU_CONFIGURE= yes
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
diff --git a/net/ipdecap/distinfo b/net/ipdecap/distinfo
index 13c689150efb..f72d1a5567a2 100644
--- a/net/ipdecap/distinfo
+++ b/net/ipdecap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464781704
-SHA256 (lpefferkorn-ipdecap-v0.7.1_GH0.tar.gz) = a1a18a799867ea9931fac5d9b54f1ed79d15f1b12989758584ee48187847bd6b
-SIZE (lpefferkorn-ipdecap-v0.7.1_GH0.tar.gz) = 818778
+TIMESTAMP = 1539426959
+SHA256 (lpefferkorn-ipdecap-v0.7.2_GH0.tar.gz) = 39e24c0ee343be485feb5d03114510c96eda24092c4908968e50fe7c50165bde
+SIZE (lpefferkorn-ipdecap-v0.7.2_GH0.tar.gz) = 825828
diff --git a/net/ipdecap/files/patch-src_esp.c b/net/ipdecap/files/patch-src_esp.c
new file mode 100644
index 000000000000..11f4a1af32b5
--- /dev/null
+++ b/net/ipdecap/files/patch-src_esp.c
@@ -0,0 +1,10 @@
+--- src/esp.c.orig 2018-07-19 13:30:02 UTC
++++ src/esp.c
+@@ -21,6 +21,7 @@
+ #include <arpa/inet.h> // for inet_ntop, inet_pton
+ #include <err.h> // for err
+ #include <errno.h> // for __errno_location, errno, ERANGE
++#include <sys/types.h> // for u_char
+ #include <net/ethernet.h> // for ether_header
+ #include <netinet/ip.h> // for ip
+ #include <stdio.h> // for printf, fclose, fgets, fopen, FILE
diff --git a/net/ipdecap/files/patch-src_esp.h b/net/ipdecap/files/patch-src_esp.h
new file mode 100644
index 000000000000..9621ac418314
--- /dev/null
+++ b/net/ipdecap/files/patch-src_esp.h
@@ -0,0 +1,11 @@
+--- src/esp.h.orig 2018-07-19 13:30:02 UTC
++++ src/esp.h
+@@ -19,6 +19,8 @@
+ */
+
+ #include <stdint.h>
++#include <sys/socket.h>
++#include <netinet/in.h>
+ #include <openssl/evp.h>
+ #include "utils.h"
+ #pragma once
diff --git a/net/ipdecap/files/patch-src_ipdecap.c b/net/ipdecap/files/patch-src_ipdecap.c
new file mode 100644
index 000000000000..3890b0c57248
--- /dev/null
+++ b/net/ipdecap/files/patch-src_ipdecap.c
@@ -0,0 +1,18 @@
+--- src/ipdecap.c.orig 2018-07-19 13:30:02 UTC
++++ src/ipdecap.c
+@@ -20,6 +20,7 @@
+
+ #include <err.h> // for warnx
+ #include <getopt.h> // for getopt_long, optarg, required_argument
++#include <sys/types.h> // for u_char, u_int16_t
+ #include <net/ethernet.h> // for ether_header, ether_addr, ETHERTYPE_IP
+ #include <netinet/in.h> // for ntohs, htons, IPPROTO_ESP, IPPROTO_GRE
+ #include <netinet/ip.h> // for ip
+@@ -31,7 +32,6 @@
+ #include <stdio.h> // for NULL, printf
+ #include <stdlib.h> // for free, exit, EXIT_FAILURE, EXIT_SUCCESS
+ #include <string.h> // for memcpy, memset, strcmp
+-#include <sys/types.h> // for u_char, u_int16_t
+ #include "esp.h" // for flows_cleanup, parse_esp_conf, print_algor...
+ #include "gre.h" // for grehdr, GRE_CHECKSUM, GRE_KEY, GRE_ROUTING
+ #include "config.h"
diff --git a/net/ipdecap/files/patch-src_utils.c b/net/ipdecap/files/patch-src_utils.c
new file mode 100644
index 000000000000..860c0c88194a
--- /dev/null
+++ b/net/ipdecap/files/patch-src_utils.c
@@ -0,0 +1,10 @@
+--- src/utils.c.orig 2018-07-19 13:30:02 UTC
++++ src/utils.c
+@@ -19,6 +19,7 @@
+ */
+
+ #include "utils.h"
++#include <sys/types.h>
+ #include <net/ethernet.h> // for ETHER_ADDR_LEN
+ #include <stdarg.h> // for va_list
+ #include <stdio.h> // for printf, NULL, vfprintf, stdout