aboutsummaryrefslogtreecommitdiff
path: root/net/ipsorc/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 20:05:26 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-12-08 20:05:26 +0000
commit3a887ab7f2edebfceafc319aa17086f12ee2d9e4 (patch)
tree7dbc627bce2d3301fceb71c18098aa5285869dc4 /net/ipsorc/Makefile
parente022cdbdc5c121996a5fc09a6b1392cbac8c1297 (diff)
downloadports-3a887ab7f2edebfceafc319aa17086f12ee2d9e4.tar.gz
ports-3a887ab7f2edebfceafc319aa17086f12ee2d9e4.zip
Notes
Diffstat (limited to 'net/ipsorc/Makefile')
-rw-r--r--net/ipsorc/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net/ipsorc/Makefile b/net/ipsorc/Makefile
new file mode 100644
index 000000000000..850af7918233
--- /dev/null
+++ b/net/ipsorc/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: ipsorc
+# Date created: 02 December, 2001
+# Whom: Nicolas.Jombart@hsc-labs.com
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipsorc
+PORTVERSION= 1.4
+CATEGORIES= net security
+MASTER_SITES= http://www.legions.org/~phric/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= Nicolas.Jombart@hsc-labs.com
+
+USE_GTK= yes
+
+post-patch:
+ @${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.old
+ @${SED} s,gtk-config,${GTK_CONFIG}, < ${WRKSRC}/Makefile.old \
+ > ${WRKSRC}/Makefile
+ @${RM} ${WRKSRC}/Makefile.old
+
+do-install:
+.for file in ipmagic magic
+ ${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in README
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>