aboutsummaryrefslogtreecommitdiff
path: root/net/ipvs/Makefile
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-08-24 19:55:33 +0000
committerClement Laforet <clement@FreeBSD.org>2005-08-24 19:55:33 +0000
commit376b321e6924572660031caef1d4d23768c446aa (patch)
tree13a2c5b7a91e3f47cd96dcc1cf79ee888ca107a1 /net/ipvs/Makefile
parent7659a915b87d1ca6d4f3f0cd73c7580a6b4959d0 (diff)
downloadports-376b321e6924572660031caef1d4d23768c446aa.tar.gz
ports-376b321e6924572660031caef1d4d23768c446aa.zip
Notes
Diffstat (limited to 'net/ipvs/Makefile')
-rw-r--r--net/ipvs/Makefile27
1 files changed, 15 insertions, 12 deletions
diff --git a/net/ipvs/Makefile b/net/ipvs/Makefile
index ca018ef7f31c..c734bf317781 100644
--- a/net/ipvs/Makefile
+++ b/net/ipvs/Makefile
@@ -7,14 +7,15 @@
PORTNAME= ipvs
PORTVERSION= 0.4.0
+PORTREVISION= 1
CATEGORIES= net
-MASTER_SITES= http://dragon.linux-vs.org/~dragonfly/software/
-DISTNAME= ipvs_freebsd-${PORTVERSION}
+MASTER_SITES= http://www.cultdeadsheep.org/~clement/FreeBSD/ipvs/
+DISTNAME= ipvs-${PORTVERSION}_${PORTREVISION}
MAINTAINER= clement@FreeBSD.org
COMMENT= FreeBSD port of Linux Virtual Server
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+#WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
SRCDIR?= /usr/src
MAN8= ipvsadm.8 ipvsadm-restore.8 ipvsadm-save.8
@@ -37,26 +38,28 @@ pre-everything::
.if !defined(SYSTEM_PATCHED)
-.if ${OSVERSION} < 503001 || ${OSVERSION} > 600000 || defined(PACKAGE_BUILDING)
+.if ${OSVERSION} < 503001 || defined(PACKAGE_BUILDING)
IGNORE= Does not compile. If your system is patched to support ipvs, please\
define SYSTEM_PATCHED
.elif ${OSVERSION} == 503001
-FREEBSD_VERSION= 5.4
+FREEBSD_VERSION= 5.3-RELEASE
.elif (${OSVERSION} == 504000 || defined(TRY_STABLE))
-FREEBSD_VERSION= 5.4
+FREEBSD_VERSION= 5.4-RELEASE
+.elif (${OSVERSION} >= 600029 || defined(TRY_STABLE6))
+FREEBSD_VERSION= 6.0-RELEASE
+.elif (${OSVERSION} >= 700000 || defined(TRY_CURRENT))
+FREEBSD_VERSION= 7.0-CURRENT
.else
-IGNORE= is designed for 5.3-RELEASE and 5.4-RELEASE, define TRY_STABLE\
- to test it on 5-STABLE
+IGNORE= is designed orginally for 5.3-RELEASE and 5.4-RELEASE, define TRY_STABLE\
+ to test it on 5-STABLE, TRY_STABLE6 on 6-STABLE or TRY_CURRENT\
+ on 7.0-CURRENT
.endif
.endif
ONLY_FOR_ARCHS= i386
patch-system: extract
- @${FIND} ${WRKSRC}/patch/${FREEBSD_VERSION}-RELEASE -type f \
+ @${FIND} ${WRKSRC}/patch/${FREEBSD_VERSION} -type f \
-name "*.patch" -exec ${PATCH} -p0 -d ${SRCDIR} -i {} \;
-post-patch:
- @${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}
-
.include <bsd.port.post.mk>