aboutsummaryrefslogtreecommitdiff
path: root/net/ipvs
diff options
context:
space:
mode:
authorClement Laforet <clement@FreeBSD.org>2005-06-12 19:10:18 +0000
committerClement Laforet <clement@FreeBSD.org>2005-06-12 19:10:18 +0000
commit6c3a9a104d408b40a996a23ebce314bdb10927c9 (patch)
tree7712f1c40a3355a3ff8e83485e725bcd3aee0e1a /net/ipvs
parent90eb5eb18294525b9c0f056af6955431e5adbb87 (diff)
downloadports-6c3a9a104d408b40a996a23ebce314bdb10927c9.tar.gz
ports-6c3a9a104d408b40a996a23ebce314bdb10927c9.zip
Notes
Diffstat (limited to 'net/ipvs')
-rw-r--r--net/ipvs/Makefile35
1 files changed, 21 insertions, 14 deletions
diff --git a/net/ipvs/Makefile b/net/ipvs/Makefile
index 515e12dcec3b..ca018ef7f31c 100644
--- a/net/ipvs/Makefile
+++ b/net/ipvs/Makefile
@@ -22,20 +22,6 @@ MAKE_ENV+= MKDIR="${MKDIR}" KMODDIR="/boot/modules"
.include <bsd.port.pre.mk>
-ONLY_FOR_ARCHS= i386
-
-.if ${OSVERSION} == 503001
-FREEBSD_VERSION= 5.3
-.elif (${OSVERSION} == 504000 || defined(TRY_STABLE)) && !defined(PACKAGE_BUILDING)
-FREEBSD_VERSION= 5.4
-.else
-IGNORE= : You need a patched 5.3-RELEASE of 5.4-RELEASE src tree in ${SRCDIR}
-.endif
-
-patch-system: extract
- @${FIND} ${WRKSRC}/patch/${FREEBSD_VERSION}-RELEASE -type f \
- -name "*.patch" -exec ${PATCH} -p0 -d ${SRCDIR} -i {} \;
-
pre-everything::
@${ECHO_CMD} "LVS on FreeBSD works only with 5.3-RELEASE and 5.4-RELEASE."
@${ECHO_CMD} "However it may work on 5-STABLE. If you are running FreeBSD 5.4-STABLE, define"
@@ -49,6 +35,27 @@ pre-everything::
@${ECHO_CMD} " 5. install the port"
@${ECHO_CMD} " 6. reboot your system"
+
+.if !defined(SYSTEM_PATCHED)
+.if ${OSVERSION} < 503001 || ${OSVERSION} > 600000 || defined(PACKAGE_BUILDING)
+IGNORE= Does not compile. If your system is patched to support ipvs, please\
+ define SYSTEM_PATCHED
+.elif ${OSVERSION} == 503001
+FREEBSD_VERSION= 5.4
+.elif (${OSVERSION} == 504000 || defined(TRY_STABLE))
+FREEBSD_VERSION= 5.4
+.else
+IGNORE= is designed for 5.3-RELEASE and 5.4-RELEASE, define TRY_STABLE\
+ to test it on 5-STABLE
+.endif
+.endif
+
+ONLY_FOR_ARCHS= i386
+
+patch-system: extract
+ @${FIND} ${WRKSRC}/patch/${FREEBSD_VERSION}-RELEASE -type f \
+ -name "*.patch" -exec ${PATCH} -p0 -d ${SRCDIR} -i {} \;
+
post-patch:
@${INSTALL_DATA} ${FILESDIR}/Makefile ${WRKSRC}