aboutsummaryrefslogtreecommitdiff
path: root/net/ipw-firmware-kmod/Makefile
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2007-01-31 19:45:07 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2007-01-31 19:45:07 +0000
commitff2df759b3a1d58c1bf969b5d0a8415834605d88 (patch)
tree0789371fb40116eec3588ea2944f0e5476b7038a /net/ipw-firmware-kmod/Makefile
parentf491bb18148b7ceff8eb05b20ca87ff3858b861a (diff)
downloadports-ff2df759b3a1d58c1bf969b5d0a8415834605d88.tar.gz
ports-ff2df759b3a1d58c1bf969b5d0a8415834605d88.zip
Notes
Diffstat (limited to 'net/ipw-firmware-kmod/Makefile')
-rw-r--r--net/ipw-firmware-kmod/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/net/ipw-firmware-kmod/Makefile b/net/ipw-firmware-kmod/Makefile
index 6c53a4d71d5b..61ab2825ab53 100644
--- a/net/ipw-firmware-kmod/Makefile
+++ b/net/ipw-firmware-kmod/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ipw-firmware
PORTVERSION= ${FWVERSION}
-PORTREVISION?= 1
+PORTREVISION?= 2
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= flz/ipw
@@ -29,13 +29,12 @@ KMODDIR= /boot/modules
KMODVERSION= ${FWVERSION:C/^(...)$/\1.0/:S/.//g}
PLIST_SUB= DRIVERNAME="${DRIVERNAME}" \
KMODDIR="${KMODDIR}"
-MAKE_ENV= KMODDIR="${KMODDIR}"
CFLAGS+= -D_KERNEL
NO_PACKAGE= "this is a modified version of a restricted firmware"
MIN6OSVERSION?= 999999
-MIN7OSVERSION?= 999999
+MIN7OSVERSION?= 700015
.include <bsd.port.pre.mk>
@@ -56,12 +55,12 @@ post-patch:
do-build:
.for i in ${FIRMWARES}
- @cd ${WRKSRC}/${i:C/.*://}; make all ${MAKE_ENV}
+ @cd ${WRKSRC}/${i:C/.*://}; ${SETENV} KMODDIR="${KMODDIR}" make all
.endfor
do-install:
.for i in ${FIRMWARES}
- @cd ${WRKSRC}/${i:C/.*://}; make install ${MAKE_ENV}
+ @cd ${WRKSRC}/${i:C/.*://}; ${SETENV} KMODDIR="${KMODDIR}" make install
.endfor
.include <bsd.port.post.mk>