aboutsummaryrefslogtreecommitdiff
path: root/net/ipw-firmware
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2006-06-01 18:20:15 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2006-06-01 18:20:15 +0000
commit06036293beb01a6815331f2e108fe1b50d4335c9 (patch)
tree69ac19ad9bd08743fa89bcff682348667b9f6653 /net/ipw-firmware
parente80287dc934d1a1f528978a8a637218bf159920c (diff)
downloadports-06036293beb01a6815331f2e108fe1b50d4335c9.tar.gz
ports-06036293beb01a6815331f2e108fe1b50d4335c9.zip
Notes
Diffstat (limited to 'net/ipw-firmware')
-rw-r--r--net/ipw-firmware/Makefile22
1 files changed, 17 insertions, 5 deletions
diff --git a/net/ipw-firmware/Makefile b/net/ipw-firmware/Makefile
index d36e6a92ae07..af40d0c99487 100644
--- a/net/ipw-firmware/Makefile
+++ b/net/ipw-firmware/Makefile
@@ -25,8 +25,23 @@ FIRMWARES?= ${RELNAME}-${PORTVERSION}-i.fw:${DRIVERNAME}-i.fw \
${RELNAME}-${PORTVERSION}-p.fw:${DRIVERNAME}-p.fw \
${RELNAME}-${PORTVERSION}.fw:${DRIVERNAME}.fw
-OPTIONS= MODULE "Install ${DRIVERNAME}(4) kernel module (very old snapshot)" off \
- CONTROL "Install ${DRIVERNAME}control(8) utility" on
+OSVERSION!= /sbin/sysctl -n kern.osreldate
+
+# Dummy OSVERSION for ipw.
+MIN7OSVERSION?= 999999
+
+# Try to guess sensible defaults.
+.if ${OSVERSION} > ${MIN7OSVERSION}
+OPTIONS+= CONTROL "Install ${DRIVERNAME}control(8) utility" off
+.else
+OPTIONS+= CONTROL "Install ${DRIVERNAME}control(8) utility" on
+.endif
+
+.if ${OSVERSION} > 600023
+OPTIONS+= MODULE "Install ${DRIVERNAME}(4) kernel module (very old snapshot)" off
+.else
+OPTIONS+= MODULE "Install ${DRIVERNAME}(4) kernel module (very old snapshot)" on
+.endif
# Override PREFIX to install ${DRIVERNAME}control(8) somewhere we hope it'll
# be available soon enough.
@@ -48,9 +63,6 @@ MAKE_ENV= BINDIR="${PREFIX}/sbin" \
MANCOMPRESSED= yes
-# Dummy OSVERSION for ipw.
-MIN7OSVERSION?= 999999
-
.if !defined(PACKAGE_BUILDING)
IS_INTERACTIVE= yes
.endif