aboutsummaryrefslogtreecommitdiff
path: root/net/ipw-firmware
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2005-06-11 22:12:32 +0000
committerFlorent Thoumie <flz@FreeBSD.org>2005-06-11 22:12:32 +0000
commitf4698edf13dc7db5758babdbdda89371700d48b8 (patch)
treecd31bba466b88dcd3d433b79ad7e07da27d5b5e9 /net/ipw-firmware
parente6ca7b011abf3ed9606c16a95783886e32a9ef76 (diff)
downloadports-f4698edf13dc7db5758babdbdda89371700d48b8.tar.gz
ports-f4698edf13dc7db5758babdbdda89371700d48b8.zip
Notes
Diffstat (limited to 'net/ipw-firmware')
-rw-r--r--net/ipw-firmware/Makefile28
-rw-r--r--net/ipw-firmware/distinfo8
-rw-r--r--net/ipw-firmware/pkg-plist4
3 files changed, 21 insertions, 19 deletions
diff --git a/net/ipw-firmware/Makefile b/net/ipw-firmware/Makefile
index 69bf48ac80da..a8558b0a2771 100644
--- a/net/ipw-firmware/Makefile
+++ b/net/ipw-firmware/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
#
-PORTNAME= ipw-firmware
-RELNAME= ipw2100
-PORTVERSION= 1.3
-PORTREVISION= 1
+PORTNAME?= ipw-firmware
+RELNAME?= ipw2100
+PORTVERSION?= 1.3
+PORTREVISION?= 1
CATEGORIES= net sysutils
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= flz/ipw
@@ -17,14 +17,16 @@ DISTFILES= ${RELNAME}-fw-${PORTVERSION}.tgz
MAINTAINER= flz@FreeBSD.org
COMMENT= Intel PRO/Wireless 2100 Driver Firmware
-DRIVERNAME= ipw
-DRIVERVERSION= 1.6.4
+DRIVERNAME?= ipw
+DRIVERVERSION?= 1.6.4
DRIVERDISTNAME= ${DRIVERNAME}-freebsd-${DRIVERVERSION}
DISTFILES+= ${DRIVERDISTNAME}.tgz
+FIRMWARES?= ${RELNAME}-${PORTVERSION}-i.fw ${RELNAME}-${PORTVERSION}-p.fw ${RELNAME}-${PORTVERSION}.fw
OPTIONS= MODULE "Install ${DRIVERNAME}(4) kernel module" off
WRKSRC= ${WRKDIR}
+KERNDIR= /boot/kernel
KMODDIR= /boot/modules
SUB_FILES= pkg-message
SUB_LIST= DRIVERNAME="${DRIVERNAME}" \
@@ -42,10 +44,10 @@ MANCOMPRESSED= yes
.include <bsd.port.pre.mk>
-# That's a bit arbitrary since I have no idea if ${DRIVERNAME}(4) can be compiled on FreeBSD
-# previous to 5.3-RELEASE. This is just too old, people should move on.
-# I may change this if I get successful reports though.
-# Comment this if you want to test it anyway.
+# That's a bit arbitrary since I have no idea if ${DRIVERNAME}(4) can be
+# compiled on FreeBSD previous to 5.3-RELEASE. This is just too old, people
+# should move on. I may change this if I get successful reports though.
+# Comment this IGNORE line if you want to test it anyway.
.if ${OSVERSION} < 503000
IGNORE= Need a fresh version of RELENG_5
.endif
@@ -58,12 +60,12 @@ PLIST_SUB+= WITH_MODULE=""
MAN4+= ${DRIVERNAME}.4
. endif
.else
-PLIST_SUB+= WITH_MODULE="@comment "
+PLIST_SUB+= WITH_MODULE="@comment MODULE "
.endif
# "Might" because people still can include ${DRIVERNAME}(4) support in kernel by extracting
# its source in src/ and tweaking src/sys/conf/files.
-.if ${OSVERSION} <= 600023 && !exists(${KMODDIR}/if_${DRIVERNAME}.ko) && !defined(WITH_MODULE)
+.if ${OSVERSION} <= 600023 && !exists(${KERNDIR}/if_${DRIVERNAME}.ko) && !defined(WITH_MODULE)
SUB_LIST+= MIGHT_NEED_MODULE=""
.else
SUB_LIST+= MIGHT_NEED_MODULE="@comment "
@@ -88,7 +90,7 @@ do-install:
.else
cd ${WRKSRC}/${DRIVERDISTNAME}/src/usr.sbin/${DRIVERNAME}control/; make install ${MAKE_ENV}
.endif
-.for i in LICENSE ${RELNAME}-${PORTVERSION}-i.fw ${RELNAME}-${PORTVERSION}-p.fw ${RELNAME}-${PORTVERSION}.fw
+.for i in LICENSE ${FIRMWARES}
${INSTALL_DATA} ${WRKSRC}/$i ${DATADIR}/
.endfor
diff --git a/net/ipw-firmware/distinfo b/net/ipw-firmware/distinfo
index 2ed34c538801..089c4a05f304 100644
--- a/net/ipw-firmware/distinfo
+++ b/net/ipw-firmware/distinfo
@@ -1,4 +1,4 @@
-MD5 (ipw2100-fw-1.3.tgz) = 46aa75bcda1a00efa841f9707bbbd113
-SIZE (ipw2100-fw-1.3.tgz) = 248471
-MD5 (ipw-freebsd-1.6.4.tgz) = 4af640b3fe9035884dd03cbd2e8b1c27
-SIZE (ipw-freebsd-1.6.4.tgz) = 23051
+MD5 (ipw2200-fw-2.3.tgz) = 487ba63b1bf98bc1e38059b6d3abea44
+SIZE (ipw2200-fw-2.3.tgz) = 267413
+MD5 (iwi-freebsd-1.3.4.tgz) = 037eceec361385cc8e0df42d6b9b9822
+SIZE (iwi-freebsd-1.3.4.tgz) = 22272
diff --git a/net/ipw-firmware/pkg-plist b/net/ipw-firmware/pkg-plist
index 10901beca8bd..5c82b5f813e2 100644
--- a/net/ipw-firmware/pkg-plist
+++ b/net/ipw-firmware/pkg-plist
@@ -4,5 +4,5 @@ sbin/%%DRIVERNAME%%control
%%DATADIR%%/%%RELNAME%%-%%PORTVERSION%%-p.fw
%%DATADIR%%/%%RELNAME%%-%%PORTVERSION%%.fw
@dirrm %%DATADIR%%
-%%WITH_MODULE%%@cwd %%KMODDIR%%
-%%WITH_MODULE%%if_%%DRIVERNAME%%.ko
+%%WITH_MODULE%%@cwd /
+%%WITH_MODULE%%%%KMODDIR%%/if_%%DRIVERNAME%%.ko